summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarc Schiffbauer <mschiff@gentoo.org>2023-06-03 14:41:12 +0300
committerMarc Schiffbauer <mschiff@gentoo.org>2023-06-03 14:43:00 +0300
commit5d08c4cb6dc345dc7e784027cb6a8dc4717cad76 (patch)
tree9df31696dc121a1c58aef1489dea3dcf244f0090
parentdev-python/etuples: enable py3.12 (diff)
downloadgentoo-5d08c4cb6dc345dc7e784027cb6a8dc4717cad76.tar.gz
gentoo-5d08c4cb6dc345dc7e784027cb6a8dc4717cad76.tar.bz2
gentoo-5d08c4cb6dc345dc7e784027cb6a8dc4717cad76.zip
sci-geosciences/opencpn: fix build deps
Closes: https://bugs.gentoo.org/862591 Closes: https://bugs.gentoo.org/846953 Bug: https://bugs.gentoo.org/907738 Signed-off-by: Marc Schiffbauer <mschiff@gentoo.org>
-rw-r--r--sci-geosciences/opencpn/opencpn-5.6.2-r2.ebuild7
-rw-r--r--sci-geosciences/opencpn/opencpn-5.6.2-r3.ebuild63
-rw-r--r--sci-geosciences/opencpn/opencpn-5.8.2-r2.ebuild67
3 files changed, 134 insertions, 3 deletions
diff --git a/sci-geosciences/opencpn/opencpn-5.6.2-r2.ebuild b/sci-geosciences/opencpn/opencpn-5.6.2-r2.ebuild
index 53ecdb5e91ac..884fa909efe4 100644
--- a/sci-geosciences/opencpn/opencpn-5.6.2-r2.ebuild
+++ b/sci-geosciences/opencpn/opencpn-5.6.2-r2.ebuild
@@ -18,7 +18,7 @@ S="${WORKDIR}/OpenCPN-Release_${PV}"
LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="doc lzma opengl"
+IUSE="doc lzma"
RDEPEND="
app-arch/bzip2
@@ -28,9 +28,10 @@ RDEPEND="
media-libs/portaudio
net-misc/curl
sys-libs/zlib
- opengl? ( virtual/opengl )
+ virtual/opengl
+ x11-base/xorg-proto
x11-libs/gtk+:3
- x11-libs/wxGTK:${WX_GTK_VER}=[opengl?,X]
+ x11-libs/wxGTK:${WX_GTK_VER}=[opengl,X]
"
DEPEND="${RDEPEND}"
BDEPEND="
diff --git a/sci-geosciences/opencpn/opencpn-5.6.2-r3.ebuild b/sci-geosciences/opencpn/opencpn-5.6.2-r3.ebuild
new file mode 100644
index 000000000000..cb75281d7cff
--- /dev/null
+++ b/sci-geosciences/opencpn/opencpn-5.6.2-r3.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+WX_GTK_VER="3.0-gtk3"
+inherit wxwidgets xdg cmake
+
+DOC_VERSION="4.8.2.0"
+
+DESCRIPTION="a free, open source software for marine navigation"
+HOMEPAGE="https://opencpn.org/"
+SRC_URI="
+ https://github.com/OpenCPN/OpenCPN/archive/refs/tags/Release_${PV}.tar.gz -> ${P}.tar.gz
+ doc? ( https://launchpad.net/~opencpn/+archive/ubuntu/${PN}/+files/${PN}-doc_${DOC_VERSION}.orig.tar.xz )"
+S="${WORKDIR}/OpenCPN-Release_${PV}"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc lzma"
+
+RDEPEND="
+ app-arch/bzip2
+ dev-libs/tinyxml
+ lzma? ( app-arch/xz-utils )
+ media-libs/freetype:2
+ media-libs/portaudio
+ net-misc/curl
+ sys-libs/zlib
+ virtual/libusb:1
+ virtual/opengl
+ x11-base/xorg-proto
+ x11-libs/gtk+:3
+ x11-libs/wxGTK:${WX_GTK_VER}=[opengl,X]
+ "
+DEPEND="${RDEPEND}"
+BDEPEND="
+ sys-devel/gettext
+ sys-apps/lsb-release
+ "
+
+src_configure() {
+ use doc && HTML_DOCS=( "${S}"/../${PN}/doc/. )
+
+ setup-wxwidgets
+ local mycmakeargs=(
+ -DUSE_S57=ON
+ -DUSE_GARMINHOST=ON
+ -DBUNDLE_GSHHS=CRUDE
+ -DBUNDLE_TCDATA=ON
+ )
+
+ cmake_src_configure
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+
+ if use doc; then
+ einfo "Documentation is available at file:///usr/share/doc/${PF}/html/help_en_US.html"
+ fi
+}
diff --git a/sci-geosciences/opencpn/opencpn-5.8.2-r2.ebuild b/sci-geosciences/opencpn/opencpn-5.8.2-r2.ebuild
new file mode 100644
index 000000000000..7d5e879a5b06
--- /dev/null
+++ b/sci-geosciences/opencpn/opencpn-5.8.2-r2.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+WX_GTK_VER="3.2-gtk3"
+inherit wxwidgets xdg cmake
+
+DOC_VERSION="4.8.2.0"
+
+DESCRIPTION="a free, open source software for marine navigation"
+HOMEPAGE="https://opencpn.org/"
+SRC_URI="
+ https://github.com/OpenCPN/OpenCPN/archive/refs/tags/Release_${PV}.tar.gz -> ${P}.tar.gz
+ doc? ( https://launchpad.net/~opencpn/+archive/ubuntu/${PN}/+files/${PN}-doc_${DOC_VERSION}.orig.tar.xz )"
+S="${WORKDIR}/OpenCPN-Release_${PV}"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc lzma"
+
+RDEPEND="
+ app-arch/bzip2
+ dev-libs/tinyxml
+ lzma? ( app-arch/xz-utils )
+ media-libs/freetype:2
+ media-libs/glew:0
+ media-libs/jasper
+ media-libs/portaudio
+ net-misc/curl
+ sys-libs/zlib
+ virtual/libusb:1
+ virtual/opengl
+ x11-base/xorg-proto
+ x11-libs/gtk+:3
+ x11-libs/wxGTK:${WX_GTK_VER}=[opengl,X]
+ "
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-cpp/gtest
+ dev-libs/rapidjson
+ sys-apps/lsb-release
+ sys-devel/gettext
+ "
+
+src_configure() {
+ use doc && HTML_DOCS=( "${S}"/../${PN}/doc/. )
+
+ setup-wxwidgets
+ local mycmakeargs=(
+ -DUSE_GARMINHOST=ON
+ )
+# -DUSE_S57=ON
+# -DBUNDLE_TCDATA=ON
+# -DBUNDLE_GSHHS=CRUDE
+
+ cmake_src_configure
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+
+ if use doc; then
+ einfo "Documentation is available at file:///usr/share/doc/${PF}/html/help_en_US.html"
+ fi
+}