summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Bauman <bman@gentoo.org>2019-08-10 10:51:42 -0400
committerAaron Bauman <bman@gentoo.org>2019-08-10 10:51:42 -0400
commit5d1627f8ef6acd6dab6b419acf80247e035c57bf (patch)
tree3721580ba18c58e7c5c688449e119c7255307061
parentnet-misc/dhcp: remove unused patch (diff)
downloadgentoo-5d1627f8.tar.gz
gentoo-5d1627f8.tar.bz2
gentoo-5d1627f8.zip
app-arch/unzip: remove vulnerable wrt bug #602048
* maintainer/project timeout Signed-off-by: Aaron Bauman <bman@gentoo.org>
-rw-r--r--app-arch/unzip/Manifest1
-rw-r--r--app-arch/unzip/unzip-6.0_p20.ebuild88
2 files changed, 0 insertions, 89 deletions
diff --git a/app-arch/unzip/Manifest b/app-arch/unzip/Manifest
index 23675a263bc6..c338085389aa 100644
--- a/app-arch/unzip/Manifest
+++ b/app-arch/unzip/Manifest
@@ -1,3 +1,2 @@
DIST unzip60.tar.gz 1376845 BLAKE2B 5016d300b4452018a391f4ebc03c6960c068df400a0407c0c60bd7bb5ec5012031f916d8b204a6149ba291c2c35beba40d9b43c76fc093026e79471329ab0e47 SHA512 0694e403ebc57b37218e00ec1a406cae5cc9c5b52b6798e0d4590840b6cdbf9ddc0d9471f67af783e960f8fa2e620394d51384257dca23d06bcd90224a80ce5d
-DIST unzip_6.0-20.debian.tar.xz 16680 BLAKE2B 17ce9234ac485eab4e5188b555af31dcb0db577b199e0c58991ba7211c4c80edce52b72e89cc4d82b000b70bed1ac90262c0972507f28f054af2cebd0ca33b48 SHA512 7212cb110291581c2e465dc8ea5130eabffc4e0369d6245e8c26fa9d350bed904847d6e1191afaaa2d3fc23bd05fda7da80439d0c06b88f5331b01c9eff97fbe
DIST unzip_6.0-21.debian.tar.xz 17740 BLAKE2B 098a84e5b05f819f9c8c6a6656fdb2359dfb5b93f63444e55347e0bef9735fa48bf1631a658a2cb6d0c604e7e740e47b57910d251b74e5df7c8b9468acfe55f4 SHA512 f7bce4156ac13c34da3f991df3ae88b0db99b0810c7f8904ea3ac666a4cb2788d7182056f2bbd82d7519d0e0ee31a10af47bee08f360ceb859e5fbfc6e15ef36
diff --git a/app-arch/unzip/unzip-6.0_p20.ebuild b/app-arch/unzip/unzip-6.0_p20.ebuild
deleted file mode 100644
index 65112b3cb15f..000000000000
--- a/app-arch/unzip/unzip-6.0_p20.ebuild
+++ /dev/null
@@ -1,88 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="5"
-
-inherit eutils toolchain-funcs flag-o-matic
-
-MY_PV="${PV//.}"
-MY_PV="${MY_PV%_p*}"
-MY_P="${PN}${MY_PV}"
-
-DESCRIPTION="unzipper for pkzip-compressed files"
-HOMEPAGE="http://www.info-zip.org/"
-SRC_URI="mirror://sourceforge/infozip/${MY_P}.tar.gz
- mirror://debian/pool/main/u/${PN}/${PN}_${PV/_p/-}.debian.tar.xz"
-
-LICENSE="Info-ZIP"
-SLOT="0"
-KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~amd64-fbsd ~x86-fbsd ~x86-linux"
-IUSE="bzip2 natspec unicode"
-
-DEPEND="bzip2? ( app-arch/bzip2 )
- natspec? ( dev-libs/libnatspec )"
-RDEPEND="${DEPEND}"
-
-S="${WORKDIR}/${MY_P}"
-
-src_prepare() {
- local deb="${WORKDIR}"/debian/patches
- rm \
- "${deb}"/series \
- "${deb}"/02-branding-patch-this-is-debian-unzip \
- || die
- epatch "${deb}"/*
-
- epatch "${FILESDIR}"/${PN}-6.0-no-exec-stack.patch
- use natspec && epatch "${FILESDIR}/${PN}-6.0-natspec.patch" #275244
- sed -i -r \
- -e '/^CFLAGS/d' \
- -e '/CFLAGS/s:-O[0-9]?:$(CFLAGS) $(CPPFLAGS):' \
- -e '/^STRIP/s:=.*:=true:' \
- -e "s:\<CC *= *\"?g?cc2?\"?\>:CC=\"$(tc-getCC)\":" \
- -e "s:\<LD *= *\"?(g?cc2?|ld)\"?\>:LD=\"$(tc-getCC)\":" \
- -e "s:\<AS *= *\"?(g?cc2?|as)\"?\>:AS=\"$(tc-getCC)\":" \
- -e 's:LF2 = -s:LF2 = :' \
- -e 's:LF = :LF = $(LDFLAGS) :' \
- -e 's:SL = :SL = $(LDFLAGS) :' \
- -e 's:FL = :FL = $(LDFLAGS) :' \
- -e "/^#L_BZ2/s:^$(use bzip2 && echo .)::" \
- -e 's:$(AS) :$(AS) $(ASFLAGS) :g' \
- unix/Makefile \
- || die "sed unix/Makefile failed"
-
- # Delete bundled code to make sure we don't use it.
- rm -r bzip2 || die
-
- epatch_user
-}
-
-src_configure() {
- case ${CHOST} in
- i?86*-*linux*) TARGET="linux_asm" ;;
- *linux*) TARGET="linux_noasm" ;;
- i?86*-*bsd* | \
- i?86*-dragonfly*) TARGET="freebsd" ;; # mislabelled bsd with x86 asm
- *bsd* | *dragonfly*) TARGET="bsd" ;;
- *-darwin*) TARGET="macosx" ;;
- *-cygwin*) TARGET="cygwin" ;;
- *) die "Unknown target; please update the ebuild to handle ${CHOST} " ;;
- esac
-
- [[ ${CHOST} == *linux* ]] && append-cppflags -DNO_LCHMOD
- use bzip2 && append-cppflags -DUSE_BZIP2
- use unicode && append-cppflags -DUNICODE_SUPPORT -DUNICODE_WCHAR -DUTF8_MAYBE_NATIVE
- append-cppflags -DLARGE_FILE_SUPPORT #281473
-}
-
-src_compile() {
- ASFLAGS="${ASFLAGS} $(get_abi_var CFLAGS)" \
- emake -f unix/Makefile ${TARGET}
-}
-
-src_install() {
- dobin unzip funzip unzipsfx unix/zipgrep
- dosym unzip /usr/bin/zipinfo
- doman man/*.1
- dodoc BUGS History* README ToDo WHERE
-}