summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2022-06-30 10:04:09 -0400
committerBrian Evans <grknight@gentoo.org>2022-06-30 10:04:32 -0400
commit5d307ddd727e8c573f8ff83683dabcdd2d151b58 (patch)
tree02eb2fe13fdcdc2fe6e7567eb0a6add95c5a38a6
parentdev-php/pecl-ssh2: Update live ebuild and add upstream metadata (diff)
downloadgentoo-5d307ddd727.tar.gz
gentoo-5d307ddd727.tar.bz2
gentoo-5d307ddd727.zip
dev-php/pecl-http: Version bump for 3.3.0
Signed-off-by: Brian Evans <grknight@gentoo.org>
-rw-r--r--dev-php/pecl-http/Manifest1
-rw-r--r--dev-php/pecl-http/metadata.xml3
-rw-r--r--dev-php/pecl-http/pecl-http-3.3.0.ebuild74
3 files changed, 78 insertions, 0 deletions
diff --git a/dev-php/pecl-http/Manifest b/dev-php/pecl-http/Manifest
index b019015d7974..199b3a293893 100644
--- a/dev-php/pecl-http/Manifest
+++ b/dev-php/pecl-http/Manifest
@@ -1,4 +1,5 @@
DIST pecl_http-3.2.4.tgz 220631 BLAKE2B 996236cf9dd2f7d9bfaf046306e99c3ccf778261df19df8fd828b5811798f784841d89a6890e7347bd20cc6da71c966ea3ac9b17bf058e0bb766db7e1a8a6c49 SHA512 59c41d57c94a6e50e2f0b261130a24791b2845246f783b55e7f644f9a897d3650da364c5b38a860761b4a23f9266ed05000d6348bae2a7941e59d6bf5fb61a9e
DIST pecl_http-3.2.5.tgz 220593 BLAKE2B 3dfeefa69b0566f15f1dda73e7e4da2723033424e704039fbb42177e4996b434ea3450e40aa16844fe52c9fabac96d16ba5154a0112f00ff3838cf7bde149938 SHA512 13e99cd567a708cba56150a2127d060cdc78f9f5908371e5fb5fb3f02f27f8aa1b48c5eb147f61e9b5c9d5f2c627049f846d810f0135072cc9e4cd967e2bfa1d
+DIST pecl_http-3.3.0.tgz 225653 BLAKE2B b8d3875b2716edda98a2f813e2f5947e65684da12be087b2ec51c405223574b2e44dee3ae0a653a538e9c3acafafcec1ff40778d45d8389b239a1ea4578c2831 SHA512 e774ba0514994f219cbd2d8bef872308be8617ea22894db72473042154842c62d918d4c0b87f8c592182fa81fd1487b672252d587857e1b306dce6d38e2f53fb
DIST pecl_http-4.2.1.tgz 224452 BLAKE2B 58d2e1159aa64b9893b2b8b67c8444801308084ac13a743760c25cb3d0456fb586f69dc6b9e77db53341e4e9e45ce68f954c47b4e2663afe86de67d63db5e8e2 SHA512 2ad7e57fae313a7b46ba88e528e124ac9d83804827131a6ef478ccf3cf5883dec2d928b8ceb377ee7f5947c76f24d640d77533a9946612419e526786a79877e6
DIST pecl_http-4.2.2.tgz 224436 BLAKE2B 26ef3bb38778f0374938ba3f3bddba37c3a2044c7b9ffe2aacbca2566251d26d37882bf66773b8ed62d46855e8f14ad9b577cdb1ef3db9eba9850c0b30e57284 SHA512 1203367d590c7d80ffe7a21e7ac352ba053e3daeb778bf99e08fc13582e665e1429f850e51e36304bdec15e6646b648f2c444b46fa263e5441d008ac41a00f4b
diff --git a/dev-php/pecl-http/metadata.xml b/dev-php/pecl-http/metadata.xml
index 222c77f3742a..dc824b3a1b7c 100644
--- a/dev-php/pecl-http/metadata.xml
+++ b/dev-php/pecl-http/metadata.xml
@@ -5,4 +5,7 @@
<email>php-bugs@gentoo.org</email>
<name>PHP</name>
</maintainer>
+ <upstream>
+ <remote-id type="github">m6w6/ext-http</remote-id>
+ </upstream>
</pkgmetadata>
diff --git a/dev-php/pecl-http/pecl-http-3.3.0.ebuild b/dev-php/pecl-http/pecl-http-3.3.0.ebuild
new file mode 100644
index 000000000000..be789fd1c79e
--- /dev/null
+++ b/dev-php/pecl-http/pecl-http-3.3.0.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+PHP_EXT_NAME="http"
+PHP_EXT_PECL_PKG="pecl_http"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+PHP_INI_NAME="50-http"
+
+USE_PHP="php7-4 php8-0 php8-1"
+
+inherit php-ext-pecl-r3
+
+USE_PHP="php7-4"
+
+KEYWORDS="~amd64 ~x86"
+
+DESCRIPTION="Extended HTTP Support for PHP"
+LICENSE="BSD-2 MIT"
+SLOT="7"
+IUSE="ssl curl_ssl_gnutls curl_ssl_nss +curl_ssl_openssl"
+
+# Patch gets cookies working with curl 7.77, but further interop work was done later
+# Just set min version for this short time to live branch
+COMMON_DEPEND="app-arch/brotli:=
+ dev-libs/libevent
+ dev-php/pecl-propro:7[php_targets_php7-4(-)?]
+ >=dev-php/pecl-raphf-2.0.1:7[php_targets_php7-4(-)?]
+ net-dns/libidn2
+ sys-libs/zlib
+ ssl? ( >=net-misc/curl-7.77[ssl,curl_ssl_gnutls(-)=,curl_ssl_nss(-)=,curl_ssl_openssl(-)=] )
+ !ssl? ( >=net-misc/curl-7.77[-ssl] )
+"
+DEPEND="php_targets_php7-4? ( ${COMMON_DEPEND} dev-lang/php:7.4[session(-),iconv(-)] )"
+RDEPEND="${DEPEND}
+ php_targets_php8-0? ( dev-php/pecl-http:8[php_targets_php8-0(-)] )
+ php_targets_php8-1? ( dev-php/pecl-http:8[php_targets_php8-1(-)] )"
+
+PHP_EXT_ECONF_ARGS=( --with-http --without-http-shared-deps
+ --without-http-libidn-dir --without-http-libicu-dir
+ --without-http-libidnkit2-dir --without-http-libidnkit-dir )
+
+src_prepare() {
+ if use php_targets_php7-4 ; then
+ php-ext-source-r3_src_prepare
+ else
+ default_src_prepare
+ fi
+}
+
+src_install() {
+ if use php_targets_php7-4 ; then
+ php-ext-pecl-r3_src_install
+ fi
+}
+
+src_test() {
+ # Cannot use eclass function due to required modules
+ # All tests SKIP otherwise
+ for slot in $(php_get_slots); do
+ php_init_slot_env "${slot}"
+ # Link in required modules for testing
+ ln -s "${EXT_DIR}/propro.so" "modules/propro.so" || die
+ ln -s "${EXT_DIR}/raphf.so" "modules/raphf.so" || die
+ sed -i \
+ 's/PHP_TEST_SHARED_EXTENSIONS)/PHP_TEST_SHARED_EXTENSIONS) -d extension=propro.so -d extension=raphf.so/' \
+ Makefile || die
+ SKIP_ONLINE_TESTS=yes NO_INTERACTION="yes" emake test
+ # Clean up testing links
+ rm modules/propro.so modules/raphf.so || die
+ done
+}