summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJouni Kosonen <jouni.kosonen@tukesoft.com>2021-09-29 03:32:15 +0300
committerJoonas Niilola <juippis@gentoo.org>2021-10-15 13:22:40 +0300
commit5d343fa737d419a3b205a870a5861acf3efa37de (patch)
treed34c5c9bf910b1fdcad9dc22481578af6782971a
parentdev-vcs/topgit: update EAPI 7 -> 8, add missing perl BDEPEND (diff)
downloadgentoo-5d343fa737d419a3b205a870a5861acf3efa37de.tar.gz
gentoo-5d343fa737d419a3b205a870a5861acf3efa37de.tar.bz2
gentoo-5d343fa737d419a3b205a870a5861acf3efa37de.zip
net-libs/czmq: bump to v4.2.1
- Put new automagic dev-libs/nss support behind USE=nss - Fix failing test in bug #756844 Closes: https://bugs.gentoo.org/756844 Signed-off-by: Jouni Kosonen <jouni.kosonen@tukesoft.com> Closes: https://github.com/gentoo/gentoo/pull/22438 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
-rw-r--r--net-libs/czmq/Manifest1
-rw-r--r--net-libs/czmq/czmq-4.2.1.ebuild52
-rw-r--r--net-libs/czmq/metadata.xml1
3 files changed, 54 insertions, 0 deletions
diff --git a/net-libs/czmq/Manifest b/net-libs/czmq/Manifest
index 7750e2635c95..8e879cecd352 100644
--- a/net-libs/czmq/Manifest
+++ b/net-libs/czmq/Manifest
@@ -1 +1,2 @@
DIST czmq-4.2.0.tar.gz 1522824 BLAKE2B 2b2ec308f37a122d5478f63ed029c5ac01d8da40e676e812ec321e039839c7d364fef3eef67df928e6514f0fd2cd65ae35ba89347ead2b44c610812a012364dd SHA512 a3716efbece193196355fb7055b7e81067d29551765de2533178804ca5d85f98cd8cd01f88b4eecbea905adf3b7513e3b8a7e78e350adf1a6e69edbea5f6260c
+DIST czmq-4.2.1.tar.gz 1617066 BLAKE2B 5b635ccd7e85f05cd4f81f1ddaef80f7478feccfb916b1a7317f539354d0a4dabb7bf14a9dbee4dae3f6fbfcaf402c51ee9ba9810d952fc837c03c14304d4dab SHA512 776c524ffeba3dbe2534351f91623a6f9db31268aa2e794e29b7eca99c9fd0a726de0f7fba4376a5b3d7321b1033314e86644efaa5a9c7226fc1f06805f7aa9f
diff --git a/net-libs/czmq/czmq-4.2.1.ebuild b/net-libs/czmq/czmq-4.2.1.ebuild
new file mode 100644
index 000000000000..f678661d9120
--- /dev/null
+++ b/net-libs/czmq/czmq-4.2.1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+DESCRIPTION="High-level C Binding for ZeroMQ"
+HOMEPAGE="http://czmq.zeromq.org"
+SRC_URI="https://github.com/zeromq/${PN}/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="MPL-2.0"
+SLOT="0/4"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~x86"
+IUSE="curl drafts http-client http-server lz4 nss static-libs systemd +uuid"
+
+BDEPEND="app-text/asciidoc
+ app-text/xmlto
+ virtual/pkgconfig"
+
+RDEPEND=">=net-libs/zeromq-4:=[drafts?]
+ http-client? ( net-misc/curl )
+ http-server? ( net-libs/libmicrohttpd:= )
+ lz4? ( app-arch/lz4:= )
+ nss? ( dev-libs/nss:= )
+ systemd? ( sys-apps/systemd )
+ uuid? ( sys-apps/util-linux:0= )"
+
+DEPEND="${RDEPEND}"
+
+DOCS=( AUTHORS NEWS README.md )
+
+src_configure() {
+ local myeconfargs=(
+ --enable-drafts=$(usex drafts)
+ --with-docs=no
+ --with-uuid=$(usex uuid)
+ --with-libcurl=$(usex http-client)
+ --with-libmicrohttpd=$(usex http-server)
+ --with-libsystemd=$(usex systemd)
+ --with-liblz4=$(usex lz4)
+ --with-nss=$(usex nss)
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+
+ if ! use static-libs ; then
+ find "${ED}" -type f \( -name "*.a" -o -name "*.la" \) -delete || die
+ fi
+}
diff --git a/net-libs/czmq/metadata.xml b/net-libs/czmq/metadata.xml
index 25a5bec4901f..bbd0bd05fd80 100644
--- a/net-libs/czmq/metadata.xml
+++ b/net-libs/czmq/metadata.xml
@@ -10,6 +10,7 @@
</flag>
<flag name="http-client">Build support for HTTP client using <pkg>net-misc/curl</pkg></flag>
<flag name="http-server">Build support for HTTP server using <pkg>net-libs/libmicrohttpd</pkg></flag>
+ <flag name="nss">Use <pkg>dev-libs/nss</pkg> for SHA instead of an internal implementation</flag>
<flag name="uuid">Enable UUID support using <pkg>sys-apps/util-linux</pkg></flag>
</use>
</pkgmetadata>