summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2017-04-07 03:01:27 +0200
committerManuel Rüger <mrueg@gentoo.org>2017-04-07 03:02:19 +0200
commit5d3dcfb7e98413328e739acb34b149b19cb0429e (patch)
treeaee45a0bc8c53f7c61a401e89ffc3fc94575c463
parentdev-php/PEAR-Numbers_Words: new EAPI=6 revision with a test suite. (diff)
downloadgentoo-5d3dcfb7e98413328e739acb34b149b19cb0429e.tar.gz
gentoo-5d3dcfb7e98413328e739acb34b149b19cb0429e.tar.bz2
gentoo-5d3dcfb7e98413328e739acb34b149b19cb0429e.zip
dev-python/python-ldap: Version bump to 2.4.32
Package-Manager: Portage-2.3.5, Repoman-2.3.2
-rw-r--r--dev-python/python-ldap/Manifest1
-rw-r--r--dev-python/python-ldap/python-ldap-2.4.32.ebuild67
2 files changed, 68 insertions, 0 deletions
diff --git a/dev-python/python-ldap/Manifest b/dev-python/python-ldap/Manifest
index 3ff54901b125..e7e42e7a7cc2 100644
--- a/dev-python/python-ldap/Manifest
+++ b/dev-python/python-ldap/Manifest
@@ -1,2 +1,3 @@
DIST python-ldap-2.4.19.tar.gz 138503 SHA256 02fddb3accbfb54e40ff47a59457e422b253f9fb6cd64bb3851b349295fab048 SHA512 bfa8b87449f03d70d78bf890d1190ef5a153e1b84db97ca4b40465bfba9faedace2a69f4ae1279ef6323c01255f52993cf0e4374bc32d9660a5286dfc7c17b85 WHIRLPOOL 708c6744b41fc4c9dc4473a9ab088016aa722f5b196c080973fedbb07a08dd57f859ddb5d193665349f44d2d08ff9e2f797cfa6af23e34624f1d0a9e21d62d4d
DIST python-ldap-2.4.21.tar.gz 121176 SHA256 2a3ce606465d2d5fbd0a620516b6648ffd85c343d9305d49a2a1f7d338b8bbd4 SHA512 38f879bd70e5a31b2ec0f89c7a9aab6bdfe86285976300358828cdb83995edaaa960d29c8fcd9f333bda88a2015f306460de7bb24b2d514944d9dc83650acb75 WHIRLPOOL 8cc7526356e63642430804370ffd41cd1e74b74654d4302f90fe87a6471639848ae6ecff160a26daa39763718625b4bcdf3e2b6aaa58e98b00854e1692b30db5
+DIST python-ldap-2.4.32.tar.gz 126025 SHA256 5810f1b5a9ae9255df99fb9c2dcab7352fed325687efda56c0faae1a82c5e3cb SHA512 35a526330852ee87acd240cd285881afe498612fcedbffe93c6e41fb082300cd8b351d9100dc2b3049c658ed062d69cea90f28f9db51a80d94816ce249bbd028 WHIRLPOOL 162208a2dd65069729a4868aa5737f0d6cf312b8e9072978c55d42f6d742ab95a244a6cc996af80a92d422793ad4780a05832a37967262619278007abf51725a
diff --git a/dev-python/python-ldap/python-ldap-2.4.32.ebuild b/dev-python/python-ldap/python-ldap-2.4.32.ebuild
new file mode 100644
index 000000000000..a9f4153a34d1
--- /dev/null
+++ b/dev-python/python-ldap/python-ldap-2.4.32.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 pypy )
+
+inherit distutils-r1 multilib
+
+DESCRIPTION="Various LDAP-related Python modules"
+HOMEPAGE="http://www.python-ldap.org https://pypi.python.org/pypi/python-ldap"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="PSF-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-solaris"
+IUSE="examples sasl ssl"
+
+# If you need support for openldap-2.3.x, please use python-ldap-2.3.9.
+# python team: Please do not remove python-ldap-2.3.9 from the tree.
+# OpenSSL is an optional runtime dep.
+# setup.py sets setuptools and misses pyasn1 and pyasn1-modules in install_requires
+RDEPEND=">net-nds/openldap-2.4.11
+ dev-python/pyasn1[${PYTHON_USEDEP}]
+ dev-python/pyasn1-modules[${PYTHON_USEDEP}]
+ sasl? ( >=dev-libs/cyrus-sasl-2.1 )"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND+=" !dev-python/pyldap"
+
+python_prepare_all() {
+ sed -e "s:^library_dirs =.*:library_dirs = /usr/$(get_libdir) /usr/$(get_libdir)/sasl2:" \
+ -e "s:^include_dirs =.*:include_dirs = ${EPREFIX}/usr/include ${EPREFIX}/usr/include/sasl:" \
+ -i setup.cfg || die "error fixing setup.cfg"
+
+ local mylibs="ldap"
+ if use sasl; then
+ use ssl && mylibs="ldap_r"
+ mylibs="${mylibs} sasl2"
+ else
+ sed -e 's/HAVE_SASL//g' -i setup.cfg || die
+ fi
+ use ssl && mylibs="${mylibs} ssl crypto"
+ use elibc_glibc && mylibs="${mylibs} resolv"
+
+ sed -e "s:^libs = .*:libs = lber ${mylibs}:" \
+ -i setup.cfg || die "error setting up libs in setup.cfg"
+
+ # set test expected to fail to expectedFailure
+ sed -e "s:^ def test_bad_urls: @unittest.expectedFailure\n def test_bad_urls:" \
+ -i Tests/t_ldapurl.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ # XXX: the tests supposedly can start local slapd
+ # but it requires some manual config, it seems.
+
+ "${PYTHON}" Tests/t_ldapurl.py || die "Tests fail with ${EPYTHON}"
+}
+
+python_install_all() {
+ use examples && local EXAMPLES=( Demo/. )
+
+ distutils-r1_python_install_all
+}