summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2015-10-15 01:09:12 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2015-10-15 01:54:11 -0500
commit5d3deec862051c49969e98c0efc19730fb1bb94d (patch)
treef24679e356cfed19b57ac5e9b5201bfdd1a09110
parentdev-python/glance_store: bup for liberty (diff)
downloadgentoo-5d3deec862051c49969e98c0efc19730fb1bb94d.tar.gz
gentoo-5d3deec862051c49969e98c0efc19730fb1bb94d.tar.bz2
gentoo-5d3deec862051c49969e98c0efc19730fb1bb94d.zip
dev-python/WSME: bup for liberty
Package-Manager: portage-2.2.20.1
-rw-r--r--dev-python/WSME/Manifest1
-rw-r--r--dev-python/WSME/WSME-0.8.0.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/WSME/Manifest b/dev-python/WSME/Manifest
index 31c711c7ba18..f10ffb7ba420 100644
--- a/dev-python/WSME/Manifest
+++ b/dev-python/WSME/Manifest
@@ -1 +1,2 @@
DIST WSME-0.6.2.tar.gz 117174 SHA256 a3aede98e9cd1531a697db9f0e4bc038a423cff44ca7c196a1b4fe648427ec74 SHA512 edfbc4f1e0df40273adb1064faced3b047751e611688853fbd66c78248ef57b6cfbab2177ca506afa7727ee26136aa066eb53ea2c012eda3ba65b7ca05b25cb2 WHIRLPOOL babdcb786c636ec7fc7cb067aba72d601e877520fc81bc03d099710a03ed393dfdcc8767a4982de01e75c88da0a0b902eeba903185c491aee846a261574c9da0
+DIST WSME-0.8.0.tar.gz 121619 SHA256 00241e4e4e40d6183f6354a8f5659b601753d49e28b6e5aca332bdf2e31188db SHA512 a0fb92a16bf3a3df75c71ad8756a18e97ee6ab381ad954898970a5eec93cae5469a8fa07a8724cfc64e53d3ad3c3d7d7feaaa55b92176bfb24fc566bd7f415a7 WHIRLPOOL 542f46ffab012f83d18c7c10d4e681f2ae775d0995d48c29a68b7c0b4a7f1cff7fc16d88251f73c4bf04740947d35dc7b5f6c68391e0d05ae5e29cee9bc4ea82
diff --git a/dev-python/WSME/WSME-0.8.0.ebuild b/dev-python/WSME/WSME-0.8.0.ebuild
new file mode 100644
index 000000000000..5fb89ce2771c
--- /dev/null
+++ b/dev-python/WSME/WSME-0.8.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 python3_3 python3_4 )
+
+inherit distutils-r1
+
+DESCRIPTION="Simplify the writing of REST APIs, and extend them with additional protocols."
+HOMEPAGE="http://pythonhosted.org//WSME"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+CDEPEND=">=dev-python/pbr-1.3[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}
+"
+RDEPEND="
+ ${CDEPEND}
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+ >=dev-python/webob-1.2.3[${PYTHON_USEDEP}]
+ dev-python/simplegeneric[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ >=dev-python/netaddr-0.7.12[${PYTHON_USEDEP}]
+"