summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2022-12-20 21:10:07 -0500
committerMichael Orlitzky <mjo@gentoo.org>2022-12-20 21:15:40 -0500
commit5d43eb3b8b9093d2210b64b687c28f623968e3a4 (patch)
tree4160936deb313bff3cb1c3073a9fa3323e9e0658
parentsys-apps/systemd-utils: add 251.10 (diff)
downloadgentoo-5d43eb3b8b9093d2210b64b687c28f623968e3a4.tar.gz
gentoo-5d43eb3b8b9093d2210b64b687c28f623968e3a4.tar.bz2
gentoo-5d43eb3b8b9093d2210b64b687c28f623968e3a4.zip
sci-mathematics/nauty: add 2.8.6
Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
-rw-r--r--sci-mathematics/nauty/Manifest2
-rw-r--r--sci-mathematics/nauty/nauty-2.8.6.ebuild71
2 files changed, 73 insertions, 0 deletions
diff --git a/sci-mathematics/nauty/Manifest b/sci-mathematics/nauty/Manifest
index 4d6cba17d82e..6d6e6df96096 100644
--- a/sci-mathematics/nauty/Manifest
+++ b/sci-mathematics/nauty/Manifest
@@ -1,3 +1,5 @@
DIST nauty-includes.patch 2530 BLAKE2B 8789bc2f65b89aa3bbf27e517f1c56340f9bde089ef54aa28757c66c3954b5c54e8a09b6989ad8d57098970240dd1838baa0003766fe10c7f6c32041abf461e3 SHA512 d11f530fecb86edc9e95f0b4d91240778047c0e84d6259c80490358baf0a3eeaa112acfe1fcdb594da6c6e17855f5e21cb75c88446b8d6d9e96402be0e5e6af2
DIST nauty27r4.tar.gz 1731562 BLAKE2B 104481e5af3333b60574a7185848832ad08b0cfeb8378e3c89ddd3f2cc87023cd701889356fa196b529ddbf19232a733fe3e694d9573adef04c2ad86baaf38e5 SHA512 2ed691bf0a6806f77cccbd95ee7687a66b6e6342493a0d65636166727cf4ea8cd887187d88a3154d911f665deb8d6f5bbaba33c8a1b740a564a1fc52bf4b4520
+DIST nauty2_8_6.tar.gz 1546765 BLAKE2B be8aa8ef816c8833a79876e6bf99b0dc4a23922f48684c8a3272c01b0b4eb64959366cae363fbda4200354a0833942b64e85c009fc35a3d6fa02f9b74c9b9a74 SHA512 9bc597d4341a6a67aece0ad95ecd4a649f675def73e97af1d215cf7399cbd3fb8e39f140cbd6f69740f2083c7a5739d5089e746bb3f831250709e0d2b43548b5
DIST nauty_2.7r4+ds-1.debian.tar.xz 45712 BLAKE2B e4a7a1d2b70b5fa969f708bbd56b47aaf422c268be23ffa7ceb3f9cc21ff8d27270556adadd43fe60309e7840e1541a586b1d9d42d90ba6207801e170b747922 SHA512 7384e7637a875c35f6da94707576aa26a94f981a750eb80991a837fa9ae245680f11ca57cf24a9efe1164dcd386c9888270688c1b3de30d1a81b67bb7c670dd9
+DIST nauty_2.8.6+ds-1.debian.tar.xz 62852 BLAKE2B fcbbed54b10d9dd4bdf82d8a72ef91866a235c7679266b8f395e2fe6b44a679e98f85462a42037094d856130d5456d9989749c416932f895bc17df8ef32241a2 SHA512 3784e0ec15c64ea6850f9198c61af3924fcedf1ffa4715fbd53a9bd1cd7defd69b543a8d4e6d46ef727918661409e2de77c89c3ca79f36769c1335b30bdd305c
diff --git a/sci-mathematics/nauty/nauty-2.8.6.ebuild b/sci-mathematics/nauty/nauty-2.8.6.ebuild
new file mode 100644
index 000000000000..4fc0728515d0
--- /dev/null
+++ b/sci-mathematics/nauty/nauty-2.8.6.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+MY_PV=${PV//./_}
+DEBIAN_PATCH_VERSION=1
+
+DESCRIPTION="Computing automorphism groups of graphs and digraphs"
+HOMEPAGE="https://pallini.di.uniroma1.it/"
+
+SRC_URI="https://pallini.di.uniroma1.it/${PN}${MY_PV}.tar.gz
+ mirror://debian/pool/main/${PN:0:1}/${PN}/${PN}_${PV}+ds-${DEBIAN_PATCH_VERSION}.debian.tar.xz
+ https://src.fedoraproject.org/rpms/nauty/raw/f35/f/nauty-includes.patch"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~riscv ~x86"
+IUSE="cpu_flags_x86_popcnt examples"
+
+BDEPEND="sys-apps/help2man"
+DEPEND="dev-libs/gmp:0
+ sys-libs/zlib
+ sci-mathematics/cliquer"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${PN}${MY_PV}"
+
+DOCS=( schreier.txt formats.txt changes24-28.txt )
+
+PATCHES=(
+ "${WORKDIR}/debian/patches/upstream-fix-gt_numorbits.patch"
+ "${WORKDIR}/debian/patches/upstream-C2help2man.patch"
+ "${WORKDIR}/debian/patches/upstream-autotoolization.patch"
+ "${DISTDIR}/nauty-includes.patch"
+ "${WORKDIR}/debian/patches/unbundle-cliquer.patch"
+ "${WORKDIR}/debian/patches/upstream-zlib-dimacs2g.patch"
+ "${WORKDIR}/debian/patches/fall-off.patch"
+ "${WORKDIR}/debian/patches/format.patch"
+)
+
+src_prepare() {
+ default
+ rm makefile || die
+
+ # The debian patch looks for <cliquer.h>, but the autotools-form of
+ # cliquer installs that header as <cliquer/cliquer.h>.
+ sed -e 's~<cliquer\.h>~<cliquer/cliquer\.h>~' -i nautycliquer.h || die
+
+ eautoreconf
+}
+
+src_configure() {
+ econf --disable-static \
+ --enable-tls \
+ --enable-generic \
+ $(use_enable cpu_flags_x86_popcnt popcnt)
+}
+
+src_install() {
+ default
+
+ if use examples; then
+ docinto examples
+ dodoc nautyex*.c
+ fi
+
+ find "${ED}" -name '*.la' -delete || die
+}