summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYixun Lan <dlan@gentoo.org>2023-06-18 05:09:32 +0800
committerYixun Lan <dlan@gentoo.org>2023-06-18 05:09:52 +0800
commit5d4862afe7e43f31b2623948a57fc8486fd9d69c (patch)
tree54a09a553698fa9923fe676f484f6565a7b562cc
parentsys-fs/btrfs-progs: Stabilize 6.3.1 ppc, #908642 (diff)
downloadgentoo-5d4862af.tar.gz
gentoo-5d4862af.tar.bz2
gentoo-5d4862af.zip
app-backup/snapper: add 0.10.5
Signed-off-by: Yixun Lan <dlan@gentoo.org>
-rw-r--r--app-backup/snapper/Manifest1
-rw-r--r--app-backup/snapper/snapper-0.10.5.ebuild89
2 files changed, 90 insertions, 0 deletions
diff --git a/app-backup/snapper/Manifest b/app-backup/snapper/Manifest
index e4662ebb1835..5d2e4014602a 100644
--- a/app-backup/snapper/Manifest
+++ b/app-backup/snapper/Manifest
@@ -1,2 +1,3 @@
DIST snapper-0.10.3.tar.gz 409277 BLAKE2B bc4963081a24572015ff888b5cb85f3afa071e487a89e89f1a72d5b96391be69ad982c79ddfd71f020203d0c50ca07d67cbeb535cd6e57bc3d6ee269ef5c788e SHA512 74cb04d045304021564a0452769fdcde1764595a52e30947396c37fe4c36b3fba08d10505734bc0bd631986e933ee2bfaf67c871cba93a96e498fbfe5e2c6985
DIST snapper-0.10.4.tar.gz 409357 BLAKE2B c2b33d917647118848dfd02315435d9dab21bcaade22b9da5a2d4d628c00731ecd9bbc7cedba223f618f336535ccba0ca92b065d572aab328337858dba76275f SHA512 f42bcfa541e1fff23f5057c9b38d93f31a28980ce1cd37e07bcf622ff9151bd98c42975610d59da0c33a9bee7d83290edbdd05e013839e4ca23f02e9a9f8c793
+DIST snapper-0.10.5.tar.gz 422114 BLAKE2B 35c4772fc84920755d5fe87cad4a73792692ab7a55bcbcae65f20bf2e0cbcfb79429a423a5b55a89dbfeba1ff0474741c884bc632daa997fbb86cec52b68e3ef SHA512 e710069374b805394d691f8060d2852e35960a965fd49bb59768ebcc53a615af1f36269adac2d916b5e3f1b3e42fb2a53049d8f1b8a6a8430e992fa0de49c235
diff --git a/app-backup/snapper/snapper-0.10.5.ebuild b/app-backup/snapper/snapper-0.10.5.ebuild
new file mode 100644
index 000000000000..1a6c2c9abb0c
--- /dev/null
+++ b/app-backup/snapper/snapper-0.10.5.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools systemd
+
+DESCRIPTION="Command-line program for btrfs and lvm snapshot management"
+HOMEPAGE="http://snapper.io/"
+SRC_URI="https://github.com/openSUSE/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+IUSE="doc lvm pam test systemd xattr"
+RESTRICT="test"
+
+RDEPEND="dev-libs/boost:=
+ dev-libs/json-c:=
+ dev-libs/libxml2
+ dev-libs/icu:=
+ sys-apps/acl
+ sys-apps/dbus
+ sys-apps/util-linux
+ >=sys-fs/btrfs-progs-3.17.1
+ sys-libs/zlib
+ virtual/libintl
+ lvm? ( sys-fs/lvm2 )
+ pam? ( sys-libs/pam )
+ xattr? ( sys-apps/attr )"
+
+DEPEND="${RDEPEND}
+ app-text/docbook-xsl-stylesheets
+ dev-libs/libxslt
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/cron-confd.patch
+ "${FILESDIR}"/${PN}-0.10.1-testsuite.patch
+)
+
+src_prepare() {
+ default
+
+ sed -e "s,/usr/lib/systemd/system,$(systemd_get_systemunitdir),g" \
+ -i data/Makefile.* \
+ || die "Failed to fix systemd services and timers installation path"
+ eautoreconf
+}
+
+src_configure() {
+ # ext4 code does not work anymore
+ # snapper does not build without btrfs
+ local myeconfargs=(
+ --disable-silent-rules
+ --with-conf="/etc/conf.d"
+ --enable-zypp
+ --enable-rollback
+ --enable-btrfs-quota
+ --disable-ext4
+ --enable-btrfs
+ $(use_enable doc)
+ $(use_enable lvm)
+ $(use_enable pam)
+ $(use_enable test tests)
+ $(use_enable systemd)
+ $(use_enable xattr xattrs)
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+ # Existing configuration file required to function
+ keepdir /etc/snapper/configs
+ newconfd data/sysconfig.snapper snapper
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ elog "In order to use Snapper, you need to set up"
+ elog "at least one config first. To do this, run:"
+ elog "snapper create-config <subvolume>"
+ elog "For more information, see man (8) snapper or"
+ elog "http://snapper.io/documentation.html and"
+ elog "https://wiki.gentoo.org/wiki/Snapper"
+}