summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetr Vaněk <arkamar@atlas.cz>2023-11-08 13:07:46 +0100
committerSam James <sam@gentoo.org>2023-11-17 11:08:04 +0000
commit5d52e756ae04a116425ebc4fe80eefb5241d0650 (patch)
tree3484e3f7fc28ba8b66d2a04185be4bfbc1cd84f1
parentsys-apps/s6: add 2.12.0.0 (diff)
downloadgentoo-5d52e756ae04a116425ebc4fe80eefb5241d0650.tar.gz
gentoo-5d52e756ae04a116425ebc4fe80eefb5241d0650.tar.bz2
gentoo-5d52e756ae04a116425ebc4fe80eefb5241d0650.zip
sys-apps/s6-rc: add 0.5.4.2
Signed-off-by: Petr Vaněk <arkamar@atlas.cz> Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--sys-apps/s6-rc/Manifest1
-rw-r--r--sys-apps/s6-rc/s6-rc-0.5.4.2.ebuild65
2 files changed, 66 insertions, 0 deletions
diff --git a/sys-apps/s6-rc/Manifest b/sys-apps/s6-rc/Manifest
index 2dfed362bf6c..a37e5cd863c7 100644
--- a/sys-apps/s6-rc/Manifest
+++ b/sys-apps/s6-rc/Manifest
@@ -1 +1,2 @@
DIST s6-rc-0.5.4.1.tar.gz 101078 BLAKE2B d85a194712ab63369cb71cbe4c59efd8cbe507a5e74c6bdb1bbe9a0e9123b8b1179850a8abdb0dbc67ef3c09764c9a6fb11c5b366590ecf4922b0d5a0115bc14 SHA512 6b61df9fa1d9bd24430bab4c11bfba009ca79c62a32dd2db3b79a1057645da9f92db4058c66c35bb068d805d958bfdf024399d240559dfdee62f9a6a30cf2086
+DIST s6-rc-0.5.4.2.tar.gz 100896 BLAKE2B d9e6f580a32d27950c7c525a5b657b429616d1c937c71cee302939b847a58bae1d5e209f53113dc82b953b5aa14c6078b206566e4809902a8f06b17c5621205f SHA512 f04e94db957e6d0033e328cc63530f64c9db101815bcafdb00a23205f4e75039dd3e593f93d48e4d9877b0696ea734ca62f672d92ff31e4e07aa19d26d809443
diff --git a/sys-apps/s6-rc/s6-rc-0.5.4.2.ebuild b/sys-apps/s6-rc/s6-rc-0.5.4.2.ebuild
new file mode 100644
index 000000000000..7d597db9002f
--- /dev/null
+++ b/sys-apps/s6-rc/s6-rc-0.5.4.2.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Service manager for the s6 supervision suite"
+HOMEPAGE="https://www.skarnet.org/software/s6-rc/"
+SRC_URI="https://www.skarnet.org/software/${PN}/${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0/$(ver_cut 1-2)"
+KEYWORDS="~amd64 ~arm ~x86"
+
+RDEPEND="
+ dev-lang/execline:=
+ >=dev-libs/skalibs-2.14.0.0:=
+ >=sys-apps/s6-2.11.3.0:=[execline]
+"
+DEPEND="${RDEPEND}"
+
+HTML_DOCS=( doc/. )
+
+src_prepare() {
+ default
+
+ # Avoid QA warning for LDFLAGS addition
+ sed -i -e 's/.*-Wl,--hash-style=both$/:/' configure || die
+
+ sed -i -e '/AR := /d' -e '/RANLIB := /d' Makefile || die
+}
+
+src_configure() {
+ tc-export AR CC RANLIB
+
+ local myconf=(
+ --bindir=/bin
+ --dynlibdir="/$(get_libdir)"
+ --libdir="/usr/$(get_libdir)/${PN}"
+ --libexecdir=/lib/s6
+ --with-dynlib="/$(get_libdir)"
+ --with-lib="/usr/$(get_libdir)/execline"
+ --with-lib="/usr/$(get_libdir)/s6"
+ --with-lib="/usr/$(get_libdir)/skalibs"
+ --with-sysdeps="/usr/$(get_libdir)/skalibs"
+ --enable-shared
+ --disable-allstatic
+ --disable-static
+ --disable-static-libc
+ )
+
+ econf "${myconf[@]}"
+}
+
+pkg_postinst() {
+ for ver in ${REPLACING_VERSIONS}; do
+ if ver_test "${ver}" -lt "0.5.4.0"; then
+ elog "Location of helper utilities was changed from /usr/libexec to /lib/s6 in"
+ elog "version 0.5.4.0. It is necessary to recompile and update s6-rc database and"
+ elog "restart s6rc-oneshot-runner service because you are upgrading from older"
+ elog "version."
+ fi
+ done
+}