summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-11-19 15:37:10 +0100
committerMichał Górny <mgorny@gentoo.org>2023-11-19 17:01:09 +0100
commit5d69a790cfc8a7402e9b9672e4f83c788a01cb49 (patch)
tree658bc45a149c462005d8c8cd13089bc25a917fb4
parentdev-python/scipy: Bump to 1.11.4 (diff)
downloadgentoo-5d69a790cfc8a7402e9b9672e4f83c788a01cb49.tar.gz
gentoo-5d69a790cfc8a7402e9b9672e4f83c788a01cb49.tar.bz2
gentoo-5d69a790cfc8a7402e9b9672e4f83c788a01cb49.zip
dev-python/versioningit: Bump to 2.3.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/versioningit/Manifest1
-rw-r--r--dev-python/versioningit/versioningit-2.3.0.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/versioningit/Manifest b/dev-python/versioningit/Manifest
index 6e764479922b..b657baa5f60d 100644
--- a/dev-python/versioningit/Manifest
+++ b/dev-python/versioningit/Manifest
@@ -1 +1,2 @@
DIST versioningit-2.2.1.tar.gz 743942 BLAKE2B f0f84b2323cdeac79144d842bbebfc196aecb35752da4dc0e343a709fc539eba50f33079dc652e95dc06bda8ddb761b5a68179b50f533434aafd7d4b1263af63 SHA512 9ec8d4cf26392fd3bfd29d5c3e573a6af8e6a42c6aff1d0f9dbf68a17b667c55859d64d91d5715bf232f4eea22a6f300cbfc6da2be8364186c23b5023fa0e6ad
+DIST versioningit-2.3.0.tar.gz 209785 BLAKE2B 392706b969a3a94be6dee2bbd8935cf97e3f0ab0b102c5ae1ef2d65b25d6e44faf9e50301639aca77c8d81e0265875c548a9d28d331cbc07aaae7ed589c6ab04 SHA512 2e91ab8bf7be333b4783e8e7ad6cf4897694a5d3e14f41cad0f3683291078fb88845d629ee1e41885408bf07d5ea6250588af6e6cf6d6596df1bae4bee5ddf0b
diff --git a/dev-python/versioningit/versioningit-2.3.0.ebuild b/dev-python/versioningit/versioningit-2.3.0.ebuild
new file mode 100644
index 000000000000..bae678a7309a
--- /dev/null
+++ b/dev-python/versioningit/versioningit-2.3.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A setuptools plugin for versioning based on git tags"
+HOMEPAGE="
+ https://github.com/jwodder/versioningit/
+ https://pypi.org/project/versioningit/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/packaging-17.1[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ <dev-python/tomli-3[${PYTHON_USEDEP}]
+ ' 3.10)
+"
+BDEPEND="
+ test? (
+ dev-python/pydantic[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_IGNORE=(
+ # Tries to do wheel/pip installs
+ test/test_end2end.py
+)
+
+distutils_enable_tests pytest
+
+python_test() {
+ epytest -o addopts=
+}