summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOliver Freyermuth <o.freyermuth@googlemail.com>2022-01-20 22:24:23 +0100
committerSam James <sam@gentoo.org>2022-01-21 19:05:30 +0000
commit5d933922e2b1e7793bb0b1c2befe87f7c7fb9b0c (patch)
treea6b11aab3cba604164c8fc37f04b74401bf428b1
parentgo-module.eclass fixed referenced package (diff)
downloadgentoo-5d933922e2b1e7793bb0b1c2befe87f7c7fb9b0c.tar.gz
gentoo-5d933922e2b1e7793bb0b1c2befe87f7c7fb9b0c.tar.bz2
gentoo-5d933922e2b1e7793bb0b1c2befe87f7c7fb9b0c.zip
sys-cluster/charliecloud: Bump to version 0.26.
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Oliver Freyermuth <o.freyermuth@googlemail.com> Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--sys-cluster/charliecloud/Manifest1
-rw-r--r--sys-cluster/charliecloud/charliecloud-0.26.ebuild80
2 files changed, 81 insertions, 0 deletions
diff --git a/sys-cluster/charliecloud/Manifest b/sys-cluster/charliecloud/Manifest
index ad49af5ee1d3..d28bf002367f 100644
--- a/sys-cluster/charliecloud/Manifest
+++ b/sys-cluster/charliecloud/Manifest
@@ -1,2 +1,3 @@
DIST charliecloud-0.24.tar.gz 420852 BLAKE2B ca55231c74012a678c24133b28e341392865a562653086766e6b5e570744f31ce69d1afa2bbb2cc85d5e52b6ed6e9f42f67187d9998afd3852a10fd4a8ff29d3 SHA512 41f44ef5f12dc35d7972923a84044b7255801705d4fcabf76e675dcb70a9f25422e7d584a7b49135ef2ae5dc1751a39efd84f8eb719653a769b41f46bd558fd2
DIST charliecloud-0.25.tar.gz 454041 BLAKE2B 3a071f3b9fb06ca1db6d3b85a577943fe76440d395fdf1415d5085110db665fb75ee09dc14768d326e7e280e6c20096479e5f62290f7dee46821c356f5f18535 SHA512 a7a35b584dbdd6c6e27188d3555173c44f90c0e44fa685a15a47f47c94f9d76aa46ab80054a7c53e10a7f56bef87696f1db2a0eb8c49a388dbb0da0fe9112a60
+DIST charliecloud-0.26.tar.gz 472324 BLAKE2B 2b4b8f44f05a497e9367e97e49de255170b610880ef5d7909f7837bc54962f2c2de929d8381b99dc3f4b6124583744993b59839f8f1481cdbd5dc32334d3da9f SHA512 a8638db42a5563723b62ba0e9b9861b41e76b9246b94887d57a8d4c421d9dd2e8c0965b62af166e47859b72a50a2e01ec6775ef13f79c52696a6b2fd95134174
diff --git a/sys-cluster/charliecloud/charliecloud-0.26.ebuild b/sys-cluster/charliecloud/charliecloud-0.26.ebuild
new file mode 100644
index 000000000000..8ce74691fe62
--- /dev/null
+++ b/sys-cluster/charliecloud/charliecloud-0.26.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8,9,10} )
+
+inherit autotools optfeature python-single-r1
+
+if [[ ${PV} == "9999" ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/hpc/${PN}.git"
+ S="${WORKDIR}/${P}"
+else
+ SRC_URI="https://github.com/hpc/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86 ~x86-linux"
+fi
+
+DESCRIPTION="Lightweight user-defined software stacks for high-performance computing"
+HOMEPAGE="https://hpc.github.io/charliecloud/"
+
+SLOT="0"
+LICENSE="Apache-2.0"
+IUSE="ch-image doc"
+
+# Extensive test suite exists, but downloads container images
+# directly and via Docker and installs packages inside using apt/yum.
+# Additionally, clashes with portage namespacing and sandbox.
+RESTRICT="test"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ elibc_musl? ( sys-libs/argp-standalone )
+"
+DEPEND="
+ ch-image? (
+ $(python_gen_cond_dep '
+ dev-python/lark-parser[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ ')
+ )
+ doc? (
+ $(python_gen_cond_dep '
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/sphinx_rtd_theme[${PYTHON_USEDEP}]
+ ')
+ net-misc/rsync
+ )"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local econf_args=()
+ econf_args+=(
+ $(use_enable doc html)
+ $(use_enable ch-image)
+ # Libdir is used as a libexec-style destination.
+ --libdir="${EPREFIX}"/usr/lib
+ # Attempts to call python-exec directly otherwise.
+ --with-sphinx-python=${PYTHON}
+ # This disables -Werror, see also: https://github.com/hpc/charliecloud/pull/808
+ --enable-buggy-build
+ # Do not use bundled version of dev-python/lark-parser.
+ --disable-bundled-lark
+ )
+ econf "${econf_args[@]}"
+}
+
+pkg_postinst() {
+ elog "Various builders are supported, as alternative to the internal ch-image."
+ optfeature "Building with Buildah" app-containers/buildah
+ optfeature "Building with Docker" app-containers/docker
+ optfeature "Progress bars during long operations" sys-apps/pv
+ optfeature "Pack and unpack squashfs images" sys-fs/squashfs-tools
+ optfeature "Mount and umount squashfs images" sys-fs/squashfuse
+}