summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2021-04-16 16:43:31 -0400
committerMatt Turner <mattst88@gentoo.org>2021-04-16 16:53:58 -0400
commit5d9f9424aaec4ef34da6d064b067ba36aec058db (patch)
tree8a8b8bf1fdf09eb87cdaf684c620c395974ae348
parentmedia-sound/gnome-sound-recorder: Version bump to 40.0 (diff)
downloadgentoo-5d9f9424.tar.gz
gentoo-5d9f9424.tar.bz2
gentoo-5d9f9424.zip
media-libs/graphene: Version bump to 1.10.6
Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rw-r--r--media-libs/graphene/Manifest1
-rw-r--r--media-libs/graphene/graphene-1.10.6.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/media-libs/graphene/Manifest b/media-libs/graphene/Manifest
index c9d4938db59c..7de672b12f05 100644
--- a/media-libs/graphene/Manifest
+++ b/media-libs/graphene/Manifest
@@ -1 +1,2 @@
DIST graphene-1.10.2.tar.xz 292372 BLAKE2B 94553a32dc57216402a9676e11525552c010d970caeb1256dde50ca842b4d673ad78d004d57e7c7a017b8c6e64ad75fc3b03603cba746027ab10befa76d32955 SHA512 a8a8ef1e4ccffee2313a18b9b8dda06c7ede6d49fdde8578694500634e3c90278fd30af7d88938d5ecb08c519cc3e09d21fe69d0f21cb766e056ceedbb3eafb0
+DIST graphene-1.10.6.tar.xz 333332 BLAKE2B d353efb22510b78c7360b748b7e83237309b88c170909e521d50e95618e907bd8b2424c3583a5db3ff2ca57954bf793646a69251bbb31caac55155c15981ed3a SHA512 075e8c712509655d0614258a7fd2943e67a9642334cdabdc15d2489a88c961e278f7464a513080cd287f5371c7ece8ceb7565d1718a8b71fea4a4977f82aeb72
diff --git a/media-libs/graphene/graphene-1.10.6.ebuild b/media-libs/graphene/graphene-1.10.6.ebuild
new file mode 100644
index 000000000000..74cf717498d6
--- /dev/null
+++ b/media-libs/graphene/graphene-1.10.6.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+inherit xdg-utils meson multilib-minimal python-any-r1
+
+DESCRIPTION="A thin layer of types for graphic libraries"
+HOMEPAGE="https://ebassi.github.io/graphene/"
+SRC_URI="https://github.com/ebassi/graphene/releases/download/${PV}/${P}.tar.xz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="cpu_flags_arm_neon cpu_flags_x86_sse2 doc +introspection test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-libs/glib-2.30.0:2[${MULTILIB_USEDEP}]
+ introspection? ( dev-libs/gobject-introspection:= )
+"
+DEPEND="${RDEPEND}"
+# Python is only needed with USE=introspection or FEATURES=test, but not bothering with conditional python_setup, as meson uses it too anyway
+BDEPEND="
+ ${PYTHON_DEPS}
+ doc? (
+ dev-util/gtk-doc
+ app-text/docbook-xml-dtd:4.3
+ )
+ virtual/pkgconfig
+"
+
+multilib_src_configure() {
+ # TODO: Do we want G_DISABLE_ASSERT as buildtype=release would do upstream?
+ local emesonargs=(
+ -Dgtk_doc=$(multilib_native_usex doc true false)
+ -Dgobject_types=true
+ -Dintrospection=$(multilib_native_usex introspection enabled disabled)
+ -Dgcc_vector=true # if built-in support tests fail, it'll just not enable vector intrinsics; unfortunately this probably means disabled on clang too, due to it claiming to be <gcc-4.9
+ $(meson_use cpu_flags_x86_sse2 sse2)
+ $(meson_use cpu_flags_arm_neon arm_neon)
+ $(meson_use test tests)
+ -Dinstalled_tests=false
+ )
+ meson_src_configure
+}
+
+multilib_src_compile() {
+ meson_src_compile
+}
+
+multilib_src_test() {
+ meson_src_test
+}
+
+multilib_src_install() {
+ meson_src_install
+}