summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2022-10-01 11:55:25 +0200
committerHans de Graaff <graaff@gentoo.org>2022-10-01 11:56:33 +0200
commit5da63bca656521d57ba75de924b58cec59f538c9 (patch)
treededfeff9b1756e4e25a18a019958f67413bd3954
parentdev-ruby/actionpack: add 7.0.4 (diff)
downloadgentoo-5da63bca656521d57ba75de924b58cec59f538c9.tar.gz
gentoo-5da63bca656521d57ba75de924b58cec59f538c9.tar.bz2
gentoo-5da63bca656521d57ba75de924b58cec59f538c9.zip
dev-ruby/activestorage: add 7.0.4
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
-rw-r--r--dev-ruby/activestorage/Manifest1
-rw-r--r--dev-ruby/activestorage/activestorage-7.0.4.ebuild67
2 files changed, 68 insertions, 0 deletions
diff --git a/dev-ruby/activestorage/Manifest b/dev-ruby/activestorage/Manifest
index 711b4d9a5e50..9f762044e7d8 100644
--- a/dev-ruby/activestorage/Manifest
+++ b/dev-ruby/activestorage/Manifest
@@ -2,3 +2,4 @@ DIST rails-5.2.8.1.tgz 8848345 BLAKE2B 6786359e6c519e98079dc6f87a1ad23a69e7b65d2
DIST rails-6.0.5.1.tgz 18607954 BLAKE2B 74f75399a287f1eae199a5764c952b75dd95a02c88899ade69d60acae00a7588b2f3a8ab3b9d2c9224d62f87305c596e16b196a5c32b19731d4415f17a29d38e SHA512 a65c3fab39eadba75e0107486c82a4da212e612ddb2350f77bb00ad887e0b52980edba08d42c02801c4e4fd71d750de3dbd78c820ef050016867737dccc06b36
DIST rails-6.1.6.1.tgz 11028264 BLAKE2B 568033eb816613ba0ba5f2df38e6a30158b2e31ef4d4da151f8c0de2934b07736833026793ce9192994d9ef2a2a45b67735a35760c1be8b8a68c1968147cc6db SHA512 04acf9dbf5ee734636aada67be001690899eb13f73ea688455fcaee8cbf4839aedf06943c8adb5eecf13fd9a5f6be1a225310aa481d3a254172fd0ce0402362f
DIST rails-7.0.3.1.tgz 11049683 BLAKE2B 31aa9c20b4add7e11b832aff57fcf78284b7f28e71cfc71b5769c65170f1fff3f33d73224bbfa826852a59aac30671ff7c3ef19cbe0aaabc8528a805c6b98e8a SHA512 2ad615df9e019193489d5ce82152fd0ff12d8435401258b2b8a87d1c5da46587cdd45dc483847891f7b8be1d019b09b77a48fa7849d5260ee6fdbbf6df64ef03
+DIST rails-7.0.4.tgz 11061225 BLAKE2B 9c520766f936c82ae9ee943c3db0ad575d7fc59aea947fb2790cf511188fbd33166a62332564c4714372203f5fabdde842334103b48f4115c31f5d0fe18375f1 SHA512 118035226054ad5083d2affde55a812917652491f82a9a578380a790770fdda3a14904f6de10f58651bbbab278aa23920b652aa1b34c71441d465c3b7b4be82c
diff --git a/dev-ruby/activestorage/activestorage-7.0.4.ebuild b/dev-ruby/activestorage/activestorage-7.0.4.ebuild
new file mode 100644
index 000000000000..9c124f9b63be
--- /dev/null
+++ b/dev-ruby/activestorage/activestorage-7.0.4.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby27 ruby30"
+
+RUBY_FAKEGEM_RECIPE_DOC=""
+RUBY_FAKEGEM_DOCDIR=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+RUBY_FAKEGEM_GEMSPEC="activestorage.gemspec"
+
+RUBY_FAKEGEM_EXTRAINSTALL="app config db"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="Attach cloud and local files in Rails applications"
+HOMEPAGE="https://github.com/rails/rails"
+SRC_URI="https://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="$(ver_cut 1-2)"
+KEYWORDS="~amd64 ~riscv ~x86"
+IUSE=""
+
+RUBY_S="rails-${PV}/${PN}"
+
+DEPEND+=" test? ( app-text/mupdf media-gfx/imagemagick[jpeg,png,tiff] media-video/ffmpeg app-text/poppler[utils] ) "
+
+ruby_add_rdepend "
+ ~dev-ruby/actionpack-${PV}:*
+ ~dev-ruby/activejob-${PV}:*
+ ~dev-ruby/activerecord-${PV}:*
+ ~dev-ruby/activesupport-${PV}:*
+ dev-ruby/marcel:1.0
+ >=dev-ruby/mini_mime-1.1.0
+"
+
+ruby_add_bdepend "
+ test? (
+ ~dev-ruby/railties-${PV}
+ >=dev-ruby/image_processing-1.2:0
+ =dev-ruby/minitest-5.15*:5
+ dev-ruby/mini_magick
+ dev-ruby/mocha
+ dev-ruby/rake
+ dev-ruby/sprockets-rails
+ dev-ruby/sqlite3
+ )"
+
+all_ruby_prepare() {
+ # Remove items from the common Gemfile that we don't need for this
+ # test run. This also requires handling some gemspecs.
+ sed -e "/\(system_timer\|sdoc\|w3c_validators\|pg\|execjs\|jquery-rails\|'mysql'\|journey\|ruby-prof\|stackprof\|benchmark-ips\|kindlerb\|turbolinks\|coffee-rails\|debugger\|redcarpet\|bcrypt\|uglifier\|aws-sdk-s3\|aws-sdk-sns\|google-cloud-storage\|azure-storage\|blade\|bootsnap\|hiredis\|qunit-selenium\|chromedriver-helper\|redis\|rb-inotify\|stackprof\|websocket-client-simple\|libxml-ruby\|sass-rails\|capybara\|rack-cache\|selenium\|dalli\|listen\|connection_pool\|puma\|mysql2\|webdrivers\|webpacker\|rexml\|webmock\|propshaft\|sprockets-export\)/ s:^:#:" \
+ -e '/stimulus-rails/,/tailwindcss-rails/ s:^:#:' \
+ -e '/group :\(doc\|job\|rubocop\|test\)/,/^end/ s:^:#:' \
+ -i ../Gemfile || die
+ rm ../Gemfile.lock || die
+
+ # Use mini_magick since vips is not packaged on Gentoo
+ sed -i -e '/mini_magick/aActiveStorage.variant_processor = :mini_magick' test/test_helper.rb || die
+ # Avoid vips-specific tests
+ sed -i -e '/\(resized and monochrome variation of JPEG blob\|monochrome with default variant_processor\|disabled variation of JPEG blob\)/askip "No vips support"' test/models/variant_test.rb || die
+}