summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-06-26 11:48:46 +0200
committerMichał Górny <mgorny@gentoo.org>2020-06-26 12:10:51 +0200
commit5da8a9181eedf89de63351d80687b5dd9d0ec677 (patch)
tree821aea5995e9c48e273cfa9651f2460e85be3ffa
parentdev-python/botocore: Bump to 1.17.11 (diff)
downloadgentoo-5da8a918.tar.gz
gentoo-5da8a918.tar.bz2
gentoo-5da8a918.zip
dev-python/boto3: Bump to 1.14.11
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.14.11.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index a7b254c5c558..1b153ed2dd96 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -2,6 +2,7 @@ DIST boto3-1.10.2.tar.gz 272071 BLAKE2B 9c3b90ae751784946a84d0cf31ed0111526ed97b
DIST boto3-1.12.48.tar.gz 292124 BLAKE2B 0baf8fb4cfa040ba05b296d15a523a5de32677684143145b12dd54182d4fedbffa5656d36ab854006c0cc6009a1bca351bb5ac2ea757cb70b446924bcae625a8 SHA512 3cf5533dd5d9aa51cf46ef81ba25bb7afbc73b1e745ea5ae47935b22da290c7d2101e377b3225f970168201dde0bf2ee967e24eed86548f9045eb72840afea6b
DIST boto3-1.13.26.tar.gz 296782 BLAKE2B 117bb18679fe3ae8c4feee1a5fb2d1df1923764bba3dce72040ccc802d10bb88263744a0491195f414761b6755353775a8a413a121a5a0fc42373a4e9b8aac1a SHA512 513ea4b39a5af4ae8e45f6b8b315a19d5184998fa881782bf2e6074aee36a709b51813fc9fe403bb8dbfb9b51ead50367af18f0918a1c88a37eab263ccddd11a
DIST boto3-1.14.0.tar.gz 297008 BLAKE2B 7f5eaf4958395b47e936596b385b5a4daa20dbed6b777a407b6c2f70d3004d89fb963f479a1a3c8be22a3cbbfdb21f59a1f3c3ea4b967fce4799fc965899bcf1 SHA512 12ce4765f22e848aac0c29d1f95ed7b63964868f18c14073f93c74e442babf8708aa69cb6c17bd7c3aa5dacda6beb67bb4a4afe86fcd298308c70abfb77802d4
+DIST boto3-1.14.11.tar.gz 298578 BLAKE2B c78ba0957c4252adeaefb7ac3e335e3db6044752cd06731b6f7367bbfdbbb2db25d717ddf8954eabce745bca07d2980445a725977d3f12a5914e8620502e7f88 SHA512 069e21ca8aa5b7d30ff7ea9f94bb4d939495f0ce30a831e985687eafe4cd22ce830af2427b645df16ddcd51126c366ff61243bb7251a2aecbef46b8573d2e124
DIST boto3-1.14.2.tar.gz 297730 BLAKE2B 174bc2435247db4421ffbf1ca0ef2cb772a9b6f357cbb438996ad635fca8ae5cd1005df3f8fdc6c63607797115c2379bb10c43edcfaf8393394f241b1e7a1ca1 SHA512 6ad539e568fe90c2f7408f37d28f194ac7094f6393858e487bf2afa73b8b53c90c8ab489bbe56f7c594351b24aaa82bfc9f81c9d68fadaecaec5acc3352fad5e
DIST boto3-1.14.5.tar.gz 297919 BLAKE2B 9428ddfa1a5549bfb8319cc91292dace9245a9db94eec373f571342808cdda7c1bf2b683ccddbcae532aca79666971b5cff7646756dff7baa24e291b348ff0f0 SHA512 7c65b1a1b6070b8954b7a705b1473543be6a4939c8594327cdaf8c91ff557bfdb49611e18f2bc6b0213fc13ef4cdbf57da7e632ac93dacf6d887f7a18889ff59
DIST boto3-1.14.8.tar.gz 297922 BLAKE2B e71a74155a6e32b310063c6c80ceb960db816898271f01066099d9ef162e90c5c446ea29b7164d957cc4d02e546eec59eb62f9168aa7e5f6e149c2d97fa14928 SHA512 a5c1c63664c406dc6b923ee565d30572173084b43a4539605cfc36a959d5d8fbcf0864720732128f26ba84fe8e4aabb31842d656e6e189860a41b365955e63ae
diff --git a/dev-python/boto3/boto3-1.14.11.ebuild b/dev-python/boto3/boto3-1.14.11.ebuild
new file mode 100644
index 000000000000..062b762234a9
--- /dev/null
+++ b/dev-python/boto3/boto3-1.14.11.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6..9} )
+DISTUTILS_USE_SETUPTOOLS=bdepend
+inherit distutils-r1
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="https://github.com/boto/boto3"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/boto3"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/boto/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+fi
+
+RDEPEND="
+ >=dev-python/botocore-1.17.0[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.3.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests nose
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # prevent an infinite loop
+ rm tests/functional/docs/test_smoke.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ nosetests -v tests/unit tests/functional ||
+ die "test failed under ${EPYTHON}"
+}