summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2016-05-31 07:09:50 +0200
committerJeroen Roovers <jer@gentoo.org>2016-05-31 07:10:05 +0200
commit5daaf978f951e762e5d4177ca11d3df786ecaedb (patch)
treed7aba29ba163c0bf7daf27bfd1a88eb484d696dc
parentdev-ruby/pdf-core: cleanup (diff)
downloadgentoo-5daaf978f951e762e5d4177ca11d3df786ecaedb.tar.gz
gentoo-5daaf978f951e762e5d4177ca11d3df786ecaedb.tar.bz2
gentoo-5daaf978f951e762e5d4177ca11d3df786ecaedb.zip
net-misc/youtube-dl: Version bump.
Package-Manager: portage-2.3.0_rc1
-rw-r--r--net-misc/youtube-dl/Manifest1
-rw-r--r--net-misc/youtube-dl/youtube-dl-2016.05.30.2.ebuild96
2 files changed, 97 insertions, 0 deletions
diff --git a/net-misc/youtube-dl/Manifest b/net-misc/youtube-dl/Manifest
index 41244be3021b..7ff33bbd0680 100644
--- a/net-misc/youtube-dl/Manifest
+++ b/net-misc/youtube-dl/Manifest
@@ -1,3 +1,4 @@
DIST youtube-dl-2016.01.01.tar.gz 1874602 SHA256 732f37c99d71b4239d72d61dd32214b5a5a618671fb0629c8f8deb28209a172c SHA512 fdb022bed426250e5ee1c2bcc1354dd195c0f9793ca479ca8ca4cfe2f71e07ba100b0dbcda2fb9f310308ab130587d06b16a6a86f9036f0d196b317d2e5b5e92 WHIRLPOOL 152e709ba15264c35a89644ea0d4793bb47c82b317e54043ccfff72e40bdf95e42d76605e801233632d3863537a945cfb9ecc2f75245171b8de31b51ce6af801
DIST youtube-dl-2016.05.16.tar.gz 2127223 SHA256 1d86102cb7f39c1a3441b70287cae55daef9724bacef4534287479d9c5c8ab0e SHA512 b1125f6857dc97a1464f91419b2b762c6aff4b7c2f599c651339797a293dc92f4763deefb4a432db4ac3088fdabd9cacf7d89f6d9725eb5ab50a5b59608df34d WHIRLPOOL 21ed93942ba1cd700e6a418767bfdaeec9f315738e50af2ef7870835d12391188cdfcda5ff11e8b50f06dc94e33d26efa4185b430273e6b6a6add2f535ae1346
DIST youtube-dl-2016.05.21.2.tar.gz 2156460 SHA256 66f94fc97012c4c7a6338dc4df6ec62af66dcfc144c5e8c8cd8b5519756f1a98 SHA512 0a3b4bac9a1a6d33859936335404c298322e3371a4d1455108e4c32b94e6427371fbcc59bc140c774fbefb42e262c0fc2b4e6a544b8dba687c35d1d7ae65c345 WHIRLPOOL 9b319d6fcbf3da8b03fcd6528f7ac2eaa1ba15da3af7eb035c7f7dc2c3b9f245bbb9cd2521c33f3ef8209f8ee75ad8e37631ee908d2a34f5e5d8001b06b711db
+DIST youtube-dl-2016.05.30.2.tar.gz 2151363 SHA256 1ffb367f65f5f0ebdaaee92db509e49e88cbd27fc83d34e80ec3e9b5a3c797ad SHA512 8baa4fd8da71a91a616bb16320c1dd5f7033b657460e0524e0c1b4daeaa70bdf2109bf710c5388db0f4c71f78495a3030b7e0d589439e5114769c53afb414bf1 WHIRLPOOL ad60d8c16cf7181044af8968c9bc61b3759828c85f05de5bfce145cbb13b5bc83dedb49e2e6b30e57aa2c69b318d6dc4f1ce9f70ccf3c28f614f0cd7446c43b2
diff --git a/net-misc/youtube-dl/youtube-dl-2016.05.30.2.ebuild b/net-misc/youtube-dl/youtube-dl-2016.05.30.2.ebuild
new file mode 100644
index 000000000000..969c3bf49e3d
--- /dev/null
+++ b/net-misc/youtube-dl/youtube-dl-2016.05.30.2.ebuild
@@ -0,0 +1,96 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=(python{2_7,3_3,3_4,3_5})
+DISTUTILS_SINGLE_IMPL=true
+inherit bash-completion-r1 distutils-r1 eutils
+
+DESCRIPTION="Download videos from YouTube.com (and more sites...)"
+HOMEPAGE="https://rg3.github.com/youtube-dl/"
+SRC_URI="http://youtube-dl.org/downloads/${PV}/${P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+IUSE="offensive test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[coverage(+)] )
+"
+
+S="${WORKDIR}/${PN}"
+
+src_prepare() {
+ if ! use offensive; then
+ sed -i -e "/__version__/s|'$|-gentoo_no_offensive_sites'|g" \
+ youtube_dl/version.py || die
+ # these have single line import statements
+ local xxx=(
+ alphaporno anysex behindkink camwithher chaturbate drtuber eporner
+ eroprofile extremetube fourtube foxgay goshgay hellporno
+ hentaistigma hornbunny keezmovies lovehomeporn mofosex motherless
+ myvidster porn91 pornhd pornotube pornovoisines pornoxo redtube
+ ruleporn sexu slutload spankbang spankwire sunporno thisav trutube
+ tube8 vporn watchindianporn xbef xnxx xtube xvideos xxxymovies
+ youjizz youporn
+ )
+ # these have multi-line import statements
+ local mxxx=(
+ pornhub xhamster tnaflix
+ )
+ # do single line imports
+ sed -i \
+ -e $( printf '/%s/d;' ${xxx[@]} ) \
+ youtube_dl/extractor/extractors.py \
+ || die
+
+ # do multiple line imports
+ sed -i \
+ -e $( printf '/%s/,/)/d;' ${mxxx[@]} ) \
+ youtube_dl/extractor/extractors.py \
+ || die
+
+ sed -i \
+ -e $( printf '/%s/d;' ${mxxx[@]} ) \
+ youtube_dl/extractor/generic.py \
+ || die
+
+ rm \
+ $( printf 'youtube_dl/extractor/%s.py ' ${xxx[@]} ) \
+ $( printf 'youtube_dl/extractor/%s.py ' ${mxxx[@]} ) \
+ test/test_age_restriction.py \
+ || die
+ fi
+
+ epatch_user
+}
+
+src_compile() {
+ distutils-r1_src_compile
+}
+
+src_test() {
+ emake test
+}
+
+src_install() {
+ python_domodule youtube_dl
+ dobin bin/${PN}
+
+ dodoc README.txt
+ doman ${PN}.1
+
+ newbashcomp ${PN}.bash-completion ${PN}
+
+ insinto /usr/share/zsh/site-functions
+ newins youtube-dl.zsh _youtube-dl
+
+ insinto /usr/share/fish/completions
+ doins youtube-dl.fish
+
+ python_fix_shebang "${ED}"
+}