summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2017-05-06 18:29:44 -0400
committerTim Harder <radhermit@gentoo.org>2017-05-06 18:39:18 -0400
commit5dac691df031ef91a218bdcebce573aa3cebff94 (patch)
tree079ea774fca05cd4ebc1c1aff49fd5d2b054d587
parentdev-python/setuptools: version bump to 35.0.2 (diff)
downloadgentoo-5dac691d.tar.gz
gentoo-5dac691d.tar.bz2
gentoo-5dac691d.zip
dev-python/xmltodict: version bump to 0.11.0
-rw-r--r--dev-python/xmltodict/Manifest1
-rw-r--r--dev-python/xmltodict/xmltodict-0.11.0.ebuild22
2 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/xmltodict/Manifest b/dev-python/xmltodict/Manifest
index c7d0b7a362b2..7966627d1371 100644
--- a/dev-python/xmltodict/Manifest
+++ b/dev-python/xmltodict/Manifest
@@ -1,2 +1,3 @@
DIST xmltodict-0.10.1.tar.gz 24620 SHA256 b2cab0184bbb8c3627fc54b03ed79ea2f4d5579fa041e3456ff8d3b3c09b0d5e SHA512 b2fdccf2a158256d8b2a78fdaf2c5527c6c25753da344864024fa8ef1d4e4b9a561d2802b10b668ea72af50dd41d05ca590dbf036a4b97c175b7788642ca3c63 WHIRLPOOL 4f239872ab411ec8c18c5184172e5cfa3a535ea3c86d92884e2993a57e10196925e32fd2139a76198d7cb739f0432cdf1d4fffc082b57c50946e5e4d2db21b1a
DIST xmltodict-0.10.2.tar.gz 24854 SHA256 fc518ccf9adbbb917a2ddcb386be852ae6dd36935e1e8b9a3e760201abfdbf77 SHA512 f734c80740b99f0ebb1c0d955094f63c5f513cf1055ac8577395f91ce1ee95dfc3712512b3e6b1f971637be9c345073a7536bd3bccd0175f191017b40a4f4537 WHIRLPOOL 441bc2fd8b6f7efe43b24aca747c1ded764025cb999f9e62da7a8934956eb0cf5616733ad9f3fb8bd7f33e7728037d0ab0ab48b61da4eb208ceaa61a66486072
+DIST xmltodict-0.11.0.tar.gz 26589 SHA256 8f8d7d40aa28d83f4109a7e8aa86e67a4df202d9538be40c0cb1d70da527b0df SHA512 d42ef146a40f386a5389958f890605c560ce9db2da4447099b8725edc1998339b77ea732576fc7e77fbe5a755a2dc3239dfae4a82fc6593c5f977145ab445295 WHIRLPOOL 8e21f0cd47a3ce4986173047d8120c97a8f95207a63a8479b18131da6851d239ac48772e088d24d8f16e6b1bc207fcc8e03a64f68e9de42e9ec7a55c47edce56
diff --git a/dev-python/xmltodict/xmltodict-0.11.0.ebuild b/dev-python/xmltodict/xmltodict-0.11.0.ebuild
new file mode 100644
index 000000000000..5e4278509d1c
--- /dev/null
+++ b/dev-python/xmltodict/xmltodict-0.11.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="Makes working with XML feel like you are working with JSON"
+HOMEPAGE="https://github.com/martinblech/xmltodict/ https://pypi.python.org/pypi/xmltodict/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+python_test() {
+ nosetests || die "Tests fail with ${EPYTHON}"
+}