summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org>2017-06-03 21:57:52 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2017-06-03 23:26:25 +0200
commit5db4188c44153a9072a15f19ac05e91b7ab0aaa8 (patch)
tree7e63575ddb540cd2b0e0c70b33261a652548633a
parentkde-apps/kaddressbook: Fix building in C++ 2011 and 2014 mode (diff)
downloadgentoo-5db4188c.tar.gz
gentoo-5db4188c.tar.bz2
gentoo-5db4188c.zip
kde-apps/kmail: Fix building in C++ 2011 and 2014 mode
-rw-r--r--kde-apps/kmail/files/kmail-4.4.2017.04-gcc6.patch42
-rw-r--r--kde-apps/kmail/kmail-4.4.2017.04.ebuild2
2 files changed, 44 insertions, 0 deletions
diff --git a/kde-apps/kmail/files/kmail-4.4.2017.04-gcc6.patch b/kde-apps/kmail/files/kmail-4.4.2017.04-gcc6.patch
new file mode 100644
index 000000000000..e4a891b8d1c8
--- /dev/null
+++ b/kde-apps/kmail/files/kmail-4.4.2017.04-gcc6.patch
@@ -0,0 +1,42 @@
+--- a/kmail/folderview.cpp
++++ b/kmail/folderview.cpp
+@@ -1907,7 +1907,7 @@
+ KGuiItem( i18n( "Go To" ) ),
+ KGuiItem( i18n( "Do Not Go To" ) ), // defaults
+ ":kmail_AskNextFolder",
+- false
++ 0
+ ) == KMessageBox::No
+ )
+ return true; // assume selected (do not continue looping)
+--- a/kmail/kmmainwidget.cpp
++++ b/kmail/kmmainwidget.cpp
+@@ -1588,7 +1588,7 @@
+ i18n( "Security Warning" ),
+ KGuiItem(i18n( "Use HTML" )),
+ KStandardGuiItem::cancel(),
+- "OverrideHtmlWarning", false);
++ "OverrideHtmlWarning", 0);
+ if( result == KMessageBox::Cancel ) {
+ mPreferHtmlAction->setChecked( false );
+ return;
+@@ -1617,7 +1617,7 @@
+ i18n( "Security Warning" ),
+ KGuiItem(i18n( "Load External References" )),
+ KStandardGuiItem::cancel(),
+- "OverrideHtmlLoadExtWarning", false);
++ "OverrideHtmlLoadExtWarning", 0);
+ if( result == KMessageBox::Cancel ) {
+ mPreferHtmlLoadExtAction->setChecked( false );
+ return;
+--- a/kmail/kmsender.cpp
++++ b/kmail/kmsender.cpp
+@@ -575,7 +575,7 @@
+ i18n( "Security Warning" ),
+ KGuiItem( i18n( "Send Unencrypted" ) ),
+ KStandardGuiItem::cancel(),
+- "useCustomTransportWithoutAsking", false );
++ "useCustomTransportWithoutAsking", 0 );
+
+ if ( result == KMessageBox::Cancel ) {
+ mProgressItem->cancel();
diff --git a/kde-apps/kmail/kmail-4.4.2017.04.ebuild b/kde-apps/kmail/kmail-4.4.2017.04.ebuild
index 30728aaf34ba..00c3717ccfd8 100644
--- a/kde-apps/kmail/kmail-4.4.2017.04.ebuild
+++ b/kde-apps/kmail/kmail-4.4.2017.04.ebuild
@@ -41,6 +41,8 @@ KMEXTRA="
"
KMLOADLIBS="libkdepim"
+PATCHES=( "${FILESDIR}/${P}-gcc6.patch" )
+
src_configure() {
mycmakeargs=(
-DWITH_IndicateQt=OFF