summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2017-03-28 13:02:49 +0200
committerLars Wendler <polynomial-c@gentoo.org>2017-03-28 13:03:32 +0200
commit5db974d42525a12ea043959c2dd24bab0730ed40 (patch)
tree864946801349d541d3b424a8b8e807900d5d295a
parentdev-libs/libpcre: arm stable (bug 609592). (diff)
downloadgentoo-5db974d42525a12ea043959c2dd24bab0730ed40.tar.gz
gentoo-5db974d42525a12ea043959c2dd24bab0730ed40.tar.bz2
gentoo-5db974d42525a12ea043959c2dd24bab0730ed40.zip
sys-libs/openipmi: Bump to version 2.0.23_rc1
Package-Manager: Portage-2.3.5, Repoman-2.3.2
-rw-r--r--sys-libs/openipmi/Manifest1
-rw-r--r--sys-libs/openipmi/openipmi-2.0.23_rc1.ebuild104
2 files changed, 105 insertions, 0 deletions
diff --git a/sys-libs/openipmi/Manifest b/sys-libs/openipmi/Manifest
index f8b4ded25a8d..46a247a298d1 100644
--- a/sys-libs/openipmi/Manifest
+++ b/sys-libs/openipmi/Manifest
@@ -1,3 +1,4 @@
DIST OpenIPMI-2.0.18.tar.gz 2895686 SHA256 6c1679a1c16aade48dd929e5124d2640ff12224ac0de1bb3777e9f1030d62e01 SHA512 a6caf791fb6d5bd83234481ea3c84a408dad3eabc093dbc4681742d23b47b223d0a1715a71a9b977a03a80f5c350dd34f6591ece5ea0d9876cb6debfc80a39d4 WHIRLPOOL 3b9bd32e01c118a450c5f6ec744b5cad521d41091f786a59485b91cde05ca184bdb4d8c05d53e9494966a9a733c560190f85208bedaa3b40e2cac116e3e6a84a
DIST OpenIPMI-2.0.21.tar.gz 3473323 SHA256 37b844d02119b94b31e2bb2bd8062ffdf6cd3eb4bc75fa6c47184e8b14fe95b8 SHA512 b684259ee5d47c36273fe6b47d60d0481c96b64b2e9421ce3190d9514e4f450b0db28d12c86a8814dcce23ba3ecfcecbbe9251d298244f1e9194a9f7563862a5 WHIRLPOOL 577da7215effe5f2e26616b4c744da42fd261263834d4d3d264220f95c4a60b3955c642d27c32af30dbf2ce0821078a463fa140edc9d3475daec7e6f84361958
DIST OpenIPMI-2.0.22.tar.gz 3081893 SHA256 4988900043c35fcfa9b2bf275d6593904f6429221befb770ba6ecb5502108e55 SHA512 78017fc0b52ce6a83db45f595f50170410120c9f7394429869c177ee40ea5b924bcc0e36bb60f9368a75a2f78ff71c70ae3631ba55a207cfb6eb4f62aa44ff89 WHIRLPOOL 2948006a489fc44a836aed5a6147b766fa06ab851b1e01bc0901e1bcad6b7d1b19bc352d2dd0130edf6750ed1822fb24203439185eef1328e7ba6adfdbdefb1a
+DIST OpenIPMI-2.0.23-rc1.tar.gz 3225557 SHA256 25bf1ad2889d5c28094bea45e8222084966c30cd17660c2993840eda2d05e98f SHA512 4da3d74073fe19573b8bc5fda15ecfa4d500a074559155456010e0bac8a8c2d345e30c086a851a9a4e7266165dd9a7a6d8f618e65bad3c2b18fe86d8f4c362ab WHIRLPOOL f6e155cfa74f7654539bbe4940c646370c2faa57acfa72f29b07b29676323733f3f4a2887a317f8e39977abcb02a3a038b2fdb4ca8630d1de0e5a7f4e4cf83a3
diff --git a/sys-libs/openipmi/openipmi-2.0.23_rc1.ebuild b/sys-libs/openipmi/openipmi-2.0.23_rc1.ebuild
new file mode 100644
index 000000000000..3f4ded19e175
--- /dev/null
+++ b/sys-libs/openipmi/openipmi-2.0.23_rc1.ebuild
@@ -0,0 +1,104 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit eutils autotools python-single-r1
+
+DESCRIPTION="Library interface to IPMI"
+HOMEPAGE="https://sourceforge.net/projects/openipmi/"
+MY_PN="OpenIPMI"
+MY_P="${MY_PN}-${PV/_/-}"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1 GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~x86"
+IUSE="crypt snmp perl python tcl"
+S="${WORKDIR}/${MY_P}"
+RESTRICT='test'
+
+RDEPEND="
+ dev-libs/glib:2
+ sys-libs/gdbm
+ sys-libs/ncurses:0=
+ crypt? ( dev-libs/openssl:0= )
+ snmp? ( net-analyzer/net-snmp )
+ perl? ( dev-lang/perl )
+ python? ( ${PYTHON_DEPS} )
+ tcl? ( dev-lang/tcl:0= )"
+DEPEND="${RDEPEND}
+ >=dev-lang/swig-1.3.21
+ virtual/pkgconfig"
+# Gui is broken!
+# python? ( tcl? ( tk? ( dev-lang/tk dev-tcltk/tix ) ) )"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+PATCHES=(
+ # Bug #338499: The installed OpenIPMIpthread.pc depends on a non-existing
+ # pthread.pc. We patch it to link -lpthread directly instead.
+ "${FILESDIR}/${PN}-2.0.16-pthreads.patch"
+
+ # https://bugs.gentoo.org/501510
+ "${FILESDIR}/${PN}-2.0.21-tinfo.patch"
+)
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+
+ # Bug #290763: The buildsys tries to compile+optimize the py file during
+ # install, when the .so might not be been added yet. We just skip the files
+ # and use python_optimize ourselves later instead.
+ sed -r -i \
+ -e '/INSTALL.*\.py[oc] /d' \
+ -e '/install-exec-local/s,OpenIPMI.pyc OpenIPMI.pyo,,g' \
+ swig/python/Makefile.{am,in}
+
+ # Bug #298250: parallel install fix.
+ sed -r -i \
+ -e '/^install-data-local:/s,$, install-exec-am,g' \
+ cmdlang/Makefile.{am,in}
+
+ # We touch the .in and .am above because if we use the below, the Perl stuff
+ # is very fragile, and often fails to link.
+ #cd "${S}"
+ eautoreconf
+}
+
+src_configure() {
+ local myconf=()
+ myconf+=( $(use_with snmp ucdsnmp yes) )
+ myconf+=( $(use_with crypt openssl yes) )
+ myconf+=( $(use_with perl perl yes) )
+ myconf+=( $(use_with tcl tcl yes) )
+ myconf+=( $(use_with python python yes) )
+
+ # GUI is broken
+ #use tk && use python && use !tcl && \
+ # ewarn "Not building Tk GUI because it needs both Python AND Tcl"
+ #if use python && use tcl; then
+ # myconf+=( $(use_with tk tkinter) )
+ #else
+ # myconf+=( --without-tkinter )
+ #fi
+
+ myconf+=( --without-tkinter )
+ myconf+=( --with-glib --with-glibver=2.0 --with-glib12=no --with-swig )
+ # these binaries are for root!
+ econf ${myconf[@]} --bindir=/usr/sbin
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc README* FAQ ChangeLog TODO doc/IPMI.pdf lanserv/README.vm
+ newdoc cmdlang/README README.cmdlang
+
+ use python && python_optimize
+}