summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-06-11 06:50:43 +0100
committerSam James <sam@gentoo.org>2022-06-11 06:50:43 +0100
commit5dcd1282bb88bec17d5eed2f93f4ee73b4fff978 (patch)
treec5fa41cd1120b567474d080283fa9cacd185a8ec
parentsys-apps/fwts: drop 20.11.00 (diff)
downloadgentoo-5dcd1282bb88bec17d5eed2f93f4ee73b4fff978.tar.gz
gentoo-5dcd1282bb88bec17d5eed2f93f4ee73b4fff978.tar.bz2
gentoo-5dcd1282bb88bec17d5eed2f93f4ee73b4fff978.zip
sys-apps/dchroot: drop Werror
Bug: https://bugs.gentoo.org/824542 Closes: https://bugs.gentoo.org/722920 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--sys-apps/dchroot/dchroot-0.12.1.ebuild9
-rw-r--r--sys-apps/dchroot/files/dchroot-0.12.1-no-werror.patch13
2 files changed, 20 insertions, 2 deletions
diff --git a/sys-apps/dchroot/dchroot-0.12.1.ebuild b/sys-apps/dchroot/dchroot-0.12.1.ebuild
index eee10e8bef06..7f02674ae0ae 100644
--- a/sys-apps/dchroot/dchroot-0.12.1.ebuild
+++ b/sys-apps/dchroot/dchroot-0.12.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -17,13 +17,18 @@ IUSE=""
DEPEND="sys-apps/help2man"
RDEPEND="!dev-util/schroot[dchroot]"
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.12.1-no-werror.patch
+)
+
src_prepare() {
- default
sed -i \
-e '/^all:/s:$: docs:' \
-e '/^CFLAGS/s:-O2:@CFLAGS@:' \
-e '/@CFLAGS@/ s:@CFLAGS@:@CFLAGS@ @LDFLAGS@:' \
Makefile.in || die "sed failed"
+
+ default
}
src_compile() {
diff --git a/sys-apps/dchroot/files/dchroot-0.12.1-no-werror.patch b/sys-apps/dchroot/files/dchroot-0.12.1-no-werror.patch
new file mode 100644
index 000000000000..4cd270190456
--- /dev/null
+++ b/sys-apps/dchroot/files/dchroot-0.12.1-no-werror.patch
@@ -0,0 +1,13 @@
+https://bugs.gentoo.org/824542
+https://bugs.gentoo.org/722920
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -3,7 +3,7 @@ mandir = ${prefix}/share/man
+ sysconfdir = $(DESTDIR)/etc
+
+ INSTALL=install
+-CFLAGS=-Wl,-z,now @CFLAGS@ @LDFLAGS@ -Wall -Wstrict-prototypes -Werror -g \
++CFLAGS=-Wl,-z,now @CFLAGS@ @LDFLAGS@ -Wall -Wstrict-prototypes \
+ -DDCHROOT_VERSION="\"@DCHROOT_VERSION@\""
+
+ all: dchroot docs