summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-01-26 15:22:02 +0000
committerSam James <sam@gentoo.org>2021-01-26 15:49:34 +0000
commit5ddbebd6166839690c9199efe9e2848dd10fd316 (patch)
tree1d7b2727c1efd1faee0e277c6a2d5496707e4e9f
parentnet-misc/networkmanager: Revbump to add support for net-misc/dhcpcd-9 (diff)
downloadgentoo-5ddbebd6166839690c9199efe9e2848dd10fd316.tar.gz
gentoo-5ddbebd6166839690c9199efe9e2848dd10fd316.tar.bz2
gentoo-5ddbebd6166839690c9199efe9e2848dd10fd316.zip
dev-python/sympy: cleanup old
Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-python/sympy/Manifest1
-rw-r--r--dev-python/sympy/sympy-1.6.2.ebuild65
2 files changed, 0 insertions, 66 deletions
diff --git a/dev-python/sympy/Manifest b/dev-python/sympy/Manifest
index 7a8476d16bf4..012659200257 100644
--- a/dev-python/sympy/Manifest
+++ b/dev-python/sympy/Manifest
@@ -1,2 +1 @@
-DIST sympy-1.6.2.tar.gz 6811705 BLAKE2B 4cd894d28bedc986acc8ef67aa60f82e0899c2ed028658a8f340d7538b890e0ed380b3614a464eb58d71873b29b0795508b4556bb8115bf0c108336ef1e4cca3 SHA512 e16a1d85aba438e4248bac48a163ea1827e2cee57c28f7670ed19cc69d4c08d6796d62f79d245e269d75765b8f7ff4f4ca2841f98534e136ceeb5d3f7a5d252a
DIST sympy-1.7.1.tar.gz 6974183 BLAKE2B 4bd8c9d60c46b05a7fc6c622667858fe17d25798756dbe967ce19abc8047263fe540f332e39418e877852c0565270377bd01fea7e65aa35ed4e03079bc130805 SHA512 eb9387bb9c632203af650279f896427556725b7496c00d8dfe97b7476beedbbee5714659f7fb44b4fa986c9567cdcaefcc19401d63e1ca0e9a6c7317855440ea
diff --git a/dev-python/sympy/sympy-1.6.2.ebuild b/dev-python/sympy/sympy-1.6.2.ebuild
deleted file mode 100644
index e389acdbe485..000000000000
--- a/dev-python/sympy/sympy-1.6.2.ebuild
+++ /dev/null
@@ -1,65 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7,8,9} )
-
-inherit distutils-r1 eutils virtualx
-
-DESCRIPTION="Computer Algebra System in pure Python"
-HOMEPAGE="https://sympy.org"
-SRC_URI="https://github.com/sympy/sympy/archive/${P}.tar.gz"
-S="${WORKDIR}/${PN}-${P}"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
-IUSE="examples imaging ipython latex mathml opengl pdf png pyglet symengine test texmacs theano"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-RESTRICT="!test? ( test )"
-
-BDEPEND="test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
-RDEPEND="dev-python/mpmath[${PYTHON_USEDEP}]
- dev-python/pexpect[${PYTHON_USEDEP}]
- imaging? ( dev-python/pillow[${PYTHON_USEDEP}] )
- ipython? ( dev-python/ipython[${PYTHON_USEDEP}] )
- latex? (
- virtual/latex-base
- dev-texlive/texlive-fontsextra
- png? ( app-text/dvipng )
- pdf? ( app-text/ghostscript-gpl )
- )
- mathml? ( dev-libs/libxml2:2[${PYTHON_USEDEP}] )
- opengl? ( dev-python/pyopengl[${PYTHON_USEDEP}] )
- pyglet? ( dev-python/pyglet[${PYTHON_USEDEP}] )
- symengine? ( dev-python/symengine[${PYTHON_USEDEP}] )
- texmacs? ( app-office/texmacs )
- theano? ( dev-python/theano[${PYTHON_USEDEP}] )
-"
-
-src_test() {
- virtx distutils-r1_src_test
-}
-
-python_test() {
- "${EPYTHON}" setup.py test || die "Tests failed with ${EPYTHON}"
-}
-
-python_install_all() {
- local DOCS=( AUTHORS README.md )
-
- if use examples; then
- dodoc -r examples
- docompress -x /usr/share/doc/${PF}/examples
- fi
-
- distutils-r1_python_install_all
-
- if use texmacs; then
- exeinto /usr/libexec/TeXmacs/bin/
- doexe data/TeXmacs/bin/tm_sympy
- insinto /usr/share/TeXmacs/plugins/sympy/
- doins -r data/TeXmacs/progs
- fi
-}