summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-05-03 08:41:38 +0200
committerMichał Górny <mgorny@gentoo.org>2020-05-03 09:07:29 +0200
commit5e0bfdeef5d4348633d1479886d5f27704b58841 (patch)
tree7d59ed279dde3c9662439e739850c9a1ca4a38ca
parentnet-misc/youtube-dl: Version 2020.05.03 (diff)
downloadgentoo-5e0bfdeef5d4348633d1479886d5f27704b58841.tar.gz
gentoo-5e0bfdeef5d4348633d1479886d5f27704b58841.tar.bz2
gentoo-5e0bfdeef5d4348633d1479886d5f27704b58841.zip
dev-python/rebulk: Bump to 2.0.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/rebulk/Manifest1
-rw-r--r--dev-python/rebulk/rebulk-2.0.1.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/rebulk/Manifest b/dev-python/rebulk/Manifest
index e079271f18e7..1682c45693d9 100644
--- a/dev-python/rebulk/Manifest
+++ b/dev-python/rebulk/Manifest
@@ -1 +1,2 @@
DIST rebulk-0.9.0.tar.gz 257342 BLAKE2B a08b2d74685eea35597331bb2ef3c48e8a9cddc39ad3821cb7f33b80a47184a21f813b339e9d64548b3003913178191075455a6f787ab80ffa2cb3bf7f0db35d SHA512 25a22b3a5f5519f6f8c10abf6a477f212c0500264cfdcc5a9be09d3818462a051b1a7cd78f94991c44ac6bcdc7435b9909e65de48d1bd8138989e0da98d10262
+DIST rebulk-2.0.1.tar.gz 258115 BLAKE2B d19210911cf89cb7c371819e384da95c2159eb92abf9f027cbdf1803a18054c556e73364ae10c5bb0b5007cbdb2156b2118d22d6e278b6a02055bacbcbdbc322 SHA512 7d453b7ba952994dec3258aa95a3f6090e6f8afb5a674c1b5e54e036f41022b887d3d65d21f2023ae6e2596cce3baf52d33fc23708498a4f0aef26d3594c8289
diff --git a/dev-python/rebulk/rebulk-2.0.1.ebuild b/dev-python/rebulk/rebulk-2.0.1.ebuild
new file mode 100644
index 000000000000..65549c458c29
--- /dev/null
+++ b/dev-python/rebulk/rebulk-2.0.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python library that performs advanced searches in strings"
+HOMEPAGE="https://github.com/Toilal/rebulk https://pypi.org/project/rebulk/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # Remove base64-encoded zip archive with pytest.
+ rm runtests.py || die
+
+ # Disable unconditional dependency on dev-python/pytest-runner.
+ sed -i -e "s|'pytest-runner'||g" setup.py || die
+
+ distutils-r1_python_prepare_all
+}