summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2021-08-03 17:36:47 +0200
committerAlexis Ballier <aballier@gentoo.org>2021-08-03 17:52:00 +0200
commit5e0ebdb72a998c15ae7868188ee62385d99b50b3 (patch)
tree65d3457eca0efa4bcc6e2f282c244b1a708f41aa
parentsys-libs/libcxxabi: Fix building in 13+ (diff)
downloadgentoo-5e0ebdb72a998c15ae7868188ee62385d99b50b3.tar.gz
gentoo-5e0ebdb72a998c15ae7868188ee62385d99b50b3.tar.bz2
gentoo-5e0ebdb72a998c15ae7868188ee62385d99b50b3.zip
sci-electronics/gazebo: bump to 11.7.0
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
-rw-r--r--sci-electronics/gazebo/Manifest1
-rw-r--r--sci-electronics/gazebo/gazebo-11.7.0.ebuild83
2 files changed, 84 insertions, 0 deletions
diff --git a/sci-electronics/gazebo/Manifest b/sci-electronics/gazebo/Manifest
index 37aedcf536e5..a45f1992f390 100644
--- a/sci-electronics/gazebo/Manifest
+++ b/sci-electronics/gazebo/Manifest
@@ -1,2 +1,3 @@
DIST gazebo-11.3.0.tar.bz2 56778002 BLAKE2B d466556c834935d8b3694461ddf6d7a7872b00d2f8f58d50d70cceb8bca3ab4ada1e72e7bb14b79404d45c48f95419e3dedd9019ecc3a8c1623afda077bcbeb2 SHA512 2e219655e45a787aeda50065dcec5d90954c18223f134d6da90b8cb43e119268262e515e527547d0b0b5ed1f73b5083d279551a01faa3d3c34ba7a580c077970
DIST gazebo-11.5.1.tar.bz2 56486174 BLAKE2B c1bffc5067f2739a8eb2e178bb2209d9c7b5a58d0589710cc515c4bcbbca281fb94ddf16de977f3771bc4b64fb6afe8e86327dde00d19ef62754e4d7634bb65f SHA512 7c922963881cf079e926c239f510e722fc6cabd07ef5e846a4b78772364a3aecb0b68f2b690ff451d42ceb11e88e2f831c30515e5a228f12826516ecad10e53a
+DIST gazebo-11.7.0.tar.bz2 56394312 BLAKE2B 2da58a2702113c1954f0202bb779b723ad8e59cab678f9ca6fe64908785198b996ef71c845a1a85f00e2f4eddb9ed5683f815ada850917b2af4afad214eac77d SHA512 7de40908a021655b2a200a73cf979585f4bdb245064f7e9a853998f87df329223252c73882aa1e2b705bc7de5841e2a87d67f772dfef18e5735c1b06c2663192
diff --git a/sci-electronics/gazebo/gazebo-11.7.0.ebuild b/sci-electronics/gazebo/gazebo-11.7.0.ebuild
new file mode 100644
index 000000000000..d2074820693c
--- /dev/null
+++ b/sci-electronics/gazebo/gazebo-11.7.0.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake flag-o-matic
+
+DESCRIPTION="A 3D multiple robot simulator with dynamics"
+HOMEPAGE="http://gazebosim.org/"
+SRC_URI="https://osrf-distributions.s3.amazonaws.com/gazebo/releases/${P}.tar.bz2"
+
+LICENSE="Apache-2.0"
+# Subslot = major version = soname of libs
+SLOT="0/11"
+KEYWORDS="~amd64"
+IUSE="cpu_flags_x86_sse2 test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-libs/protobuf-2:=
+ virtual/opengl
+ media-libs/openal
+ net-misc/curl
+ dev-libs/tinyxml
+ >=dev-libs/tinyxml2-6:=
+ dev-libs/libtar
+ dev-cpp/tbb
+ >=dev-games/ogre-1.7.4:=[freeimage]
+ <dev-games/ogre-1.10
+ >=media-libs/freeimage-3.15.4[png]
+ sci-libs/libccd
+ >=media-video/ffmpeg-2.6:0=
+ sci-libs/gts
+ >=sci-physics/bullet-2.82:=
+ >=dev-libs/sdformat-9.1:=
+ dev-qt/qtwidgets:5
+ dev-qt/qtcore:5
+ dev-qt/qtopengl:5
+ dev-libs/boost:=[threads(+)]
+ sci-libs/gdal:=
+ virtual/libusb:1
+ dev-libs/libspnav
+ media-libs/freeimage
+ sci-libs/hdf5:=[cxx]
+ sys-apps/util-linux
+ media-gfx/graphviz
+ net-libs/ignition-msgs:5=
+ sci-libs/ignition-math:6=
+ net-libs/ignition-transport:8=
+ sci-libs/ignition-common:3=
+ sci-libs/ignition-fuel-tools:4=
+ x11-libs/qwt:6=[qt5(+)]
+"
+DEPEND="${RDEPEND}
+ dev-qt/qttest:5
+ x11-apps/mesa-progs
+ test? ( dev-libs/libxslt )
+"
+BDEPEND="
+ app-text/ronn
+ app-arch/gzip
+ virtual/pkgconfig
+"
+CMAKE_BUILD_TYPE=RelWithDebInfo
+PATCHES=(
+ "${FILESDIR}/qwt.patch"
+ "${FILESDIR}/cmake.patch"
+)
+
+src_configure() {
+ # find OGRE properly
+ sed -e "s#lib/OGRE#$(get_libdir)/OGRE#" -i cmake/gazebo-config.cmake.in || die
+
+ local mycmakeargs=(
+ "-DUSE_UPSTREAM_CFLAGS=OFF"
+ "-DSSE2_FOUND=$(usex cpu_flags_x86_sse2 TRUE FALSE)"
+ "-DUSE_HOST_CFLAGS=FALSE"
+ "-DBUILD_TESTING=$(usex test TRUE FALSE)"
+ "-DENABLE_SCREEN_TESTS=FALSE"
+ "-DUSE_EXTERNAL_TINYXML2=TRUE"
+ )
+ cmake_src_configure
+}