summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel M. Weeks <dan@danweeks.net>2020-12-27 10:25:02 -0500
committerSam James <sam@gentoo.org>2021-05-17 20:40:57 +0000
commit5e1231be59417d7a35a50639b1e610ea1741590e (patch)
treeb7acf8c4db1c4297a5ab351c270be62fe5f7224d
parentsci-geosciences/qgis: adapt path for grass78 (current ebuild) (diff)
downloadgentoo-5e1231be59417d7a35a50639b1e610ea1741590e.tar.gz
gentoo-5e1231be59417d7a35a50639b1e610ea1741590e.tar.bz2
gentoo-5e1231be59417d7a35a50639b1e610ea1741590e.zip
sci-geosciences/qgis: Make qtserialport optional
Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Daniel M. Weeks <dan@danweeks.net> Closes: https://github.com/gentoo/gentoo/pull/18836 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--sci-geosciences/qgis/metadata.xml1
-rw-r--r--sci-geosciences/qgis/qgis-3.16.2-r1.ebuild (renamed from sci-geosciences/qgis/qgis-3.16.2.ebuild)5
-rw-r--r--sci-geosciences/qgis/qgis-3.16.4.ebuild5
3 files changed, 7 insertions, 4 deletions
diff --git a/sci-geosciences/qgis/metadata.xml b/sci-geosciences/qgis/metadata.xml
index 6d6203f5ceac..c54d18216564 100644
--- a/sci-geosciences/qgis/metadata.xml
+++ b/sci-geosciences/qgis/metadata.xml
@@ -23,5 +23,6 @@
<flag name="opencl">Enable OpenCL support</flag>
<flag name="polar">Enable support for the polar coordinate system via <pkg>x11-libs/qwtpolar</pkg></flag>
<flag name="qml">Enable support Qml-based plugins using <pkg>dev-qt/qtdeclarative</pkg></flag>
+ <flag name="serial">Enable support for serial GPS using <pkg>dev-qt/qtserialport</pkg></flag>
</use>
</pkgmetadata>
diff --git a/sci-geosciences/qgis/qgis-3.16.2.ebuild b/sci-geosciences/qgis/qgis-3.16.2-r1.ebuild
index ec3f713c80a3..eb880dfdcb7b 100644
--- a/sci-geosciences/qgis/qgis-3.16.2.ebuild
+++ b/sci-geosciences/qgis/qgis-3.16.2-r1.ebuild
@@ -21,7 +21,7 @@ HOMEPAGE="https://www.qgis.org/en/site/"
LICENSE="GPL-2+ GPL-3+"
SLOT="0"
-IUSE="3d examples georeferencer grass hdf5 mapserver netcdf opencl oracle polar postgres python qml"
+IUSE="3d examples georeferencer grass hdf5 mapserver netcdf opencl oracle polar postgres python qml serial"
REQUIRED_USE="${PYTHON_REQUIRED_USE} mapserver? ( python )"
@@ -45,7 +45,6 @@ COMMON_DEPEND="
dev-qt/qtnetwork:5[ssl]
dev-qt/qtpositioning:5
dev-qt/qtprintsupport:5
- dev-qt/qtserialport:5
dev-qt/qtsql:5
dev-qt/qtsvg:5
dev-qt/qtwidgets:5
@@ -92,6 +91,7 @@ COMMON_DEPEND="
')
)
qml? ( dev-qt/qtdeclarative:5 )
+ serial? ( dev-qt/qtserialport:5 )
"
DEPEND="${COMMON_DEPEND}
dev-qt/qttest:5
@@ -149,6 +149,7 @@ src_configure() {
-DWITH_BINDINGS=$(usex python)
-DWITH_CUSTOM_WIDGETS=$(usex python)
-DWITH_QUICK=$(usex qml)
+ -DWITH_QT5SERIALPORT=$(usex serial)
-DWITH_QTWEBKIT=OFF
)
diff --git a/sci-geosciences/qgis/qgis-3.16.4.ebuild b/sci-geosciences/qgis/qgis-3.16.4.ebuild
index de610e62b0f5..80d2d3168813 100644
--- a/sci-geosciences/qgis/qgis-3.16.4.ebuild
+++ b/sci-geosciences/qgis/qgis-3.16.4.ebuild
@@ -21,7 +21,7 @@ HOMEPAGE="https://www.qgis.org/en/site/"
LICENSE="GPL-2+ GPL-3+"
SLOT="0"
-IUSE="3d examples georeferencer grass hdf5 mapserver netcdf opencl oracle polar postgres python qml"
+IUSE="3d examples georeferencer grass hdf5 mapserver netcdf opencl oracle polar postgres python qml serial"
REQUIRED_USE="${PYTHON_REQUIRED_USE} mapserver? ( python )"
@@ -45,7 +45,6 @@ COMMON_DEPEND="
dev-qt/qtnetwork:5[ssl]
dev-qt/qtpositioning:5
dev-qt/qtprintsupport:5
- dev-qt/qtserialport:5
dev-qt/qtsql:5
dev-qt/qtsvg:5
dev-qt/qtwidgets:5
@@ -92,6 +91,7 @@ COMMON_DEPEND="
')
)
qml? ( dev-qt/qtdeclarative:5 )
+ serial? ( dev-qt/qtserialport:5 )
"
DEPEND="${COMMON_DEPEND}
dev-qt/qttest:5
@@ -149,6 +149,7 @@ src_configure() {
-DWITH_BINDINGS=$(usex python)
-DWITH_CUSTOM_WIDGETS=$(usex python)
-DWITH_QUICK=$(usex qml)
+ -DWITH_QT5SERIALPORT=$(usex serial)
-DWITH_QTWEBKIT=OFF
)