summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2021-12-11 15:26:23 -0500
committerIonen Wolkens <ionen@gentoo.org>2021-12-11 15:27:19 -0500
commit5e1bdd09abdc417a215c4199bbdb4ddd872c21c8 (patch)
tree1faad038dee3aac6fe0d129dc37939ed59949ce0
parentprofiles/package.mask keep dev-java/jackson (diff)
downloadgentoo-5e1bdd09.tar.gz
gentoo-5e1bdd09.tar.bz2
gentoo-5e1bdd09.zip
games-board/pysolfc: add 2.14.1
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
-rw-r--r--games-board/pysolfc/Manifest1
-rw-r--r--games-board/pysolfc/pysolfc-2.14.1.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/games-board/pysolfc/Manifest b/games-board/pysolfc/Manifest
index 082d57d9679e..9d87f01439f1 100644
--- a/games-board/pysolfc/Manifest
+++ b/games-board/pysolfc/Manifest
@@ -1,3 +1,4 @@
DIST PySolFC-2.14.0.tar.xz 4358664 BLAKE2B cadb5d1e63415d66b71f5679b9188335a4ec5e399e4437a9c4606d820f5a67613d5faa4e6a9cbb665913e5d4b0ca5d73ee8807e6baca0f5b3547d3a760e6bcd2 SHA512 0215276e5cc8caaefa0d7212d675af32e935b3ae4d4839624b34e8d68f0fc7e09accedf3b8e6428b349fe5c2ee7b4c128cd209d074b2c24311fa54f1c7b0c68f
+DIST PySolFC-2.14.1.tar.xz 4359204 BLAKE2B 48b336b67608e14a2d45923367527564d8c4fcf99f8a80e2a231f7885bd84276ad0b86db8cc31c0b33573ea4232334277458753ce72a727af293cb3f1bd6738c SHA512 e1ef4024d61aa9d86fd5e54ccacf12466e05038ad46e814e066ac3e81839c7ff03a59ace6e50aed8c44887a3620c3b36d25b9916ea564fec8a579e473c3684c0
DIST PySolFC-Cardsets--Minimal-2.0.2.tar.xz 6969096 BLAKE2B 50e87073cf4ab69031e1e4116115ddb1771197da176ac609c09e2f5fab1cc48ccb6f3ba40d7b581f67013835893106f7ab579a2cbc744aad98095944fbd2d5d9 SHA512 5317866d6259b154219ec6efea349af3f9cb0fe9309a895ee55f7be87ebc8c34df12b81a08e1dee907a3f475f4e623c3609fdbd7e357890c2ade418ec5d68cb2
DIST PySolFC-Cardsets-2.1PRE.tar.bz2 34399177 BLAKE2B 12f577e67e858b96e9d76bb3aceafaaf1cb267b1805c91f36a51ae0b92652cc265d675543bc16923b216b125142b36aee858b54c2dc8f2eeccdd0d6c3e435fe7 SHA512 7fb83450fb3579d9a4e3e0ec1404d5da779c3e99d0ceaaad9d35adf599e2d9ef173f9d2bbf272ff08dc3c3e043a5dda78ae054c95c6fad828e80dff4c9011314
diff --git a/games-board/pysolfc/pysolfc-2.14.1.ebuild b/games-board/pysolfc/pysolfc-2.14.1.ebuild
new file mode 100644
index 000000000000..083dd7e939d7
--- /dev/null
+++ b/games-board/pysolfc/pysolfc-2.14.1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+DISTUTILS_SINGLE_IMPL=1
+PYTHON_REQ_USE="tk"
+inherit distutils-r1 xdg
+
+MY_PN="PySolFC"
+MY_P="${MY_PN}-${PV}"
+PS_CARD_P="${MY_PN}-Cardsets-2.1PRE"
+PS_CARD_MIN_P="${MY_PN}-Cardsets--Minimal-2.0.2"
+
+DESCRIPTION="Exciting collection of more than 1000 solitaire card games"
+HOMEPAGE="https://pysolfc.sourceforge.io/"
+SRC_URI="mirror://sourceforge/pysolfc/${MY_P}.tar.xz
+ extra-cardsets? ( mirror://sourceforge/pysolfc/${PS_CARD_P}.tar.bz2 )
+ !extra-cardsets? ( mirror://sourceforge/pysolfc/${PS_CARD_MIN_P}.tar.xz )"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="GPL-3+ GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="extra-cardsets minimal +sound"
+
+RDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/attrs[${PYTHON_USEDEP}]
+ dev-python/configobj[${PYTHON_USEDEP}]
+ dev-python/pysol_cards[${PYTHON_USEDEP}]
+ dev-python/random2[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ !minimal? (
+ dev-python/pillow[jpeg,tk,${PYTHON_USEDEP}]
+ dev-tcltk/tktable
+ )
+ sound? ( dev-python/pygame[${PYTHON_USEDEP}] )
+ ')"
+
+distutils_enable_tests unittest
+
+python_install_all() {
+ local DOCS=( AUTHORS.md NEWS.asciidoc README.md )
+ distutils-r1_python_install_all
+
+ doman docs/pysol{,fc}.6
+
+ insinto /usr/share/${MY_PN}
+ doins -r ../$(usex extra-cardsets ${PS_CARD_P} ${PS_CARD_MIN_P})/.
+
+ # html files are used at runtime, keep at default location
+ dosym -r /usr/share/{${MY_PN},doc/${PF}}/html
+
+ # russion translation is currently not displaying right
+ rm "${ED}"/usr/share/locale/ru/LC_MESSAGES/pysol.mo || die
+}