summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolic <jakov.smolic@sartura.hr>2021-02-13 20:45:05 +0100
committerConrad Kostecki <conikost@gentoo.org>2021-02-13 21:59:26 +0100
commit5e34d641193b9db174117d3b5cf9b23904ff0bff (patch)
tree0d90c7f368e4224606c23012396cdbcccad7adcf
parentsys-cluster/nova: add missing udev inherit (diff)
downloadgentoo-5e34d641193b9db174117d3b5cf9b23904ff0bff.tar.gz
gentoo-5e34d641193b9db174117d3b5cf9b23904ff0bff.tar.bz2
gentoo-5e34d641193b9db174117d3b5cf9b23904ff0bff.zip
media-libs/libde265: Remove old
Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr> Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
-rw-r--r--media-libs/libde265/Manifest2
-rw-r--r--media-libs/libde265/files/libde265-1.0.3-use-new-FFMPEG-enum-names.patch24
-rw-r--r--media-libs/libde265/libde265-1.0.3.ebuild74
-rw-r--r--media-libs/libde265/libde265-1.0.5.ebuild99
-rw-r--r--media-libs/libde265/metadata.xml1
5 files changed, 0 insertions, 200 deletions
diff --git a/media-libs/libde265/Manifest b/media-libs/libde265/Manifest
index 465223a3e67e..2fd004d257a4 100644
--- a/media-libs/libde265/Manifest
+++ b/media-libs/libde265/Manifest
@@ -1,3 +1 @@
-DIST libde265-1.0.3.tar.gz 399996 BLAKE2B 988b21085f82d3b33b0480542677be96db5219c1b767aae3674f89862fdaf3355dcfea3fa99699798a4fcc6b72a63a3a6f61a3fd8d2ea8483231205cd6d87175 SHA512 0153632afcc9733950e8354997ccd93eddad90e8e0f7362bfe49b93b11cb1756cf803d0ba5c07042aee80e18227613af768ca82baf7891c687edf5e253a129c4
-DIST libde265-1.0.5.tar.gz 381041 BLAKE2B d561a0e5f308bed557237b88317985912537f76701783bc30d81305cf9026a853746449ece5b3092534466ea13d67bac10b3258580c8de07489844bbef0395db SHA512 3ff7310fc4621cac0ef1cb9bbc4df61724f8943d57f5263a3663a77f4d90d84716b2a708ee9fec306e909dc8b5e7fe645a641b6a6db795a89a01799be910831e
DIST libde265-1.0.8.tar.gz 381963 BLAKE2B 0577623de2ef86e1122b5b5c3642a750bb222c4988a996168e060e8ffd9f5c0787d31331cc8738362d3fc3fb31e8eb659629cab068f0ff1c71de9d15ed1f2ceb SHA512 0007138cb5da0d4cad1e118c01de249580f39c387a11f490d1e1f63ad0968ee2f7951e54580f298b3dbe31e5a3d1a7fa04454e11cbb82beaf8a9aaf56f5532ed
diff --git a/media-libs/libde265/files/libde265-1.0.3-use-new-FFMPEG-enum-names.patch b/media-libs/libde265/files/libde265-1.0.3-use-new-FFMPEG-enum-names.patch
deleted file mode 100644
index 33e73c15a93f..000000000000
--- a/media-libs/libde265/files/libde265-1.0.3-use-new-FFMPEG-enum-names.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-https://bugs.gentoo.org/575554
-
-From e5b8e2e703d608777afadc54955bd396e4211da0 Mon Sep 17 00:00:00 2001
-From: Dirk Farin <farin@struktur.de>
-Date: Thu, 19 Apr 2018 13:15:18 +0200
-Subject: [PATCH] use new FFMPEG enum names
-
----
- sherlock265/VideoDecoder.cc | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/sherlock265/VideoDecoder.cc b/sherlock265/VideoDecoder.cc
-index 119f6152..b829e1c7 100644
---- a/sherlock265/VideoDecoder.cc
-+++ b/sherlock265/VideoDecoder.cc
-@@ -237,7 +237,7 @@ void VideoDecoder::convert_frame_swscale(const de265_image* img, QImage & qimg)
- }
- width = img->get_width();
- height = img->get_height();
-- sws = sws_getContext(width, height, PIX_FMT_YUV420P, width, height, PIX_FMT_BGRA, SWS_FAST_BILINEAR, NULL, NULL, NULL);
-+ sws = sws_getContext(width, height, AV_PIX_FMT_YUV420P, width, height, AV_PIX_FMT_BGRA, SWS_FAST_BILINEAR, NULL, NULL, NULL);
- }
-
- int stride[3];
diff --git a/media-libs/libde265/libde265-1.0.3.ebuild b/media-libs/libde265/libde265-1.0.3.ebuild
deleted file mode 100644
index 7eec974a733b..000000000000
--- a/media-libs/libde265/libde265-1.0.3.ebuild
+++ /dev/null
@@ -1,74 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit autotools multilib-minimal
-
-PATCHES=( "${FILESDIR}/${PN}-1.0.2-qtbindir.patch" )
-
-if [[ ${PV} == "9999" ]] ; then
- EGIT_REPO_URI="https://github.com/strukturag/${PN}.git"
- inherit git-r3
-else
- SRC_URI="https://github.com/strukturag/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="amd64 arm64 ~ppc64 x86"
-fi
-
-DESCRIPTION="Open h.265 video codec implementation"
-HOMEPAGE="https://github.com/strukturag/libde265"
-
-LICENSE="GPL-3"
-SLOT="0"
-IUSE="cpu_flags_x86_sse debug qt5 static-libs"
-
-DEPEND="
- media-libs/libsdl[${MULTILIB_USEDEP}]
- media-video/ffmpeg:=[${MULTILIB_USEDEP}]
- qt5? (
- dev-qt/qtcore:5
- dev-qt/qtgui:5
- dev-qt/qtwidgets:5
- )
-"
-RDEPEND="${DEPEND}"
-
-PATCHES+=( "${FILESDIR}"/${P}-use-new-FFMPEG-enum-names.patch )
-
-src_prepare() {
- default
-
- eautoreconf
-
- # without this, headers would be missing and make would fail
- multilib_copy_sources
-}
-
-multilib_src_configure() {
- local myeconfargs=(
- $(use_enable cpu_flags_x86_sse sse)
- $(use_enable static-libs static)
- $(use_enable debug log-info)
- $(use_enable debug log-debug)
- $(use_enable debug log-trace)
- --enable-log-error
- )
-
- if ! multilib_is_native_abi; then
- myeconfargs+=( --disable-dec265 --disable-sherlock265 )
- else
- myeconfargs+=(
- $(use_enable qt5 dec265)
- $(use_enable qt5 sherlock265)
- )
- fi
-
- econf "${myeconfargs[@]}"
-}
-
-multilib_src_install_all() {
- find "${ED}" -name '*.la' -delete || die
- if ! use static-libs ; then
- find "${ED}" -name "*.a" -delete || die
- fi
-}
diff --git a/media-libs/libde265/libde265-1.0.5.ebuild b/media-libs/libde265/libde265-1.0.5.ebuild
deleted file mode 100644
index cd979e8c83fb..000000000000
--- a/media-libs/libde265/libde265-1.0.5.ebuild
+++ /dev/null
@@ -1,99 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit autotools multilib-minimal
-
-PATCHES=( "${FILESDIR}/${PN}-1.0.2-qtbindir.patch" )
-
-if [[ ${PV} == "9999" ]] ; then
- EGIT_REPO_URI="https://github.com/strukturag/${PN}.git"
- inherit git-r3
-else
- SRC_URI="https://github.com/strukturag/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="amd64 ~arm arm64 ~ppc64 x86"
-fi
-
-DESCRIPTION="Open h.265 video codec implementation"
-HOMEPAGE="https://github.com/strukturag/libde265"
-
-LICENSE="GPL-3"
-SLOT="0"
-IUSE="enc265 dec265 sdl tools debug static-libs cpu_flags_x86_sse4_1 cpu_flags_arm_neon cpu_flags_arm_thumb"
-# IUSE+=" sherlock265" # Require libvideogfx or libswscale
-
-RDEPEND="
- dec265? (
- sdl? ( media-libs/libsdl )
- )
-"
-# Sherlock265 require libvideogfx or libswscale
-#RDEPEND+="
-# sherlock265? (
-# media-libs/libsdl
-# dev-qt/qtcore:5
-# dev-qt/qtgui:5
-# dev-qt/qtwidgets:5
-# media-libs/libswscale
-# )
-#"
-
-DEPEND="${RDEPEND}"
-
-BDEPEND="dec265? ( virtual/pkgconfig )"
-
-# Sherlock265 require libvideogfx or libswscale
-#BDEPEND+=" sherlock265? ( virtual/pkgconfig )"
-
-src_prepare() {
- default
-
- eautoreconf
-
- # without this, headers would be missing and make would fail
- multilib_copy_sources
-}
-
-multilib_src_configure() {
- local myeconfargs=(
- ax_cv_check_cflags___msse4_1=$(usex cpu_flags_x86_sse4_1)
- ax_cv_check_cflags___mfpu_neon=$(usex cpu_flags_arm_neon)
- $(use_enable cpu_flags_arm_thumb thumb)
- $(use_enable static-libs static)
- $(use_enable debug log-info)
- $(use_enable debug log-debug)
- $(use_enable debug log-trace)
- $(multilib_native_use_enable enc265 encoder)
- $(multilib_native_use_enable dec265)
- --enable-log-error
- )
-
- # myeconfargs+=( $(multilib_native_use_enable sherlock265) ) # Require libvideogfx or libswscale
- myeconfargs+=( --disable-sherlock265 )
-
- econf "${myeconfargs[@]}"
-}
-
-multilib_src_install() {
- default
-
- if multilib_is_native_abi; then
- # Remove useless, unready and test tools (Why package ever tried to install them??)
- rm -f "${ED}/usr/bin/"{tests,gen-enc-table,yuv-distortion} || die
- if ! use tools; then
- rm -f "${ED}/usr/bin/"{bjoentegaard,block-rate-estim,rd-curves} || die
- rm -f "${ED}/usr/bin/acceleration_speed" || die
- fi
- else
- # Remove all non-native binary tools
- rm -f "${ED}/usr/bin/"* || die
- fi
-}
-
-multilib_src_install_all() {
- find "${ED}" -name '*.la' -delete || die
- if ! use static-libs ; then
- find "${ED}" -name "*.a" -delete || die
- fi
-}
diff --git a/media-libs/libde265/metadata.xml b/media-libs/libde265/metadata.xml
index 524e76641f5f..d63797e27e8c 100644
--- a/media-libs/libde265/metadata.xml
+++ b/media-libs/libde265/metadata.xml
@@ -9,7 +9,6 @@
<flag name="dec265">Enable build of dec265 example program</flag>
<flag name="sdl">Enable video output of dec265 example program with <pkg>media-libs/libsdl</pkg></flag>
<flag name="tools">Enable installation of varous binary tools</flag>
- <flag name="static-libs">Enable build of static libraries</flag>
</use>
<upstream>
<remote-id type="github">strukturag/libde265</remote-id>