summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorValérian Rousset <tharvik@users.noreply.github.com>2019-01-30 17:49:22 +0100
committerPatrice Clement <monsieurp@gentoo.org>2019-02-05 23:32:11 +0100
commit5e3a1c8c3320a4de0973fcd063b3abbd60032fec (patch)
tree67e34b1d2d4765136b735e7fbdd9ca52a47e3ba5
parentnet-analyzer/sslsplit: use HTTPS. (diff)
downloadgentoo-5e3a1c8c3320a4de0973fcd063b3abbd60032fec.tar.gz
gentoo-5e3a1c8c3320a4de0973fcd063b3abbd60032fec.tar.bz2
gentoo-5e3a1c8c3320a4de0973fcd063b3abbd60032fec.zip
net-vpn/i2p: bump to 0.9.38.
Package-Manager: Portage-2.3.51, Repoman-2.3.12 Signed-off-by: Valérian Rousset <tharvik@users.noreply.github.com> Closes: https://github.com/gentoo/gentoo/pull/10948 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
-rw-r--r--net-vpn/i2p/Manifest1
-rw-r--r--net-vpn/i2p/files/0.9.38-add-cp-to-tests45
-rw-r--r--net-vpn/i2p/i2p-0.9.38.ebuild161
3 files changed, 207 insertions, 0 deletions
diff --git a/net-vpn/i2p/Manifest b/net-vpn/i2p/Manifest
index f447a136f4c3..df84846b426f 100644
--- a/net-vpn/i2p/Manifest
+++ b/net-vpn/i2p/Manifest
@@ -1,2 +1,3 @@
DIST i2psource_0.9.36.tar.bz2 29856168 BLAKE2B 0f10101b874bf6fc8415f10b08282947962a6fb8c3eaefde67d3f250d65a159551c24038625aa6712e88b368ccae38d136314025ac19fcb9dd9145251283b357 SHA512 e9023cae1c7dbdd92c9c4823497dfa8497cee3683de1232deddbdc548ba08edefe218bd81e00e952d8a95037c32de8359daaf43c2d5f25c75aba65554d2d47b4
DIST i2psource_0.9.37.tar.bz2 30277506 BLAKE2B 2c0fe601b3a8967c23f00bd29aef197389039efbf1a3fc0847f819dea44f98e38b9b53b749763dccca740a50d467d5d079b0e4aad707347cc7c7a576fcc44407 SHA512 ce0d320810faaebe2926d988a40f4df968583edbc488b995a32cfd806550a8cf75d2c2397bfd9f3fd443cb462567cc2cdbf08d1de59b6806888724254faebf09
+DIST i2psource_0.9.38.tar.bz2 30702106 BLAKE2B c0fd4ea21643edff06853825b9b09dbd648176b6a2318c6bb3846b7c198cac88f89525df0868affbc337e31ec3459f08235cd8a52d38b8551d235c9ef2ca4a4c SHA512 148cd1504dbf0a86367b6dc120a27b2d0d936857eb8cf524e86982d6499c5a831a40aacb3ed67570ad2c323be6545e9a66c12dfc4be2377b80f4d7152e04452d
diff --git a/net-vpn/i2p/files/0.9.38-add-cp-to-tests b/net-vpn/i2p/files/0.9.38-add-cp-to-tests
new file mode 100644
index 000000000000..ddf2f7d5fcae
--- /dev/null
+++ b/net-vpn/i2p/files/0.9.38-add-cp-to-tests
@@ -0,0 +1,45 @@
+diff -Naur a/apps/ministreaming/java/build.xml b/apps/ministreaming/java/build.xml
+--- a/apps/ministreaming/java/build.xml 2019-01-30 13:31:14.958832623 +0100
++++ b/apps/ministreaming/java/build.xml 2019-01-30 13:39:00.050869739 +0100
+@@ -173,7 +173,7 @@
+
+ <javac debug="true" deprecation="on" destdir="./build/obj" encoding="UTF-8" includeAntRuntime="false" source="1.8" srcdir="./test/junit" target="1.8">
+ <classpath>
+- <pathelement location="${javac.classpath}" />
++ <pathelement path="${javac.classpath}" />
+ <pathelement location="../../../core/java/build/i2p.jar" />
+ <pathelement location="${junit.home}/junit4.jar" />
+ <pathelement location="${hamcrest.home}/hamcrest.jar" />
+diff -Naur a/apps/streaming/java/build.xml b/apps/streaming/java/build.xml
+--- a/apps/streaming/java/build.xml 2019-01-30 13:31:14.953832622 +0100
++++ b/apps/streaming/java/build.xml 2019-01-30 13:38:56.683869470 +0100
+@@ -49,7 +49,7 @@
+
+ <javac debug="true" deprecation="on" destdir="./build/obj" encoding="UTF-8" includeAntRuntime="false" source="1.8" srcdir="./test/junit" target="1.8">
+ <classpath>
+- <pathelement location="${javac.classpath}" />
++ <pathelement path="${javac.classpath}" />
+ <pathelement location="../../../core/java/build/i2p.jar" />
+ <pathelement location="../../ministreaming/java/build/mstreaming.jar" />
+ <pathelement location="${junit.home}/junit4.jar" />
+diff -Naur a/router/java/build.xml b/router/java/build.xml
+--- a/router/java/build.xml 2019-01-30 13:31:22.905833257 +0100
++++ b/router/java/build.xml 2019-01-30 13:39:04.133870065 +0100
+@@ -130,7 +130,7 @@
+ <mkdir dir="./build/obj_scala" />
+ <scalac deprecation="on" destdir="./build/obj_scala" srcdir="./test/scalatest">
+ <classpath>
+- <pathelement location="${javac.classpath}" />
++ <pathelement path="${javac.classpath}" />
+ <pathelement location="${scala-library.jar}" />
+ <pathelement location="${scalactic.jar}" />
+ <pathelement location="${scalatest.jar}" />
+@@ -148,7 +148,7 @@
+ <property name="junit.home" value="${ant.home}/lib/" />
+ <javac debug="true" debuglevel="lines,vars,source" deprecation="on" destdir="./build/obj" encoding="UTF-8" includeAntRuntime="true" source="1.8" srcdir="./test/junit" target="1.8">
+ <classpath>
+- <pathelement location="${javac.classpath}" />
++ <pathelement path="${javac.classpath}" />
+ <pathelement location="${hamcrest.home}/hamcrest-core.jar" />
+ <pathelement location="${hamcrest.home}/hamcrest-library.jar" />
+ <pathelement location="${hamcrest.home}/hamcrest-integration.jar" />
diff --git a/net-vpn/i2p/i2p-0.9.38.ebuild b/net-vpn/i2p/i2p-0.9.38.ebuild
new file mode 100644
index 000000000000..396878e979b4
--- /dev/null
+++ b/net-vpn/i2p/i2p-0.9.38.ebuild
@@ -0,0 +1,161 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit java-pkg-2 java-ant-2 systemd user
+
+DESCRIPTION="A privacy-centric, anonymous network"
+HOMEPAGE="https://geti2p.net"
+SRC_URI="https://download.i2p2.de/releases/${PV}/i2psource_${PV}.tar.bz2"
+
+LICENSE="Apache-2.0 Artistic BSD CC-BY-2.5 CC-BY-3.0 CC-BY-SA-3.0 EPL-1.0 GPL-2 GPL-3 LGPL-2.1 LGPL-3 MIT public-domain WTFPL-2"
+SLOT="0"
+
+# Until the deps reach other arches
+KEYWORDS="~amd64 ~x86"
+IUSE='nls test'
+
+# dev-java/ant-core is automatically added due to java-ant-2.eclass
+CP_DEPEND='dev-java/bcprov:1.50
+ dev-java/jrobin:0
+ dev-java/slf4j-api:0
+ dev-java/tomcat-jstl-impl:0
+ dev-java/tomcat-jstl-spec:0
+ dev-java/java-service-wrapper:0
+ dev-java/commons-logging:0
+ dev-java/slf4j-simple:0
+ java-virtuals/servlet-api:3.1
+'
+
+DEPEND="${CP_DEPEND}
+ dev-java/eclipse-ecj:*
+ nls? ( >=sys-devel/gettext-0.19 )
+ virtual/jdk:1.8
+ test? (
+ dev-java/ant-junit4:0
+ dev-java/hamcrest-core:1.3
+ dev-java/hamcrest-library:1.3
+ dev-java/junit:4
+ )
+"
+
+RDEPEND="${CP_DEPEND}
+ virtual/jre:1.8
+ net-libs/nativebiginteger:0
+"
+
+EANT_BUILD_TARGET="pkg"
+# no scala as depending on antlib.xml not installed by dev-lang/scala
+EANT_TEST_TARGET='junit.test'
+JAVA_ANT_ENCODING="UTF-8"
+
+PATCHES=(
+ "${FILESDIR}/${PV}-add-cp-to-tests"
+)
+
+pkg_setup() {
+ java-pkg-2_pkg_setup
+
+ enewgroup i2p
+ enewuser i2p -1 -1 "${EPREFIX}/var/lib/i2p" i2p
+}
+
+src_prepare() {
+ # as early as possible to allow generic patches to be applied
+ default
+
+ java-ant_rewrite-classpath
+
+ java-pkg-2_src_prepare
+
+ # We're on GNU/Linux, we don't need .exe files
+ echo "noExe=true" > override.properties || die
+ if ! use nls; then
+ echo "require.gettext=false" >> override.properties || die
+ fi
+
+ # avoid auto starting browser
+ sed -i 's|clientApp.4.startOnLoad=true|clientApp.4.startOnLoad=false|' \
+ 'installer/resources/clients.config' || die
+
+ # generate wrapper classpath, keeping the default to be replaced later
+ i2p_cp='' # global forced by java-pkg_gen-cp
+ java-pkg_gen-cp i2p_cp
+ local lib cp i=2
+ for lib in ${i2p_cp//,/ }
+ do
+ cp+="wrapper.java.classpath.$((i++))=$(java-pkg_getjars ${lib})\n"
+ done
+
+ # add generated cp and hardcode system VM
+ sed -e "s|\(wrapper\.java\.classpath\.1=.*\)|\1\n${cp}|" \
+ -e "s|\(wrapper\.java\.command\)=.*|\1=/etc/java-config-2/current-system-vm/bin/java|" \
+ -e "s|\(wrapper\.java\.library\.path\.1\)=.*|\1=/usr/lib/java-service-wrapper|" \
+ -e "s|\(wrapper\.java\.library\.path\.2\)=.*|\0\nwrapper.java.library.path.3=/usr/$(get_libdir)|" \
+ -i 'installer/resources/wrapper.config' || die
+
+ # replace paths as the installer would
+ sed -e "s|[\$%]INSTALL_PATH|${EPREFIX}/usr/share/i2p|" \
+ -e "s|%SYSTEM_java_io_tmpdir|${EPREFIX}/var/lib/i2p/.i2p|" \
+ -e "s|%USER_HOME|${EPREFIX}/var/lib/i2p|" \
+ -i 'installer/resources/'{eepget,runplain.sh,wrapper.config} || die
+
+ if use test; then
+ # no *streaming as requiring >dev-java/mockito-1.9.5
+ sed -e '/junit\.test.*streaming/d' \
+ -i build.xml ||
+ die 'unable to remove ministreaming tests'
+ fi
+}
+
+src_test() {
+ # store built version of jars, overwritten by testing
+ mv "${S}/pkg-temp/lib/"{i2p,router}.jar "${T}" ||
+ die 'unable to save jars before tests'
+
+ # generate test classpath
+ local cp
+ cp="$(java-pkg_getjars --build-only junit-4,hamcrest-core-1.3,hamcrest-library-1.3)"
+ EANT_TEST_EXTRA_ARGS="-Djavac.classpath=${cp}" java-pkg-2_src_test
+
+ # redo work undone by testing
+ mv "${T}/"{i2p,router}.jar "${S}/pkg-temp/lib/" ||
+ die 'unable to restore jars after tests'
+}
+
+src_install() {
+ # cd into pkg-temp.
+ cd "${S}/pkg-temp" || die
+
+ # we remove system installed jar and install the others
+ rm lib/{jrobin,wrapper,jbigi,commons-logging,javax.servlet}.jar || \
+ die 'unable to remove locally built jar already found in system'
+ java-pkg_dojar lib/*.jar
+
+ # create own launcher
+ java-pkg_dolauncher eepget --main net.i2p.util.EepGet --jar i2p.jar
+
+ # Install main files and basic documentation
+ insinto '/usr/share/i2p'
+ doins blocklist.txt hosts.txt *.config
+ dodoc history.txt INSTALL-headless.txt LICENSE.txt
+ doman man/*
+
+ # Install other directories
+ doins -r certificates docs eepsite geoip scripts
+ java-pkg_dowar webapps/*.war
+
+ # Install daemon files
+ newinitd "${FILESDIR}/i2p.init" i2p
+ systemd_dounit "${FILESDIR}/i2p.service"
+
+ # setup user
+ keepdir '/var/lib/i2p/.i2p'
+ fowners i2p:i2p '/var/lib/i2p/.i2p'
+}
+
+pkg_postinst() {
+ elog "Custom configuration belongs in ${EPREFIX}/var/lib/i2p/.i2p to avoid being overwritten."
+ elog 'I2P can be configured through the web interface at http://localhost:7657/console'
+}