summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-09-06 19:33:36 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-09-06 20:54:26 +0300
commit5e5302e60f6b4998019ca7d0c0e2755058bf2519 (patch)
treec8157431b63d60493acc6d73803e2f9c1156047e
parentsys-libs/libcxx: Bump 15.0.0 patchset (diff)
downloadgentoo-5e5302e6.tar.gz
gentoo-5e5302e6.tar.bz2
gentoo-5e5302e6.zip
dev-python/identify: add 2.5.5
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--dev-python/identify/Manifest1
-rw-r--r--dev-python/identify/identify-2.5.5.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/identify/Manifest b/dev-python/identify/Manifest
index 72be75db756a..32c0dcf601db 100644
--- a/dev-python/identify/Manifest
+++ b/dev-python/identify/Manifest
@@ -1,2 +1,3 @@
DIST identify-2.5.2.gh.tar.gz 101399 BLAKE2B f0ef048c6543b32016ad47a84e4b4b049a88424e496b159ce6ec1a1358172a87849e132b045a7345e818b02aee359e6d9458c458430a4d5d2b9f918cba685ed7 SHA512 72aaf406e5aa7acc83189820c389e82e90cf775541013e4ad91e5d25abdecd8526d1c47d203baa8ab8e5e028836da755a7045e74fded7e8e3167397557d4b1f0
DIST identify-2.5.3.gh.tar.gz 101397 BLAKE2B 8782a4dfcea2d84facec9fefac8c7241c978ca1f494aa3e0602171dc017b41d24545ec7a3537b07a5e9962edcc4813fa4f45f76d807ba8ba69243041bc777d1b SHA512 d6cc5737b119498af5fb3cc9478881960b4d9532eec552622e942292ec3f1c75182f50ccc94fe7e1bb8993525c5e50fcdfd58881a9226da52fbe5feb3b83a8c3
+DIST identify-2.5.5.gh.tar.gz 101461 BLAKE2B b3a4dc2273435cf9244af64b08b9a9a922025f7d32f479fb2641fcdd9f8a05d2778db126104b1e3b765b82af7ecc1660163de1f71098900296135cd1ccd129c5 SHA512 e02688805310a4f92d0435af562383a10297afa7fc468e44f73be40118c73e2ceac1b4ba7525c375fd0b671ea2700ba66307115c78558a370c525de8cba33c83
diff --git a/dev-python/identify/identify-2.5.5.ebuild b/dev-python/identify/identify-2.5.5.ebuild
new file mode 100644
index 000000000000..8ce2bd5b0e7d
--- /dev/null
+++ b/dev-python/identify/identify-2.5.5.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="File identification library for Python"
+HOMEPAGE="
+ https://github.com/pre-commit/identify/
+ https://pypi.org/project/identify/
+"
+SRC_URI="
+ https://github.com/pre-commit/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ dev-python/ukkonen[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest