summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-21 00:28:26 +0000
committerSam James <sam@gentoo.org>2021-04-21 02:09:36 +0000
commit5e71d3fb247b636e1ceb7c864306415890c45177 (patch)
tree87ca12a8fa222336487f2f7226626894bbc25fcb
parentdev-ml/ocaml-hashcons: port to EAPI 7 (diff)
downloadgentoo-5e71d3fb247b636e1ceb7c864306415890c45177.tar.gz
gentoo-5e71d3fb247b636e1ceb7c864306415890c45177.tar.bz2
gentoo-5e71d3fb247b636e1ceb7c864306415890c45177.zip
dev-ml/reactiveData: port to EAPI 7
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-ml/reactiveData/reactiveData-0.2.1.ebuild5
-rw-r--r--dev-ml/reactiveData/reactiveData-9999.ebuild5
2 files changed, 4 insertions, 6 deletions
diff --git a/dev-ml/reactiveData/reactiveData-0.2.1.ebuild b/dev-ml/reactiveData/reactiveData-0.2.1.ebuild
index 5cbd4d885110..f016dcff52af 100644
--- a/dev-ml/reactiveData/reactiveData-0.2.1.ebuild
+++ b/dev-ml/reactiveData/reactiveData-0.2.1.ebuild
@@ -1,16 +1,15 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="5"
+EAPI=7
inherit opam
DESCRIPTION="Functional reactive programming with incremental changes in data structures"
HOMEPAGE="https://github.com/ocsigen/reactiveData"
-if [ "${PV#9999}" != "${PV}" ] ; then
+if [[ "${PV#9999}" != "${PV}" ]] ; then
inherit git-r3
- SRC_URI=""
EGIT_REPO_URI="https://github.com/ocsigen/reactiveData"
else
SRC_URI="https://github.com/ocsigen/reactiveData/archive/${PV}.tar.gz -> ${P}.tar.gz"
diff --git a/dev-ml/reactiveData/reactiveData-9999.ebuild b/dev-ml/reactiveData/reactiveData-9999.ebuild
index 5cbd4d885110..f016dcff52af 100644
--- a/dev-ml/reactiveData/reactiveData-9999.ebuild
+++ b/dev-ml/reactiveData/reactiveData-9999.ebuild
@@ -1,16 +1,15 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="5"
+EAPI=7
inherit opam
DESCRIPTION="Functional reactive programming with incremental changes in data structures"
HOMEPAGE="https://github.com/ocsigen/reactiveData"
-if [ "${PV#9999}" != "${PV}" ] ; then
+if [[ "${PV#9999}" != "${PV}" ]] ; then
inherit git-r3
- SRC_URI=""
EGIT_REPO_URI="https://github.com/ocsigen/reactiveData"
else
SRC_URI="https://github.com/ocsigen/reactiveData/archive/${PV}.tar.gz -> ${P}.tar.gz"