summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-10-25 23:25:21 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-10-25 23:30:44 +0300
commit5e7700cfe0619d16f5e81cdf226a4889680c6a88 (patch)
tree03de74f7e6ec9006a09bd00efeb9a3085fe3b585
parentdev-python/mkdocs-minify-plugin: add 0.6.1 (diff)
downloadgentoo-5e7700cf.tar.gz
gentoo-5e7700cf.tar.bz2
gentoo-5e7700cf.zip
dev-python/cfn-lint: add 0.69.0
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--dev-python/cfn-lint/Manifest1
-rw-r--r--dev-python/cfn-lint/cfn-lint-0.69.0.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/dev-python/cfn-lint/Manifest b/dev-python/cfn-lint/Manifest
index 8366a805290e..eb5ab2c45452 100644
--- a/dev-python/cfn-lint/Manifest
+++ b/dev-python/cfn-lint/Manifest
@@ -1,2 +1,3 @@
DIST cfn-lint-0.67.0.gh.tar.gz 9787161 BLAKE2B 5299c956e7ca7c63c0c7608d51b01487cf4669f7af54c33f3d9917feae85565a2ce73a96a8d0a5d32cfe1c0a6db6d61b118f2994bb66700145787b650eefe6ea SHA512 35d4686da1f610a970dc1976d7a72ff58c884446f5967b069cc4826b2d9a1b75e2b8a10e676585009c918317186b4dac1c6dc78bf26215eefd5aadd4dce03e0e
DIST cfn-lint-0.68.1.gh.tar.gz 9858724 BLAKE2B 469a23daa717add95140913d85861df44445464d80291430ec42aa2a83c2e125fc395428033c5b82c571297200b28412cc8531bf8e26a0491acfbc5536037cd6 SHA512 a81a1877b9efea411b71d485e66965ca6427998ea13d088c67849a2e8c3f9dd1c125ba0531cb48a27ad75638bde54270654b6da8576fc2fdb15088a0bfb543fe
+DIST cfn-lint-0.69.0.gh.tar.gz 9862506 BLAKE2B 68e6e5e93d7f07bda3eedda71d79943ef97fd0c2e972f475380f7943f88d843effa8cd23b4534bcf4ce0918ca7a634ecf32cef7c309711f9dbc6f899324f3f97 SHA512 9972fb1be897451116e269245d7302af31a53e54c1615daa65bd6b71b9a0ff3f62c1068d86c239510737ac95a6ab3ba2746838792680f701a404008f35857c64
diff --git a/dev-python/cfn-lint/cfn-lint-0.69.0.ebuild b/dev-python/cfn-lint/cfn-lint-0.69.0.ebuild
new file mode 100644
index 000000000000..0916420e1790
--- /dev/null
+++ b/dev-python/cfn-lint/cfn-lint-0.69.0.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="CloudFormation Linter"
+HOMEPAGE="
+ https://github.com/aws-cloudformation/cfn-lint/
+ https://pypi.org/project/cfn-lint/
+"
+SRC_URI="
+ https://github.com/aws-cloudformation/cfn-lint/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/aws-sam-translator-1.53.0[${PYTHON_USEDEP}]
+ dev-python/jsonpatch[${PYTHON_USEDEP}]
+ >=dev-python/jschema_to_python-1.2.3[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-3.0[${PYTHON_USEDEP}]
+ dev-python/junit-xml[${PYTHON_USEDEP}]
+ dev-python/networkx[${PYTHON_USEDEP}]
+ >dev-python/pyyaml-5.4[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.15.0[${PYTHON_USEDEP}]
+ >=dev-python/sarif_om-1.0.4[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # TODO
+ test/unit/module/test_template.py::TestTemplate::test_build_graph
+ # requires git repo
+ test/unit/module/maintenance/test_update_documentation.py::TestUpdateDocumentation::test_update_docs
+ # Internet
+ test/unit/module/formatters/test_formatters.py::TestFormatters::test_sarif_formatter
+ test/unit/module/maintenance/test_update_resource_specs.py::TestUpdateResourceSpecs::test_update_resource_specs_python_2
+ test/unit/module/maintenance/test_update_resource_specs.py::TestUpdateResourceSpecs::test_update_resource_specs_python_3
+)
+
+src_prepare() {
+ # unpin the deps
+ sed -e 's:~=[0-9.]*::' -i setup.py || die
+ distutils-r1_src_prepare
+}