summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2015-10-28 04:08:17 -0400
committerAnthony G. Basile <blueness@gentoo.org>2015-10-28 04:08:17 -0400
commit5ea69423dcf4cbfe34cff712e3a54cbc8bcf49bf (patch)
treea832059d02bd3e55dc14850c5a7946726b6f6338
parentnet-libs/gsoap: Bump to version 2.8.24 (diff)
downloadgentoo-5ea69423.tar.gz
gentoo-5ea69423.tar.bz2
gentoo-5ea69423.zip
www-servers/monkeyd: remove older unstable version 1.6.3.
Package-Manager: portage-2.2.20.1
-rw-r--r--www-servers/monkeyd/Manifest1
-rw-r--r--www-servers/monkeyd/monkeyd-1.6.3.ebuild141
2 files changed, 0 insertions, 142 deletions
diff --git a/www-servers/monkeyd/Manifest b/www-servers/monkeyd/Manifest
index 60f417f04da4..ec9f86a3ff50 100644
--- a/www-servers/monkeyd/Manifest
+++ b/www-servers/monkeyd/Manifest
@@ -1,3 +1,2 @@
DIST monkey-1.5.6.tar.gz 902636 SHA256 7c3d845306aa74ee6effd7ab6169d16ac4e6450e564954d0d0baa2d1e9be1a22 SHA512 4c7c627cb047252252b22da5fba179a21fb5b8dc6280b96307af52757ad049d24b0daaaea51dca4f0429af5e6499c239f6b62a03654cc9e7ad98ae8f5149b64c WHIRLPOOL aba1a928023fc67224f254182eb9707c6594c7092d9ff98ecfa297c91d5c61f79235e7467192b5d46ac114ae67a3cee98e06704721348a40ee825755ab39d9a1
-DIST monkey-1.6.3.tar.gz 2032771 SHA256 47973b12cc45c185b054e251a6c3d8a36cae70301f614b4132bb1ef504f01cfa SHA512 21d317b55bc22e0ef34a2ff545103fbba3728a47e888db58506891e525e926397af81d0ad42ac134f67ab30548853ea4c98df264fab6238901dd05c5b0f55abe WHIRLPOOL acda82625c281f31212eb22d4cef0f64fa251fad25ba5e8aa9e2f4f2146d5bd626a6c66cdb2d17f6559cc858d09fd0afd2383bcdccbf225b8956e2f8b272726c
DIST monkey-1.6.4.tar.gz 2033295 SHA256 351a18a15f3ad8f64c75281105bb2f321da69d58a8034d23757b7ce29fdc9cb3 SHA512 0de83a47806529fa04d60bdf3f69c1f2e2e5980a03d82a8322bb146afff8db85f7f689add876f739133ed262951533382909cd1a3f0f51a8750dde4b15459d25 WHIRLPOOL 6498f74d122b46912065ea060a596d1badc0144069270ea4e949d6debad025ba309e66e1f4e28fb9c595d560c3a37e1a5f01e6ac5a00d31eb5909a31abe3c105
diff --git a/www-servers/monkeyd/monkeyd-1.6.3.ebuild b/www-servers/monkeyd/monkeyd-1.6.3.ebuild
deleted file mode 100644
index fc9146ee2746..000000000000
--- a/www-servers/monkeyd/monkeyd-1.6.3.ebuild
+++ /dev/null
@@ -1,141 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="5"
-
-inherit eutils flag-o-matic toolchain-funcs multilib
-
-DESCRIPTION="A small, fast, and scalable web server"
-HOMEPAGE="http://www.monkey-project.com/"
-MY_P="${PN/d}-${PV}"
-if [[ ${PV} == "9999" ]] ; then
- EGIT_REPO_URI="https://github.com/monkey/monkey.git"
- inherit git-2
- KEYWORDS=""
-else
- SRC_URI="http://monkey-project.com/releases/${PV:0:3}/${MY_P}.tar.gz"
- KEYWORDS="~amd64 ~arm ~mips ~ppc ~ppc64 ~x86"
-fi
-
-LICENSE="GPL-2"
-SLOT="0"
-
-# jemalloc is also off until we figure out how to work CMakeLists.txt magic.
-#IUSE="cgi -debug fastcgi jemalloc php static-plugins ${PLUGINS}"
-
-PLUGINS="monkeyd_plugins_auth monkeyd_plugins_cheetah monkeyd_plugins_dirlisting +monkeyd_plugins_liana monkeyd_plugins_logger monkeyd_plugins_mandril monkeyd_plugins_tls"
-IUSE="cgi -debug fastcgi php static-plugins ${PLUGINS}"
-
-# uclibc is often compiled without backtrace info so we should
-# force this off. If someone complains, consider relaxing it.
-REQUIRED_USE="
- monkeyd_plugins_tls? ( !static-plugins )
- elibc_uclibc? ( !debug )
- cgi? ( php )"
-
-#DEPEND="jemalloc? ( >=dev-libs/jemalloc-3.3.1 )"
-DEPEND="
- dev-util/cmake
- monkeyd_plugins_tls? ( net-libs/mbedtls:= )"
-RDEPEND="
- php? ( dev-lang/php )
- cgi? ( dev-lang/php[cgi] )"
-
-S="${WORKDIR}/${MY_P}"
-
-WEBROOT="/var/www/localhost"
-
-pkg_setup() {
- if use debug; then
- ewarn
- ewarn "\033[1;33m**************************************************\033[00m"
- ewarn "Do not use debug in production!"
- ewarn "\033[1;33m**************************************************\033[00m"
- ewarn
- fi
-}
-
-src_prepare() {
- # Unconditionally get rid of the bundled jemalloc
- rm -rf "${S}"/deps
- epatch "${FILESDIR}"/${P}-system-mbedtls.patch
-}
-
-src_configure() {
- local myconf=""
-
- use elibc_uclibc && myconf+=" --uclib-mode"
- use elibc_musl && myconf+=" --musl-mode"
-
- #use jemalloc || myconf+=" --malloc-libc"
- myconf+=" --malloc-libc"
-
- if use debug; then
- myconf+=" --debug --trace"
- else
- myconf+=" --no-backtrace"
- fi
-
- local enable_plugins=""
- local disable_plugins=""
- # We use 'cgi' and 'fastcgi' because they are global flags
- # instead of the corresponding monkeyd_plugins_*
- use cgi && enable_plugins+="cgi," || disable_plugins+="cgi,"
- use fastcgi && enable_plugins+="fastcgi," || disable_plugins+="fastcgi,"
- # For the rest, we scan the monkeyd_plugins_* and parse out the plugin name.
- for p in ${PLUGINS}; do
- pp=${p/+/}
- cp=${pp/monkeyd_plugins_/}
- use $pp && enable_plugins+="${cp}," || disable_plugins+="${cp},"
- done
- myconf+=" --enable-plugins=${enable_plugins%,} --disable-plugins=${disable_plugins%,}"
- if use static-plugins; then
- myconf+=" --static-plugins=${enable_plugins%,}"
- fi
-
- # For O_CLOEXEC which is guarded by _GNU_SOURCE in uClibc,
- # but shouldn't because it is POSIX. This needs to be fixed
- # in uClibc. Also, we really should us append-cppflags but
- # monkey's build system doesn't respect CPPFLAGS. This needs
- # to be fixed in monkey.
- use elibc_uclibc && append-cflags -D_GNU_SOURCE
-
- # Non-autotools configure
- ./configure \
- --pthread-tls \
- --prefix=/usr \
- --sbindir=/usr/sbin \
- --webroot=${WEBROOT}/htdocs \
- --logdir=/var/log/${PN} \
- --mandir=/usr/share/man \
- --libdir=/usr/$(get_libdir) \
- --pidfile=/run/monkey.pid \
- --sysconfdir=/etc/${PN} \
- ${myconf} \
- || die
-}
-
-src_compile() {
- emake VERBOSE=1
-}
-
-src_install() {
- default
-
- newinitd "${FILESDIR}"/monkeyd.initd-r1 monkeyd
- newconfd "${FILESDIR}"/monkeyd.confd monkeyd
-
- # Move htdocs to docdir, bug #429632
- docompress -x /usr/share/doc/"${PF}"/htdocs.dist
- mv "${D}"${WEBROOT}/htdocs \
- "${D}"/usr/share/doc/"${PF}"/htdocs.dist
- mkdir "${D}"${WEBROOT}/htdocs
-
- keepdir \
- /var/log/monkeyd \
- ${WEBROOT}/htdocs
-
- # This needs to be created at runtime
- rm -rf "${D}"/run
-}