summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-11-14 22:23:14 +0100
committerMichał Górny <mgorny@gentoo.org>2020-11-14 22:23:44 +0100
commit5eafcf000d2247d7c5284a5c8dea3b3594bb707e (patch)
tree6cb4b1467bc3b6bbdeac2b74e82ec46898f37def
parentdev-python/bpython: Mark ALLARCHES (diff)
downloadgentoo-5eafcf00.tar.gz
gentoo-5eafcf00.tar.bz2
gentoo-5eafcf00.zip
dev-python/loky: Skip high_memory tests
Skip unimportant tests that require a lot of memory, and are broken on 32-bit platforms. Closes: https://bugs.gentoo.org/743334 Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/loky/loky-2.9.0.ebuild16
1 files changed, 10 insertions, 6 deletions
diff --git a/dev-python/loky/loky-2.9.0.ebuild b/dev-python/loky/loky-2.9.0.ebuild
index dd2b48641bc5..5d4a3524b53e 100644
--- a/dev-python/loky/loky-2.9.0.ebuild
+++ b/dev-python/loky/loky-2.9.0.ebuild
@@ -25,10 +25,14 @@ BDEPEND="
distutils_enable_tests pytest
-src_prepare() {
- # docker, seriously?
- sed -e 's:test_cpu_count_cfs_limit:_&:' \
- -i tests/test_loky_module.py || die
-
- distutils-r1_src_prepare
+python_test() {
+ local args=(
+ # docker, seriously?
+ --deselect 'tests/test_loky_module.py::test_cpu_count_cfs_limit'
+ # one test that uses a lot of memory, also broken on 32-bit
+ # platforms
+ --skip-high-memory
+ )
+
+ pytest -vv "${args[@]}" || die "Tests failed on ${EPYTHON}"
}