summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org>2019-08-09 16:18:39 +0000
committerMike Gilbert <floppym@gentoo.org>2019-08-09 14:38:58 -0400
commit5ebeabbeac086d1c69357e9ab7e9a18f52bcfcbb (patch)
tree42c26184936aa619795f8186d838a0c5dc656024
parentdev-libs/utfcpp: Set maintainer Arfrever. (diff)
downloadgentoo-5ebeabbeac086d1c69357e9ab7e9a18f52bcfcbb.tar.gz
gentoo-5ebeabbeac086d1c69357e9ab7e9a18f52bcfcbb.tar.bz2
gentoo-5ebeabbeac086d1c69357e9ab7e9a18f52bcfcbb.zip
dev-libs/utfcpp: Version bump (3.1).
Signed-off-by: Arfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org> Signed-off-by: Mike Gilbert <floppym@gentoo.org>
-rw-r--r--dev-libs/utfcpp/Manifest1
-rw-r--r--dev-libs/utfcpp/utfcpp-3.1.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-libs/utfcpp/Manifest b/dev-libs/utfcpp/Manifest
index 28771adffc41..01d91412840e 100644
--- a/dev-libs/utfcpp/Manifest
+++ b/dev-libs/utfcpp/Manifest
@@ -1 +1,2 @@
DIST utf8_v2_3_4.zip 22422 BLAKE2B cf736876a99068c7e5cb1b0b892d1d63cb38906c993c60b78c8c5625aef86fac3a849551771d0840c3cccf04f1a3617216cbd4684fa5cdde0037e3901c70ff4b SHA512 0e85e443e7bd4ecbe85dedfb7bdf8b1767808108b3a4fc1c0c508bcf74787539ae0af95a31a70e715ca872689ac4d7233afc075ceb375375d26743f92051e222
+DIST utfcpp-3.1.tar.gz 25871 BLAKE2B 6bafb933b777e842375b3dc6b1b5bc41efb0e9f40bbd33ccbbaf07b57a28c4e485d596725297fc2de83c23fa3c66872519883727714d236f4a37e07ed4825fc9 SHA512 826ac7aa61215ac2144fa3f5edc7f291c3dd25dc69b0c82526840f4651f822515ec262915e1117d975e5c5dd729f6166806a5d397262f59a2b323eb7009671f5
diff --git a/dev-libs/utfcpp/utfcpp-3.1.ebuild b/dev-libs/utfcpp/utfcpp-3.1.ebuild
new file mode 100644
index 000000000000..fe95f70ff25c
--- /dev/null
+++ b/dev-libs/utfcpp/utfcpp-3.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 2015-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit cmake-utils
+
+if [[ "${PV}" == "9999" ]]; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/nemtrif/utfcpp"
+ EGIT_SUBMODULES=()
+fi
+
+DESCRIPTION="UTF-8 C++ library"
+HOMEPAGE="https://github.com/nemtrif/utfcpp"
+if [[ "${PV}" == "9999" ]]; then
+ SRC_URI=""
+else
+ SRC_URI="https://github.com/nemtrif/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+fi
+
+LICENSE="Boost-1.0"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="test"
+
+BDEPEND=""
+DEPEND="test? ( dev-cpp/gtest )"
+RDEPEND=""
+
+src_prepare() {
+ sed -e "/add_subdirectory(extern\/gtest)/d" -i CMakeLists.txt || die
+ sed -e "s/gtest_main/gtest &/" -i tests/CMakeLists.txt || die
+
+ cmake-utils_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DUTF8_SAMPLES=OFF
+ -DUTF8_TESTS=$(usex test ON OFF)
+ )
+
+ cmake-utils_src_configure
+}