summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2021-01-30 16:17:08 +0100
committerConrad Kostecki <conikost@gentoo.org>2021-01-30 16:17:26 +0100
commit5ecf3085933898aa7fd508b4e7bd02505416298c (patch)
tree2fd04bd4b72af8dae967954eea793a60a58eb267
parentprofiles: Grant a last respite of +14 days to sys-power/pm-utils (diff)
downloadgentoo-5ecf3085.tar.gz
gentoo-5ecf3085.tar.bz2
gentoo-5ecf3085.zip
dev-python/jsonrpclib: add python3_9 support (live)
Bug: https://bugs.gentoo.org/767031 Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
-rw-r--r--dev-python/jsonrpclib/jsonrpclib-9999.ebuild12
1 files changed, 3 insertions, 9 deletions
diff --git a/dev-python/jsonrpclib/jsonrpclib-9999.ebuild b/dev-python/jsonrpclib/jsonrpclib-9999.ebuild
index ec15474a0929..85ff885aecde 100644
--- a/dev-python/jsonrpclib/jsonrpclib-9999.ebuild
+++ b/dev-python/jsonrpclib/jsonrpclib-9999.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{6,7} )
+PYTHON_COMPAT=( python3_{6..9} )
inherit distutils-r1
@@ -19,13 +19,7 @@ HOMEPAGE="https://github.com/tcalmant/jsonrpclib"
LICENSE="Apache-2.0"
SLOT="0"
-IUSE="test"
-RESTRICT="!test? ( test )"
RDEPEND="dev-python/simplejson[${PYTHON_USEDEP}]"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( ${RDEPEND} )"
-python_test() {
- esetup.py test
-}
+distutils_enable_tests setup.py