summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2019-03-12 10:06:16 +0100
committerLars Wendler <polynomial-c@gentoo.org>2019-03-12 10:06:16 +0100
commit5ed3938ac8a8cf65bb6f0684cb68ab76decbceb1 (patch)
tree0a00b2880c8c5c6d73381f64c7fccb8d56aafb31
parentdev-vcs/mercurial: Bump to version 4.9 (diff)
downloadgentoo-5ed3938a.tar.gz
gentoo-5ed3938a.tar.bz2
gentoo-5ed3938a.zip
dev-vcs/tortoisehg: Bump to version 4.9
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
-rw-r--r--dev-vcs/tortoisehg/Manifest1
-rw-r--r--dev-vcs/tortoisehg/tortoisehg-4.9.ebuild79
2 files changed, 80 insertions, 0 deletions
diff --git a/dev-vcs/tortoisehg/Manifest b/dev-vcs/tortoisehg/Manifest
index 684acbd4aff2..4cae39a5717d 100644
--- a/dev-vcs/tortoisehg/Manifest
+++ b/dev-vcs/tortoisehg/Manifest
@@ -4,3 +4,4 @@ DIST tortoisehg-4.6.1.tar.gz 7947844 BLAKE2B 68d0e8672febb9bfdca763e77cbaff8de79
DIST tortoisehg-4.7.2.tar.gz 7948303 BLAKE2B 9439b86cfd004aa78fc39941cee005b3fe7fcf3a7a5d5dab4c0e0ac12477338000f07105fd7ee6c67def731f406313280acb6af7d5f1d70c51331d7339b21038 SHA512 d4d3c2bb097d12f69594d25c0029bf347f6aee7e4eb3fdecf3d49f3c679b11112376410a87733bb5e29ffdef2c6837e47f7af18121cb5b14ccef22f27a55ebfe
DIST tortoisehg-4.8.1.tar.gz 7950273 BLAKE2B 91babad30d7fc34d6115babe86a6cf3a2a8afde73719bfec7220633f7824f953f3b6f6128a0f2956c0cafa568e3b12a4fd92d4a955f3b729c47a375c90ed500f SHA512 6ee1efe504265a7a43cae88d6fe25777ffb9109f4b01056e6248b6df1a0214a6f9eacc3121c458e6e0ea051dc56faf48acb2bda73f6e89fc3f686026fa0528b2
DIST tortoisehg-4.8.2.tar.gz 8961094 BLAKE2B 3230ccd1f5fbfe44e1a656c5942592023d392816972663030df4d7c604dbea79a757b1695e60c450637d74aa53e0a821fd1e159ee9f1560ea6e48c766fd13dcb SHA512 46357dd982bdb1ecde419b63ae845f60523769e1be8145e883fcd6928008bac63a4c206423e764d4e6723049bd7ebad5fcd8027fa11beea485287fe3e74be566
+DIST tortoisehg-4.9.tar.gz 7960163 BLAKE2B bc13032ba1e36ed3e6aca978cb3917b2e5fdcf1b7dab2e66a34a0aca2e084960954f9ec135a1c2120e09931b876db7d1f3d0f3a8f69f950ff939eea9d7814523 SHA512 cc7b0360c6b362b0b9695a484b59eea879e1d4e28ed68e98ce6975342a22ddafc97976c5b0cdea289bfd78932dacf76c0b236e36bec48acd48ee361f2c09ff13
diff --git a/dev-vcs/tortoisehg/tortoisehg-4.9.ebuild b/dev-vcs/tortoisehg/tortoisehg-4.9.ebuild
new file mode 100644
index 000000000000..a56dfb73838d
--- /dev/null
+++ b/dev-vcs/tortoisehg/tortoisehg-4.9.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 )
+
+inherit desktop distutils-r1
+
+if [[ ${PV} != *9999* ]]; then
+ KEYWORDS="~amd64 ~x86"
+ SRC_URI="https://www.bitbucket.org/${PN}/targz/downloads/${P}.tar.gz"
+ HG_DEPEND=">=dev-vcs/mercurial-4.8 <dev-vcs/mercurial-4.10"
+else
+ inherit mercurial
+ EHG_REPO_URI="https://bitbucket.org/tortoisehg/thg"
+ EHG_REVISION="stable"
+ HG_DEPEND="dev-vcs/mercurial"
+fi
+
+DESCRIPTION="Set of graphical tools for Mercurial"
+HOMEPAGE="https://tortoisehg.bitbucket.io/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="doc"
+
+RDEPEND="${HG_DEPEND}
+ dev-python/iniparse[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ dev-python/PyQt5[network,svg,${PYTHON_USEDEP}]
+ >=dev-python/qscintilla-python-2.9.4:=[qt5(+),${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ doc? ( >=dev-python/sphinx-1.0.3 )"
+
+# Workaround race condition in build_qt
+DISTUTILS_IN_SOURCE_BUILD=1
+
+python_prepare_all() {
+ if [[ ${L10N+set} ]]; then
+ cd i18n/tortoisehg || die
+ local x y keep
+ for x in *.po; do
+ keep=false
+ for y in ${L10N}; do
+ if [[ ${y} == ${x%.po}* ]]; then
+ keep=true
+ break
+ fi
+ done
+ ${keep} || rm "${x}" || die
+ done
+ cd "${S}" || die
+ fi
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && emake -C doc html
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ dodoc doc/ReadMe*.txt doc/TODO contrib/mergetools.rc
+ if use doc ; then
+ dohtml -r doc/build/html/
+ fi
+ newicon -s scalable icons/scalable/apps/thg.svg thg_logo.svg
+ domenu contrib/thg.desktop
+
+ # Remove file that collides with >=mercurial-4.0 (bug #599266).
+ rm "${ED}"/usr/$(get_libdir)/${EPYTHON}/site-packages/hgext3rd/__init__.py \
+ || die
+}
+
+pkg_postinst() {
+ elog "When startup of ${PN} fails with an API version mismatch error"
+ elog "between dev-python/sip and dev-python/PyQt5 please rebuild"
+ elog "dev-python/qscintilla-python."
+}