summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2023-01-29 21:18:00 -0500
committerMike Gilbert <floppym@gentoo.org>2023-01-29 21:18:00 -0500
commit5ee2ced8801f349aeaad982f72736d0b162ba1c1 (patch)
treec374bbfb445c2c9c12deaa5ebbde33e840e2370a
parentsys-apps/systemd: update journald-audit patch (diff)
downloadgentoo-5ee2ced8.tar.gz
gentoo-5ee2ced8.tar.bz2
gentoo-5ee2ced8.zip
sys-apps/systemd: disable sysvinit compat again
This basically just means that people will need to call systemctl instead of using the sysvinit commands if they have sysv-utils diabled. Disabling the sysvinit compat code lets us drop a distro-specific patch, and cleans up some legacy codepaths. Signed-off-by: Mike Gilbert <floppym@gentoo.org>
-rw-r--r--sys-apps/systemd/systemd-9999.ebuild4
1 files changed, 3 insertions, 1 deletions
diff --git a/sys-apps/systemd/systemd-9999.ebuild b/sys-apps/systemd/systemd-9999.ebuild
index ea3aabd5a42f..77c05e37c43e 100644
--- a/sys-apps/systemd/systemd-9999.ebuild
+++ b/sys-apps/systemd/systemd-9999.ebuild
@@ -236,7 +236,6 @@ src_prepare() {
if ! use vanilla; then
PATCHES+=(
"${FILESDIR}/gentoo-generator-path-r2.patch"
- "${FILESDIR}/gentoo-systemctl-disable-sysv-sync-r1.patch"
"${FILESDIR}/gentoo-journald-audit-r1.patch"
)
fi
@@ -267,6 +266,9 @@ multilib_src_configure() {
$(meson_use split-usr split-bin)
-Drootprefix="$(usex split-usr "${EPREFIX:-/}" "${EPREFIX}/usr")"
-Drootlibdir="${EPREFIX}/usr/$(get_libdir)"
+ # Disable compatibility with sysvinit
+ -Dsysvinit-path=
+ -Dsysvrcnd-path=
# Avoid infinite exec recursion, bug 642724
-Dtelinit-path="${EPREFIX}/lib/sysvinit/telinit"
# no deps