summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-05-12 04:29:35 +0200
committerMichał Górny <mgorny@gentoo.org>2024-05-12 04:37:10 +0200
commit5f043f30e7e19a755d2d660479f86aaedce05111 (patch)
tree50aa3076035400c52f08f8c80617a58f3c623fc7
parentdev-python/tavern: Bump to 2.11.0 (diff)
downloadgentoo-5f043f30e7e19a755d2d660479f86aaedce05111.tar.gz
gentoo-5f043f30e7e19a755d2d660479f86aaedce05111.tar.bz2
gentoo-5f043f30e7e19a755d2d660479f86aaedce05111.zip
dev-python/owslib: Bump to 0.31.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/owslib/Manifest1
-rw-r--r--dev-python/owslib/owslib-0.31.0.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/owslib/Manifest b/dev-python/owslib/Manifest
index 0d51b16988ee..352a761189f4 100644
--- a/dev-python/owslib/Manifest
+++ b/dev-python/owslib/Manifest
@@ -1 +1,2 @@
DIST OWSLib-0.30.0.gh.tar.gz 995826 BLAKE2B 58066b461794d424e646cd148f1c0379c22c17bee144611e4bda71c8410f2d4dbd172e5cad14ff1e33fc3e2a7293985c943eace6284d1830a2533abbe95ecf27 SHA512 2fdad8ac282d78181e2b7953f22db063f760c2f61682967c7d99ac8e12d62345168db978d9599a4093005f520968d4e97fc588f9a9b7d81a87894b08028d42d8
+DIST OWSLib-0.31.0.gh.tar.gz 1041697 BLAKE2B 0fd7e0aa95a07229e171bbf3924a9a7036aa0e201a28c8198fcdd4a462d75b90b0979ffda7d9e20ec30abc284b97362fd195cda67c772f3f96642f1ae89ff753 SHA512 005e6f753472675aef0bd0ead138e9bafce2df4e3530003d4159a2ecf610164487ddeb63cf1dfeb6cb4847c878eb40056ccc77116aac8be658fb322ad650f41d
diff --git a/dev-python/owslib/owslib-0.31.0.ebuild b/dev-python/owslib/owslib-0.31.0.ebuild
new file mode 100644
index 000000000000..0b765014cb71
--- /dev/null
+++ b/dev-python/owslib/owslib-0.31.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+MY_P=OWSLib-${PV}
+DESCRIPTION="Library for client programming with Open Geospatial Consortium web service"
+HOMEPAGE="
+ https://geopython.github.io/OWSLib/
+ https://github.com/geopython/owslib/
+ https://pypi.org/project/OWSLib/
+"
+SRC_URI="
+ https://github.com/geopython/${PN}/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pillow[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ epytest -o addopts= -m "not online"
+}