summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <mmk@levelnine.at>2024-05-15 20:18:13 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2024-05-17 11:43:10 +0300
commit5f054a16089bae1f816c57048dc6f9ec08d88ffc (patch)
treed9a54ae9e42dc5526dae752020038ea5353c5af7
parentgames-puzzle/tong: drop old (diff)
downloadgentoo-5f054a16089bae1f816c57048dc6f9ec08d88ffc.tar.gz
gentoo-5f054a16089bae1f816c57048dc6f9ec08d88ffc.tar.bz2
gentoo-5f054a16089bae1f816c57048dc6f9ec08d88ffc.zip
games-puzzle/textmaze: EAPI8 bump, fix LICENSE
Signed-off-by: Michael Mair-Keimberger <mmk@levelnine.at> Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--games-puzzle/textmaze/textmaze-1.2-r2.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/games-puzzle/textmaze/textmaze-1.2-r2.ebuild b/games-puzzle/textmaze/textmaze-1.2-r2.ebuild
new file mode 100644
index 000000000000..e73d6073a677
--- /dev/null
+++ b/games-puzzle/textmaze/textmaze-1.2-r2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_P="${PN}_v${PV}"
+DESCRIPTION="Ncurses-based maze solving game written in Perl"
+HOMEPAGE="https://robobunny.com/projects/textmaze/html/"
+SRC_URI="https://robobunny.com/projects/${PN}/${MY_P}.tar.gz"
+S="${WORKDIR}/TextMaze"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-perl/Curses"
+
+src_prepare() {
+ default
+ sed -i \
+ -e "s#/usr/local/bin/perl#/usr/bin/perl#" \
+ textmaze || die
+}
+
+src_install() {
+ dobin textmaze
+ einstalldocs
+}