summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVirgil Dupras <vdupras@gentoo.org>2019-03-30 22:19:14 -0400
committerVirgil Dupras <vdupras@gentoo.org>2019-03-31 09:03:01 -0400
commit5f1f312f601379c900c6d04831c26442a30bb1c4 (patch)
tree52028fc0819410e9b9fb157a7a5c40a954baeed6
parentx11-themes/QGnomePlatform: amd64 stable, bug #681624 (diff)
downloadgentoo-5f1f312f.tar.gz
gentoo-5f1f312f.tar.bz2
gentoo-5f1f312f.zip
dev-python/sphinxcontrib-htmlhelp: new package
Signed-off-by: Virgil Dupras <vdupras@gentoo.org> Package-Manager: Portage-2.3.62, Repoman-2.3.11
-rw-r--r--dev-python/sphinxcontrib-htmlhelp/Manifest1
-rw-r--r--dev-python/sphinxcontrib-htmlhelp/metadata.xml11
-rw-r--r--dev-python/sphinxcontrib-htmlhelp/sphinxcontrib-htmlhelp-1.0.1.ebuild27
3 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/sphinxcontrib-htmlhelp/Manifest b/dev-python/sphinxcontrib-htmlhelp/Manifest
new file mode 100644
index 000000000000..58dc5f4161aa
--- /dev/null
+++ b/dev-python/sphinxcontrib-htmlhelp/Manifest
@@ -0,0 +1 @@
+DIST sphinxcontrib-htmlhelp-1.0.1.tar.gz 20448 BLAKE2B c7e8cc306f196719b60f4ae8aa678a09d18f7986529b71e4631b99a14d4631b00d9f59766f4d96eea1f16e26adc3e0998295b766886def705be57adf0016ee2d SHA512 a364a490e5043e767a8b498b5b621f3f3c64bf15f65847097489d3d2ba8620adea2045024d5189a68d97af6f68161f714f09a712cdd9fc6d06524ea818cf2e1a
diff --git a/dev-python/sphinxcontrib-htmlhelp/metadata.xml b/dev-python/sphinxcontrib-htmlhelp/metadata.xml
new file mode 100644
index 000000000000..0cca313393e1
--- /dev/null
+++ b/dev-python/sphinxcontrib-htmlhelp/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">sphinxcontrib-htmlhelp</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/sphinxcontrib-htmlhelp/sphinxcontrib-htmlhelp-1.0.1.ebuild b/dev-python/sphinxcontrib-htmlhelp/sphinxcontrib-htmlhelp-1.0.1.ebuild
new file mode 100644
index 000000000000..ebec7800e64c
--- /dev/null
+++ b/dev-python/sphinxcontrib-htmlhelp/sphinxcontrib-htmlhelp-1.0.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{5,6,7} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Sphinx extension which outputs HTML help book"
+HOMEPAGE="http://www.sphinx-doc.org"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris"
+
+RDEPEND=""
+PDEPEND="
+ >=dev-python/sphinx-2.0[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_install_all() {
+ distutils-r1_python_install_all
+ find "${ED}" -name '*.pth' -delete || die
+}