summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2024-03-23 16:28:11 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2024-03-23 16:29:55 +0200
commit5f34586458eebda4da0e2d35da93a4bc5f13c7d0 (patch)
tree43e55a13da4f3f6f337e1fe4d36055240359caa4
parentdev-libs/ncnn: fix openmp automagic (diff)
downloadgentoo-5f34586458eebda4da0e2d35da93a4bc5f13c7d0.tar.gz
gentoo-5f34586458eebda4da0e2d35da93a4bc5f13c7d0.tar.bz2
gentoo-5f34586458eebda4da0e2d35da93a4bc5f13c7d0.zip
tree-sitter-grammar.eclass: don't pre-strip library
When STRIP is set to anon empty value, it is called during build of the shared library. By unsetting it, the strip isn't called during compile but by the portage strip phase. Closes: https://bugs.gentoo.org/927571 Closes: https://bugs.gentoo.org/927572 Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--eclass/tree-sitter-grammar.eclass1
1 files changed, 1 insertions, 0 deletions
diff --git a/eclass/tree-sitter-grammar.eclass b/eclass/tree-sitter-grammar.eclass
index 74443e213b89..b5e020065547 100644
--- a/eclass/tree-sitter-grammar.eclass
+++ b/eclass/tree-sitter-grammar.eclass
@@ -163,6 +163,7 @@ tree-sitter-grammar_src_compile() {
if [[ -f "${S}/pyproject.toml" ]]; then
sed -e "/SONAME_MINOR :=/s/:=.*$/:= $(_get_tsg_abi_ver)/" -i "${S}/Makefile" || die
emake \
+ STRIP="" \
PREFIX="${EPREFIX}/usr" \
LIBDIR="${EPREFIX}/usr/$(get_libdir)"
else