summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-02-26 23:18:02 +0000
committerSam James <sam@gentoo.org>2021-02-27 01:00:01 +0000
commit5f350f10332cca48ef19b5abe78504935ffd6019 (patch)
treebd9358b4c41437a4f1e3bedd8fae2a2efa0c4b34
parentapp-admin/supervisor: bump to 4.2.2 (diff)
downloadgentoo-5f350f10.tar.gz
gentoo-5f350f10.tar.bz2
gentoo-5f350f10.zip
dev-libs/bitset: port to EAPI 7
Package-Manager: Portage-3.0.15, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-libs/bitset/bitset-2.8.4-r1.ebuild29
1 files changed, 22 insertions, 7 deletions
diff --git a/dev-libs/bitset/bitset-2.8.4-r1.ebuild b/dev-libs/bitset/bitset-2.8.4-r1.ebuild
index 420af9b499c2..74a48300b7fc 100644
--- a/dev-libs/bitset/bitset-2.8.4-r1.ebuild
+++ b/dev-libs/bitset/bitset-2.8.4-r1.ebuild
@@ -1,10 +1,9 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="5"
+EAPI=7
-AUTOTOOLS_AUTORECONF=1
-inherit autotools-utils
+inherit autotools
DESCRIPTION="A compressed bitset with supporting data structures and algorithms"
HOMEPAGE="https://github.com/chriso/bitset"
@@ -15,21 +14,37 @@ SLOT="0"
IUSE="jemalloc static-libs tcmalloc"
KEYWORDS="amd64 ~arm x86"
-RDEPEND="tcmalloc? ( dev-util/google-perftools:= )
- jemalloc? ( >=dev-libs/jemalloc-3.2 )"
+RDEPEND="
+ tcmalloc? ( dev-util/google-perftools:= )
+ jemalloc? ( >=dev-libs/jemalloc-3.2 )
+"
DEPEND="${RDEPEND}"
REQUIRED_USE="?? ( jemalloc tcmalloc )"
DOCS=( README.md )
+src_prepare() {
+ default
+ eautoreconf
+}
+
src_configure() {
local tcmalloc_lib_name='tcmalloc'
+
has_version dev-util/google-perftools[minimal] && tcmalloc_lib_name='tcmalloc_minimal'
+
local myeconfargs=(
$(use_with jemalloc) \
$(use_with tcmalloc) \
$(use_with tcmalloc tcmalloc-lib "${tcmalloc_lib_name}")
)
- autotools-utils_src_configure
+
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+
+ find "${ED}" -name '*.la' -delete || die
}