summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-02-01 06:09:49 +0100
committerMichał Górny <mgorny@gentoo.org>2023-02-01 06:09:49 +0100
commit5f3c3a49869a6e8c9f61cadeb34bc9140e719b1f (patch)
treec6550fa7eacdc0f9648f718e25823a9bce48d8cd
parentdev-libs/opencl-clang: Remove old (diff)
downloadgentoo-5f3c3a49869a6e8c9f61cadeb34bc9140e719b1f.tar.gz
gentoo-5f3c3a49869a6e8c9f61cadeb34bc9140e719b1f.tar.bz2
gentoo-5f3c3a49869a6e8c9f61cadeb34bc9140e719b1f.zip
dev-util/spirv-llvm-translator: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-util/spirv-llvm-translator/Manifest2
-rw-r--r--dev-util/spirv-llvm-translator/spirv-llvm-translator-13.0.0-r2.ebuild60
2 files changed, 0 insertions, 62 deletions
diff --git a/dev-util/spirv-llvm-translator/Manifest b/dev-util/spirv-llvm-translator/Manifest
index d315944ddd39..f34eb94f0d47 100644
--- a/dev-util/spirv-llvm-translator/Manifest
+++ b/dev-util/spirv-llvm-translator/Manifest
@@ -1,4 +1,2 @@
-DIST spirv-llvm-translator-13.0.0-rename-OpConstFunctionPointerINTEL.patch.bz2 3632 BLAKE2B b2c3ed9ff1040fef12cd5b7962c71f2e52febbf1e1d1d06bee079093940c32e67f7c246c92876207f296677bd655f91447d0ce837f191cd0d4cfb66adfb11a62 SHA512 bba6a9b838ebf0bd29f5fa906fefcecdb1b3832b15ac1af8a1ed86da0e988385172b1a51468a4d8d97352c4a57c3e224f12d7e24b7a202a38353e2dbd3a2c27c
-DIST spirv-llvm-translator-13.0.0.tar.gz 1436324 BLAKE2B 254450f153a0f0d7c0a75005705f4a7d90effa1e6bcde0d6b931195e4a925ddc34896e66b686c55583d50ab99a9e1e45ad1c0600f7fa4eaa2039642460e9b711 SHA512 1ce7a38c2c3447249e19d50063a7a2acf32699905572950e4f102d8ce1680785433035154b7b55782d5a56211a50e042aef775836f37c33fe847b347a02b5a04
DIST spirv-llvm-translator-14.0.0.tar.gz 1482704 BLAKE2B f88eb8f4cd652c448e465605ec8c34bb80f87f1269c244b33be542ae98ef97ea04a759b9cd9fed0814f4360733d7560d301d2b8d586706d1ca988b4524526aeb SHA512 5659149a380ceef7acdcb274bcad9b23e4817bf88e795e0a8464dfe14fbd102dbf7199cbe67eb611a16d3a411c7a1b8afc6f0eef61fec5a2b8f9fba06748bcb1
DIST spirv-llvm-translator-15.0.0.tar.gz 1515145 BLAKE2B 1f93b55f8934ce7dbc9416b82f7bd544d16e95be795047e914d0c303ec90965eae03ab3522b3c92d6cffb1fe00bed78a4bb74085d3da21c14b68ad3fbe53113c SHA512 8a6ddddf326dad96c1c5749ebf03e63e6be60592dccd307f7a35be668cec2b4f58c2f089854aeefa37398c3a97dad6bf92a6ceb892da27b5cf9d4ae1aa41dd06
diff --git a/dev-util/spirv-llvm-translator/spirv-llvm-translator-13.0.0-r2.ebuild b/dev-util/spirv-llvm-translator/spirv-llvm-translator-13.0.0-r2.ebuild
deleted file mode 100644
index c3d768a3bbcc..000000000000
--- a/dev-util/spirv-llvm-translator/spirv-llvm-translator-13.0.0-r2.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-LLVM_MAX_SLOT="13"
-MY_PN="SPIRV-LLVM-Translator"
-MY_P="${MY_PN}-${PV}"
-
-inherit cmake flag-o-matic llvm
-
-DESCRIPTION="Bi-directional translator between SPIR-V and LLVM IR"
-HOMEPAGE="https://github.com/KhronosGroup/SPIRV-LLVM-Translator"
-SRC_URI="https://github.com/KhronosGroup/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-SRC_URI+=" https://dev.gentoo.org/~sam/distfiles/${CATEGORY}/${PN}/${P}-rename-OpConstFunctionPointerINTEL.patch.bz2"
-S="${WORKDIR}/${MY_P}"
-
-LICENSE="UoI-NCSA"
-SLOT="$(ver_cut 1)"
-KEYWORDS="amd64"
-IUSE="test +tools"
-REQUIRED_USE="test? ( tools )"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- dev-util/spirv-headers
- sys-devel/clang:${SLOT}
- sys-devel/llvm:${SLOT}
-"
-
-DEPEND="${RDEPEND}"
-
-BDEPEND="
- virtual/pkgconfig
- test? ( dev-python/lit )
-"
-
-PATCHES=( "${WORKDIR}"/${P}-rename-OpConstFunctionPointerINTEL.patch )
-
-src_prepare() {
- append-flags -fPIC
- cmake_src_prepare
-}
-
-src_configure() {
- local mycmakeargs=(
- -DCCACHE_ALLOWED="OFF"
- -DCMAKE_INSTALL_PREFIX="$(get_llvm_prefix ${LLVM_MAX_SLOT})"
- -DLLVM_EXTERNAL_SPIRV_HEADERS_SOURCE_DIR="${BROOT}/usr/include/spirv"
- -DLLVM_BUILD_TOOLS=$(usex tools "ON" "OFF")
- -DLLVM_SPIRV_INCLUDE_TESTS=$(usex test "ON" "OFF")
- -Wno-dev
- )
-
- cmake_src_configure
-}
-
-src_test() {
- lit "${BUILD_DIR}/test" || die
-}