summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-07-13 08:44:48 +0200
committerMichał Górny <mgorny@gentoo.org>2021-07-13 08:44:48 +0200
commit5f3d061e728b910e34ded87f7fe1bd2c54db3ea4 (patch)
treef1619767e79dce6b71953b4e9fdffea50c863e5a
parentdev-python/oauthlib: Remove old (diff)
downloadgentoo-5f3d061e728b910e34ded87f7fe1bd2c54db3ea4.tar.gz
gentoo-5f3d061e728b910e34ded87f7fe1bd2c54db3ea4.tar.bz2
gentoo-5f3d061e728b910e34ded87f7fe1bd2c54db3ea4.zip
dev-python/GitPython: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/GitPython/GitPython-3.1.15.ebuild59
-rw-r--r--dev-python/GitPython/GitPython-3.1.17.ebuild66
-rw-r--r--dev-python/GitPython/Manifest6
3 files changed, 0 insertions, 131 deletions
diff --git a/dev-python/GitPython/GitPython-3.1.15.ebuild b/dev-python/GitPython/GitPython-3.1.15.ebuild
deleted file mode 100644
index 66fe6caf3dd0..000000000000
--- a/dev-python/GitPython/GitPython-3.1.15.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7..9} )
-PYTHON_REQ_USE="threads(+)"
-
-inherit distutils-r1
-
-TEST_P=GitPython-${PV}
-GITDB_P=gitdb-4.0.5-r1
-SMMAP_P=smmap-3.0.4
-
-DESCRIPTION="Library used to interact with Git repositories"
-HOMEPAGE="https://github.com/gitpython-developers/GitPython https://pypi.org/project/GitPython/"
-SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz
- test? (
- https://dev.gentoo.org/~mgorny/dist/${TEST_P}.gitbundle
- https://dev.gentoo.org/~mgorny/dist/${GITDB_P}.gitbundle
- https://dev.gentoo.org/~mgorny/dist/${SMMAP_P}.gitbundle
- )"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~arm arm64 ~ppc64 x86 ~amd64-linux ~x86-linux"
-
-RDEPEND="
- dev-vcs/git
- >=dev-python/gitdb-4.0.1[${PYTHON_USEDEP}]
- dev-python/typing-extensions[${PYTHON_USEDEP}]"
-BDEPEND="
- test? (
- >=dev-python/ddt-1.1.1[${PYTHON_USEDEP}]
- )"
-
-distutils_enable_tests unittest
-
-src_test() {
- git config --global user.email "travis@ci.com" || die
- git config --global user.name "Travis Runner" || die
-
- git clone "${DISTDIR}/${TEST_P}.gitbundle" "${T}"/test || die
- git clone "${DISTDIR}/${GITDB_P}.gitbundle" \
- "${T}"/test/git/ext/gitdb || die
- git clone "${DISTDIR}/${SMMAP_P}.gitbundle" \
- "${T}"/test/git/ext/gitdb/gitdb/ext/smmap || die
-
- cd "${T}"/test || die
- TRAVIS=1 ./init-tests-after-clone.sh || die
- cat test/fixtures/.gitconfig >> ~/.gitconfig || die
- rm -r test/performance || die
- # tests requiring network access
- sed -i -e 's:test_fetch_error:_&:' test/test_remote.py || die
- sed -i -e 's:test_leaking_password_in_clone_logs:_&:' test/test_repo.py || die
- rm test/test_installation.py || die
-
- distutils-r1_src_test
-}
diff --git a/dev-python/GitPython/GitPython-3.1.17.ebuild b/dev-python/GitPython/GitPython-3.1.17.ebuild
deleted file mode 100644
index 058915920815..000000000000
--- a/dev-python/GitPython/GitPython-3.1.17.ebuild
+++ /dev/null
@@ -1,66 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{8..10} )
-PYTHON_REQ_USE="threads(+)"
-
-inherit distutils-r1
-
-TEST_P=GitPython-${PV}
-GITDB_P=gitdb-4.0.7
-SMMAP_P=smmap-4.0.0
-
-DESCRIPTION="Library used to interact with Git repositories"
-HOMEPAGE="https://github.com/gitpython-developers/GitPython https://pypi.org/project/GitPython/"
-SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz
- test? (
- https://dev.gentoo.org/~mgorny/dist/${TEST_P}.gitbundle
- https://dev.gentoo.org/~mgorny/dist/${GITDB_P}.gitbundle
- https://dev.gentoo.org/~mgorny/dist/${SMMAP_P}.gitbundle
- )"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86 ~amd64-linux ~x86-linux"
-
-RDEPEND="
- dev-vcs/git
- >=dev-python/gitdb-4.0.1[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '
- dev-python/typing-extensions[${PYTHON_USEDEP}]
- ' python3_7)"
-BDEPEND="
- test? (
- >=dev-python/ddt-1.1.1[${PYTHON_USEDEP}]
- )"
-
-distutils_enable_tests unittest
-
-src_test() {
- git config --global user.email "travis@ci.com" || die
- git config --global user.name "Travis Runner" || die
-
- git clone "${DISTDIR}/${TEST_P}.gitbundle" "${T}"/test || die
- git clone "${DISTDIR}/${GITDB_P}.gitbundle" \
- "${T}"/test/git/ext/gitdb || die
- git clone "${DISTDIR}/${SMMAP_P}.gitbundle" \
- "${T}"/test/git/ext/gitdb/gitdb/ext/smmap || die
-
- cd "${T}"/test || die
- git rev-parse HEAD > .git/refs/remotes/origin/master || die
- TRAVIS=1 ./init-tests-after-clone.sh || die
- cat test/fixtures/.gitconfig >> ~/.gitconfig || die
- rm -r test/performance || die
- # tests requiring network access
- sed -i -e 's:test_fetch_error:_&:' test/test_remote.py || die
- sed -i -e 's:test_leaking_password_in_clone_logs:_&:' test/test_repo.py || die
- # TODO
- sed -e 's:test_root_module:_&:' \
- -e 's:test_base_rw:_&:' \
- -i test/test_submodule.py || die
- rm test/test_installation.py || die
-
- distutils-r1_src_test
-}
diff --git a/dev-python/GitPython/Manifest b/dev-python/GitPython/Manifest
index deef82c425c8..54af7688d54b 100644
--- a/dev-python/GitPython/Manifest
+++ b/dev-python/GitPython/Manifest
@@ -1,10 +1,4 @@
-DIST GitPython-3.1.15.gitbundle 4811422 BLAKE2B 16399b302f7f3f36b315bcaa1535992a43b02fd888586d135824f8f4dc5ba611875d68e6d3102d71edc93848a91d3b244176d6b735ef30d65fdf64c28d325ef9 SHA512 13064036f20aaa58cf7784a3a61ed9c9e08414e9126332fc629e976889c87a2a70b1c9270774df676dcc08ded0ee3629112c60b88025536a9d13a04491b7b1e2
-DIST GitPython-3.1.15.tar.gz 175132 BLAKE2B 5a0cc8176257a5fec9afbf81351da191fc70ad5678d3ee89d36807cdf01a7f69216916723ac551bcc29fbc07a88a9a0357d12d41b4f43888917bd45dd766328e SHA512 bee1e12625995a0264694796ec6f346a5258ec13c24517939e65eaf9b679d82afb7848c02e6222389609bdf3a0dccbce4af1bd59a5d12f2851da47878a21b210
-DIST GitPython-3.1.17.gitbundle 9249795 BLAKE2B 2c647de0e335d58d85eb5444e52f93adb13c5e2cf9a6272fa26a7fd68bc1f467ab2134ee88a4386af03b9816cd568b7366a202480ab0fd7540202b5757a7caf3 SHA512 576082e3f6f741183392e3fa51c3ed0f3c6de668562f07ead14500644afe01ea5d667a1c30f3a111326b3bcb320b42eadfeefb9eeccb699cb19661b330321a6b
-DIST GitPython-3.1.17.tar.gz 178303 BLAKE2B cc4a89c6d5ab8ae59439286ed4159aa4e6cc936e5ef011eecae2ba79010eb13a2e7e79635e1f89bfbc32dc58e4a6f11c9bb13f164d8111178b3302a2780d599c SHA512 c87d9de510f245a64d9df68f0e5c07744eef21669ef3beb81f2d0aefe4299f1cb4cfd2d37b87120b21781aea06fa9f8b2ccbfda1f2648c92cd9c73506b953ed4
DIST GitPython-3.1.18.gitbundle 9129652 BLAKE2B df2ea8fa06d4209c532a239fa5bebde29314b467811526f67629f181a62b2b5ba235a3302b979dfd87993deca238a91820b3caa58fcb7cf3aaffc3bf76b0c731 SHA512 91fd937193db8a948fb575bf24a295c349e69b132128ed3b0c4fc3be89feb76ff47f31afe422c99ccbee4cf908b3040e9dd3f568db74785d12cf6cabbc356daa
DIST GitPython-3.1.18.tar.gz 181199 BLAKE2B ac50cee78b5980c6d23ec60786e8d279558a2740480e0975c212de8d96abd58da95de8d66bc9c7c3f0c7d1baa1757460f36df53552b06bd6323d3f882d0b90ae SHA512 981b3f4eec71c4e1de6efa2381c3c411aedfc51918f9f58f397926d21dabdfabb54d498ae44a5b6ceca59adf99e866df8d04f97a86df942e81408a5a0e751a15
-DIST gitdb-4.0.5-r1.gitbundle 1499071 BLAKE2B e429014def18d645b7117b27f592ead9c518076eeee2f6cc42c4a231f9a4f61c8275ccb1def5d042d44f34863528570163e9e154bb1536a0917b10f135e2462c SHA512 6fcf345af9f72afa39f4ba931bf474b2596678f1b790e3d4e1e3f7420baafbad04689bcdee9e99407f7c2b1c6f0d36fcf524b408ceb37b95dc4980e9423b1ad7
DIST gitdb-4.0.7.gitbundle 1498536 BLAKE2B 1e0aff67259c04d2932dbdefb0ae07bd9fb51c5dcb99ee8431e78bf428095250ed45f5e12e2484b407bb4257050b0864e67096b3501d4829491cb7714a7b5ddf SHA512 f8b1b3de00f0597d65f528dd30495fd3dd9e1e4d494987899ef2064d23947ede799db391a59688dfa27e4fcdc9379b5352a378b39e6fb2421e6c850f81157bec
-DIST smmap-3.0.4.gitbundle 276552 BLAKE2B 2d17b927b2c644d2f1984168ee99fe5a9a58392401ac0b2894a1d5e5f9c292f32311a7a5d7669bd93c642ff791f4801d61ef3236c1dafa1434e99a17fd8751f6 SHA512 6deb282c6ece3b556c59c458b5242ff362b903441db63c005a0ab1ac055b3f974f9b34f30e0a4a41ef9246696e08b191254f72db61a8f24d4eb2f0e48a08937b
DIST smmap-4.0.0.gitbundle 322820 BLAKE2B 20ac688cafa9ad036f3e21ac1bb9323ae55e618eb0806634fe4c885d2b12fe802779adcffb0fea3da9707e94109a168738d63abe990d1ce9b141c779aa6798d6 SHA512 03296099303eb38ac9ca46733255024355aed2e64a2f9409552ae34af76beb9685a6dd2458df986593fe426e428bc184617abe22c8b92ee01c8c7e1d98de8592