summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-01-01 15:20:30 +0100
committerMichał Górny <mgorny@gentoo.org>2020-01-01 17:04:06 +0100
commit5f408a70d9f007529d86f97a651d01c10aaa8e39 (patch)
treee190374ce38e769e7e148f4c6f4c35f12224a129
parentnet-misc/stuntman: Drop old (diff)
downloadgentoo-5f408a70.tar.gz
gentoo-5f408a70.tar.bz2
gentoo-5f408a70.zip
dev-python/setuptools: Bump to 43.0.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/setuptools/Manifest1
-rw-r--r--dev-python/setuptools/setuptools-43.0.0.ebuild77
2 files changed, 78 insertions, 0 deletions
diff --git a/dev-python/setuptools/Manifest b/dev-python/setuptools/Manifest
index e2ae22df030f..13b1b43bdac0 100644
--- a/dev-python/setuptools/Manifest
+++ b/dev-python/setuptools/Manifest
@@ -1,3 +1,4 @@
DIST setuptools-40.6.3.zip 839328 BLAKE2B ddc87213439ce2ad96ba54218bd5b3e41a7c31d670bddb9e4ea058b8ee7dffbe6fcb0e5fd24baf3fb38f5e824fde36aa8dc1e09d7ac37f9375ee351406389cd6 SHA512 6c628b8fc67645bca96ddcd016ec9a685e91690bf98dff077e842cfbd0d8d24de76ac51b3ff238d31551a48819d8f694fee6e9bb422ca954e54c22b4bda0038c
DIST setuptools-41.5.1.zip 851097 BLAKE2B 2411db77cffb24190c1510c7fab623ae0fb2a248994eae01e1a79427d35d8bf6a2f065de0d95dc11105df0bb42962a57c914486b48dc91115ec32e4dbcbc059d SHA512 eb6e944c80448873f8970477aaf474e75879e2b81b91fdc7a308670fed231d52880c3be3452e7ed3f094f20d4afe54b1db24ec4d98845ed47ee5e71dbf66261d
DIST setuptools-42.0.2.zip 858444 BLAKE2B 2b77dbeeb9a3b4138810a96fe7ac0a7800717b4b68d6e9db2d146ca176127d5bfd5e4ef07adfa98758f8c4d05396152ca08e1707caf3d91703c7b268bd291f28 SHA512 ab623fd69b92111d3ab19a3ad9de9c07b4316f4130f3db4068a436d3c13c971d97506f7307c9f64d9cc9ca24a5f3800b68748455e70418d0c0cd240c93ebae35
+DIST setuptools-43.0.0.zip 858857 BLAKE2B 763067560c7f9ee7e2e205eb2c8f215c0c82a5f0b40f3cae2d6a55024376196b478ac1fc44b5f6e4ca55a05d53c16e32b671e409d7d142042cc174fc92540a16 SHA512 bcd630e387784c14bc5427b7a99f7da2d46cca178c318d33a3b5be31b0315b6f957bdabfe85112ad3ffcd39442e654a3d80b609ee4cdac122a19597314f90714
diff --git a/dev-python/setuptools/setuptools-43.0.0.ebuild b/dev-python/setuptools/setuptools-43.0.0.ebuild
new file mode 100644
index 000000000000..417a3cbbded4
--- /dev/null
+++ b/dev-python/setuptools/setuptools-43.0.0.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+DISTUTILS_USE_SETUPTOOLS=no
+PYTHON_COMPAT=( python2_7 python3_{5,6,7,8} pypy{,3} )
+PYTHON_REQ_USE="xml(+)"
+
+inherit distutils-r1
+
+if [[ ${PV} == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/pypa/setuptools.git"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sh ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+fi
+
+DESCRIPTION="Collection of extensions to Distutils"
+HOMEPAGE="https://github.com/pypa/setuptools https://pypi.org/project/setuptools/"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ app-arch/unzip
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pip[${PYTHON_USEDEP}]
+ >=dev-python/pytest-3.7.0[${PYTHON_USEDEP}]
+ dev-python/pytest-fixture-config[${PYTHON_USEDEP}]
+ dev-python/pytest-virtualenv[${PYTHON_USEDEP}]
+ dev-python/wheel[${PYTHON_USEDEP}]
+ virtual/python-futures[${PYTHON_USEDEP}]
+ )
+"
+PDEPEND="
+ >=dev-python/certifi-2016.9.26[${PYTHON_USEDEP}]"
+
+# Force in-source build because build system modifies sources.
+DISTUTILS_IN_SOURCE_BUILD=1
+
+DOCS=( {CHANGES,README}.rst docs/{easy_install.txt,pkg_resources.txt,setuptools.txt} )
+
+PATCHES=(
+ # fix regression introduced by reinventing deprecated 'imp'
+ # https://github.com/pypa/setuptools/pull/1905
+ "${FILESDIR}"/setuptools-42.0.0-imp-fix.patch
+)
+
+python_prepare_all() {
+ if [[ ${PV} == "9999" ]]; then
+ python_setup
+ ${EPYTHON} bootstrap.py || die
+ fi
+
+ # disable tests requiring a network connection
+ rm setuptools/tests/test_packageindex.py || die
+
+ # don't run integration tests
+ rm setuptools/tests/test_integration.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ # test_easy_install raises a SandboxViolation due to ${HOME}/.pydistutils.cfg
+ # It tries to sandbox the test in a tempdir
+ HOME="${PWD}" pytest -vv ${PN} || die "Tests failed under ${EPYTHON}"
+}
+
+python_install() {
+ export DISTRIBUTE_DISABLE_VERSIONED_EASY_INSTALL_SCRIPT=1
+ distutils-r1_python_install
+}