summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-10-02 01:29:45 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-10-02 01:43:05 +0200
commit5f7bb23e33d15ad5e5d73fbe7d0543e9c76057f1 (patch)
tree6e753f31877d2ed3bb8c618acf4e738ca4d89bec
parentdev-libs/librevenge: EAPI-7 bump (diff)
downloadgentoo-5f7bb23e.tar.gz
gentoo-5f7bb23e.tar.bz2
gentoo-5f7bb23e.zip
app-text/libetonyek: Populate BDEPEND
Package-Manager: Portage-2.3.76, Repoman-2.3.17 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--app-text/libetonyek/libetonyek-9999.ebuild12
1 files changed, 7 insertions, 5 deletions
diff --git a/app-text/libetonyek/libetonyek-9999.ebuild b/app-text/libetonyek/libetonyek-9999.ebuild
index 5a2e3527e53a..9bea9ad25cf0 100644
--- a/app-text/libetonyek/libetonyek-9999.ebuild
+++ b/app-text/libetonyek/libetonyek-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-if [[ ${PV} = 9999 ]]; then
+if [[ ${PV} = *9999 ]]; then
EGIT_REPO_URI="https://anongit.freedesktop.org/git/libreoffice/libetonyek.git"
inherit autotools git-r3
else
@@ -17,6 +17,10 @@ LICENSE="|| ( GPL-2+ LGPL-2.1 MPL-1.1 )"
SLOT="0"
IUSE="doc static-libs test"
+BDEPEND="
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )
+"
RDEPEND="
app-text/liblangtag
dev-libs/librevenge
@@ -28,15 +32,13 @@ DEPEND="${RDEPEND}
dev-libs/boost
media-libs/glm
sys-devel/libtool
- virtual/pkgconfig
- doc? ( app-doc/doxygen )
test? ( dev-util/cppunit )
"
src_prepare() {
default
[[ -d m4 ]] || mkdir "m4"
- [[ ${PV} == 9999 ]] && eautoreconf
+ [[ ${PV} == *9999 ]] && eautoreconf
}
src_configure() {
@@ -57,5 +59,5 @@ src_configure() {
src_install() {
default
- find "${D}" -name '*.la' -delete || die
+ find "${D}" -name '*.la' -type f -delete || die
}