summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMo Zhou <cdluminate@gmail.com>2019-06-26 02:27:40 +0000
committerBenda Xu <heroxbd@gentoo.org>2019-06-26 14:06:09 +0800
commit5f8a985b71b033d7a7c4d252c00dd83669ee5913 (patch)
treefdc39acaec83bdc706d9ccbe0cc4a916bcf7d6f4
parentwww-servers/puma: add 4.0.0 (diff)
downloadgentoo-5f8a985b71b033d7a7c4d252c00dd83669ee5913.tar.gz
gentoo-5f8a985b71b033d7a7c4d252c00dd83669ee5913.tar.bz2
gentoo-5f8a985b71b033d7a7c4d252c00dd83669ee5913.zip
virtual/{blas,cblas,lapack,lapacke}: add/update virtual packages.
These virtual packages are used by the BLAS/LAPACK runtime switching mechanism. Drop old EAPI=5 ebuilds. Closes: https://github.com/gentoo/gentoo/pull/12323 Closes: https://bugs.gentoo.org/373613 Closes: https://bugs.gentoo.org/669644 Closes: https://bugs.gentoo.org/564546 Closes: https://bugs.gentoo.org/565776 Closes: https://bugs.gentoo.org/646316 Closes: https://bugs.gentoo.org/563674 Closes: https://bugs.gentoo.org/659014 Closes: https://bugs.gentoo.org/659264 Closes: https://bugs.gentoo.org/657984 Closes: https://bugs.gentoo.org/381801 Closes: https://bugs.gentoo.org/646316 Closes: https://bugs.gentoo.org/565776 Closes: https://bugs.gentoo.org/498490 Signed-off-by: Mo Zhou <cdluminate@gmail.com> Signed-off-by: Benda Xu <heroxbd@gentoo.org>
-rw-r--r--virtual/blas/blas-1.0.ebuild14
-rw-r--r--virtual/blas/blas-3.8.ebuild14
-rw-r--r--virtual/blas/metadata.xml10
-rw-r--r--virtual/cblas/cblas-1.0.ebuild14
-rw-r--r--virtual/cblas/cblas-3.8.ebuild14
-rw-r--r--virtual/cblas/metadata.xml10
-rw-r--r--virtual/lapack/lapack-3.0.ebuild13
-rw-r--r--virtual/lapack/lapack-3.1.ebuild13
-rw-r--r--virtual/lapack/lapack-3.8.ebuild14
-rw-r--r--virtual/lapack/metadata.xml10
-rw-r--r--virtual/lapacke/lapacke-3.8.ebuild14
-rw-r--r--virtual/lapacke/metadata.xml16
12 files changed, 93 insertions, 63 deletions
diff --git a/virtual/blas/blas-1.0.ebuild b/virtual/blas/blas-1.0.ebuild
deleted file mode 100644
index 83e7db925a5a..000000000000
--- a/virtual/blas/blas-1.0.ebuild
+++ /dev/null
@@ -1,14 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-DESCRIPTION="Virtual for FORTRAN 77 BLAS implementation"
-SLOT="0"
-KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~mips ppc ppc64 s390 sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris"
-
-RDEPEND="|| (
- sci-libs/blas-reference
- >=sci-libs/mkl-9.1.023
- sci-libs/blas-goto
- )"
diff --git a/virtual/blas/blas-3.8.ebuild b/virtual/blas/blas-3.8.ebuild
new file mode 100644
index 000000000000..e3807aaa8c4a
--- /dev/null
+++ b/virtual/blas/blas-3.8.ebuild
@@ -0,0 +1,14 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+DESCRIPTION="Virtual for FORTRAN 77 BLAS implementation"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris"
+IUSE="eselect-ldso"
+
+RDEPEND="
+ >=sci-libs/lapack-3.8.0[eselect-ldso?]
+"
+DEPEND="${RDEPEND}"
diff --git a/virtual/blas/metadata.xml b/virtual/blas/metadata.xml
index 1b4d6e817c05..35dd50fb4450 100644
--- a/virtual/blas/metadata.xml
+++ b/virtual/blas/metadata.xml
@@ -6,7 +6,11 @@
<name>Gentoo Science Project</name>
</maintainer>
<longdescription lang="en">
-Gentoo virtual package for the Basic Linear Algebra Subprograms
-FORTRAN 77 implementation.
-</longdescription>
+ Gentoo virtual package for the Basic Linear Algebra Subprograms
+ FORTRAN 77 implementation.
+ </longdescription>
+ <use>
+ <flag name="eselect-ldso">Enable runtime library switching by
+ eselect and ld.so.</flag>
+ </use>
</pkgmetadata>
diff --git a/virtual/cblas/cblas-1.0.ebuild b/virtual/cblas/cblas-1.0.ebuild
deleted file mode 100644
index 4d8381244936..000000000000
--- a/virtual/cblas/cblas-1.0.ebuild
+++ /dev/null
@@ -1,14 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-DESCRIPTION="Virtual for BLAS C implementation"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 s390 sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
-
-RDEPEND="|| (
- sci-libs/cblas-reference
- sci-libs/gsl[-cblas-external]
- >=sci-libs/mkl-9.1.023
- )"
diff --git a/virtual/cblas/cblas-3.8.ebuild b/virtual/cblas/cblas-3.8.ebuild
new file mode 100644
index 000000000000..0b295963f8de
--- /dev/null
+++ b/virtual/cblas/cblas-3.8.ebuild
@@ -0,0 +1,14 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+DESCRIPTION="Virtual for BLAS C implementation"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="eselect-ldso"
+
+RDEPEND="
+ >=sci-libs/lapack-3.8.0[eselect-ldso?]
+"
+DEPEND="${RDEPEND}"
diff --git a/virtual/cblas/metadata.xml b/virtual/cblas/metadata.xml
index 9aac1c20c93f..204ea7552ca9 100644
--- a/virtual/cblas/metadata.xml
+++ b/virtual/cblas/metadata.xml
@@ -6,7 +6,11 @@
<name>Gentoo Science Project</name>
</maintainer>
<longdescription lang="en">
-Gentoo virtual package for the Basic Linear Algebra Subprograms
-C implementation.
-</longdescription>
+ Gentoo virtual package for the Basic Linear Algebra Subprograms
+ C implementation.
+ </longdescription>
+ <use>
+ <flag name="eselect-ldso">Enable runtime library switching by
+ eselect and ld.so.</flag>
+ </use>
</pkgmetadata>
diff --git a/virtual/lapack/lapack-3.0.ebuild b/virtual/lapack/lapack-3.0.ebuild
deleted file mode 100644
index 38d1fae658da..000000000000
--- a/virtual/lapack/lapack-3.0.ebuild
+++ /dev/null
@@ -1,13 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-DESCRIPTION="Virtual for Linear Algebra Package FORTRAN 77 (LAPACK) implementation"
-SLOT="0"
-KEYWORDS="alpha amd64 hppa ia64 ppc ppc64 sparc x86 ~x86-fbsd"
-
-RDEPEND="|| (
- sci-libs/lapack-reference
- >=sci-libs/mkl-9.1.023
- )"
diff --git a/virtual/lapack/lapack-3.1.ebuild b/virtual/lapack/lapack-3.1.ebuild
deleted file mode 100644
index 30d27aba4b40..000000000000
--- a/virtual/lapack/lapack-3.1.ebuild
+++ /dev/null
@@ -1,13 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-DESCRIPTION="Virtual for Linear Algebra Package FORTRAN 77 (LAPACK) implementation"
-SLOT="0"
-KEYWORDS="alpha amd64 arm arm64 hppa ia64 ppc ppc64 s390 sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
-
-RDEPEND="|| (
- >=sci-libs/lapack-reference-3.1
- >=sci-libs/mkl-10
- )"
diff --git a/virtual/lapack/lapack-3.8.ebuild b/virtual/lapack/lapack-3.8.ebuild
new file mode 100644
index 000000000000..93ddd49d8b79
--- /dev/null
+++ b/virtual/lapack/lapack-3.8.ebuild
@@ -0,0 +1,14 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Virtual for Linear Algebra Package FORTRAN 77 (LAPACK) implementation"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="eselect-ldso"
+
+RDEPEND="
+ >=sci-libs/lapack-3.8.0[eselect-ldso?]
+"
+DEPEND="${RDEPEND}"
diff --git a/virtual/lapack/metadata.xml b/virtual/lapack/metadata.xml
index ccb7a1fa1fad..0b91d851efe1 100644
--- a/virtual/lapack/metadata.xml
+++ b/virtual/lapack/metadata.xml
@@ -6,7 +6,11 @@
<name>Gentoo Science Project</name>
</maintainer>
<longdescription lang="en">
-Gentoo virtual package for the Linear Algebra PACKAge
-FORTRAN 77 implementation.
-</longdescription>
+ Gentoo virtual package for the Linear Algebra PACKAge
+ FORTRAN 77 implementation.
+ </longdescription>
+ <use>
+ <flag name="eselect-ldso">Enable runtime library switching by
+ eselect and ld.so.</flag>
+ </use>
</pkgmetadata>
diff --git a/virtual/lapacke/lapacke-3.8.ebuild b/virtual/lapacke/lapacke-3.8.ebuild
new file mode 100644
index 000000000000..fc61bf733e2e
--- /dev/null
+++ b/virtual/lapacke/lapacke-3.8.ebuild
@@ -0,0 +1,14 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Virtual for LAPACK C implementation"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="eselect-ldso"
+
+RDEPEND="
+ >=sci-libs/lapack-3.8.0[lapacke,eselect-ldso?]
+"
+DEPEND="${RDEPEND}"
diff --git a/virtual/lapacke/metadata.xml b/virtual/lapacke/metadata.xml
new file mode 100644
index 000000000000..299f0ab2ab69
--- /dev/null
+++ b/virtual/lapacke/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+ <longdescription lang="en">
+ Gentoo virtual package for the Linear Algebra PACKAge C
+ implementation.
+ </longdescription>
+ <use>
+ <flag name="eselect-ldso">Enable runtime library switching by
+ eselect and ld.so.</flag>
+ </use>
+</pkgmetadata>