summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2020-11-29 02:28:22 +0100
committerConrad Kostecki <conikost@gentoo.org>2020-11-29 02:32:26 +0100
commit5f9219dac9d0235d4d7399f9004461eb248ac162 (patch)
treed5d30167808bd172522a238912dcaf038288b0af
parentdev-lua/luacheck: add keywords and update deps (diff)
downloadgentoo-5f9219da.tar.gz
gentoo-5f9219da.tar.bz2
gentoo-5f9219da.zip
dev-lua/luacheck: drop old version
Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
-rw-r--r--dev-lua/luacheck/luacheck-0.23.0.ebuild54
1 files changed, 0 insertions, 54 deletions
diff --git a/dev-lua/luacheck/luacheck-0.23.0.ebuild b/dev-lua/luacheck/luacheck-0.23.0.ebuild
deleted file mode 100644
index bfdbe93ecb29..000000000000
--- a/dev-lua/luacheck/luacheck-0.23.0.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-inherit toolchain-funcs
-
-DESCRIPTION="A tool for linting and static analysis of Lua code"
-HOMEPAGE="https://github.com/mpeterv/luacheck"
-SRC_URI="https://github.com/mpeterv/luacheck/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~ppc64"
-IUSE="doc luajit test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- dev-lua/lua-argparse[luajit=]
- dev-lua/luafilesystem[luajit(-)=]
- dev-lua/lua-utf8[luajit=]
- !luajit? ( >=dev-lang/lua-5.1:= )
- luajit? ( dev-lang/luajit:2 )"
-BDEPEND="
- virtual/pkgconfig
- doc? ( dev-python/sphinx )
- test? (
- ${RDEPEND}
- dev-lua/busted
- )"
-DEPEND="${RDEPEND}"
-
-src_compile() {
- if use doc; then
- sphinx-build docsrc html || die
- fi
-}
-
-src_test() {
- busted -o gtest || die
-}
-
-src_install() {
- local instdir
- instdir="$($(tc-getPKG_CONFIG) --variable INSTALL_LMOD $(usex luajit 'luajit' 'lua'))"
- insinto "${instdir#${EPREFIX}}"
- doins -r src/luacheck
-
- newbin bin/luacheck.lua luacheck
-
- use doc && local HTML_DOCS=( html/. )
-
- local -a DOCS=( CHANGELOG.md LICENSE README.md )
- einstalldocs
-}