summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexander Tsoy <alexander@tsoy.me>2020-12-30 02:33:03 +0300
committerMiroslav Šulc <fordfrog@gentoo.org>2020-12-30 07:28:06 +0100
commit5fa7cef1adf33b14e9487c59429079a50388e353 (patch)
tree55ca1ab5b7ce3d99959b947a9afe1a7b4f21fbdd
parentmedia-sound/guitarix: Version bump to 0.42.1 (diff)
downloadgentoo-5fa7cef1.tar.gz
gentoo-5fa7cef1.tar.bz2
gentoo-5fa7cef1.zip
media-sound/guitarix: Update live ebuild
* EAPI 7 bump * reorganize dependencies * support python3.9 Signed-off-by: Alexander Tsoy <alexander@tsoy.me> Closes: https://github.com/gentoo/gentoo/pull/18874 Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
-rw-r--r--media-sound/guitarix/guitarix-9999.ebuild24
1 files changed, 14 insertions, 10 deletions
diff --git a/media-sound/guitarix/guitarix-9999.ebuild b/media-sound/guitarix/guitarix-9999.ebuild
index 1f66e9647b1f..5bd6d0e7b8af 100644
--- a/media-sound/guitarix/guitarix-9999.ebuild
+++ b/media-sound/guitarix/guitarix-9999.ebuild
@@ -1,9 +1,9 @@
# Copyright 2019-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-PYTHON_COMPAT=( python3_{6,7,8} )
+PYTHON_COMPAT=( python3_{6,7,8,9} )
PYTHON_REQ_USE='threads(+)'
inherit python-any-r1 waf-utils xdg git-r3
@@ -21,7 +21,8 @@ KEYWORDS=""
IUSE="bluetooth debug lv2 nls nsm +standalone zeroconf"
REQUIRED_USE="|| ( lv2 standalone )"
-COMMON_DEPEND="dev-cpp/eigen:3
+DEPEND="
+ dev-cpp/eigen:3
dev-cpp/glibmm:2
dev-cpp/gtkmm:3.0
dev-libs/glib:2
@@ -29,7 +30,7 @@ COMMON_DEPEND="dev-cpp/eigen:3
>=media-libs/zita-convolver-3:=
media-libs/zita-resampler
>=net-misc/curl-7.26.0
- >=sci-libs/fftw-3.1.2:3.0=
+ >=sci-libs/fftw-3.3.8:3.0=
x11-libs/gtk+:3
lv2? ( media-libs/lv2 )
standalone? (
@@ -43,18 +44,21 @@ COMMON_DEPEND="dev-cpp/eigen:3
)
"
# roboto fonts are required for correct ui rendering
-RDEPEND="${COMMON_DEPEND}
+RDEPEND="
+ ${DEPEND}
standalone? (
media-fonts/roboto
)
"
-DEPEND="${COMMON_DEPEND}
+BDEPEND="
${PYTHON_DEPS}
- dev-lang/sassc
virtual/pkgconfig
- nls? (
- dev-util/intltool
- sys-devel/gettext
+ standalone? (
+ dev-lang/sassc
+ nls? (
+ dev-util/intltool
+ sys-devel/gettext
+ )
)
"