summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-03-09 17:10:23 +0100
committerMichał Górny <mgorny@gentoo.org>2018-03-09 17:14:15 +0100
commit5fa9f8aaffeef3b0fb2cb75bde0b49dd9f355d63 (patch)
tree8ec06da99a8257a09c816db3f3c1f04952ea80e6
parentnet-misc/asterisk: 13.19.2 for CVE-2018-7284 & CVE-2018-7286 (diff)
downloadgentoo-5fa9f8aaffeef3b0fb2cb75bde0b49dd9f355d63.tar.gz
gentoo-5fa9f8aaffeef3b0fb2cb75bde0b49dd9f355d63.tar.bz2
gentoo-5fa9f8aaffeef3b0fb2cb75bde0b49dd9f355d63.zip
sys-libs/llvm-libunwind: Correct test dependencies
-rw-r--r--sys-libs/llvm-libunwind/llvm-libunwind-6.0.0.ebuild5
-rw-r--r--sys-libs/llvm-libunwind/llvm-libunwind-6.0.9999.ebuild5
-rw-r--r--sys-libs/llvm-libunwind/llvm-libunwind-9999.ebuild5
3 files changed, 12 insertions, 3 deletions
diff --git a/sys-libs/llvm-libunwind/llvm-libunwind-6.0.0.ebuild b/sys-libs/llvm-libunwind/llvm-libunwind-6.0.0.ebuild
index 45ca2b2e5f9f..db6bc3cacf89 100644
--- a/sys-libs/llvm-libunwind/llvm-libunwind-6.0.0.ebuild
+++ b/sys-libs/llvm-libunwind/llvm-libunwind-6.0.0.ebuild
@@ -25,10 +25,13 @@ RESTRICT="!test? ( test )"
RDEPEND="!sys-libs/libunwind"
# llvm-6 for new lit options
+# tests need libcxx with implicit -lunwind and libcxxabi
+# (but libcxx does not need to be built against it)
DEPEND="
>=sys-devel/llvm-6
test? (
- sys-libs/libcxx[${MULTILIB_USEDEP}]
+ sys-libs/libcxx[libunwind,${MULTILIB_USEDEP}]
+ sys-libs/libcxxabi
$(python_gen_any_dep 'dev-python/lit[${PYTHON_USEDEP}]') )"
S=${WORKDIR}/${MY_P}
diff --git a/sys-libs/llvm-libunwind/llvm-libunwind-6.0.9999.ebuild b/sys-libs/llvm-libunwind/llvm-libunwind-6.0.9999.ebuild
index 789d9a6d71c7..6eb95d733fc2 100644
--- a/sys-libs/llvm-libunwind/llvm-libunwind-6.0.9999.ebuild
+++ b/sys-libs/llvm-libunwind/llvm-libunwind-6.0.9999.ebuild
@@ -24,10 +24,13 @@ RESTRICT="!test? ( test )"
RDEPEND="!sys-libs/libunwind"
# llvm-6 for new lit options
+# tests need libcxx with implicit -lunwind and libcxxabi
+# (but libcxx does not need to be built against it)
DEPEND="
>=sys-devel/llvm-6
test? (
- sys-libs/libcxx[${MULTILIB_USEDEP}]
+ sys-libs/libcxx[libunwind,${MULTILIB_USEDEP}]
+ sys-libs/libcxxabi
$(python_gen_any_dep 'dev-python/lit[${PYTHON_USEDEP}]') )"
# least intrusive of all
diff --git a/sys-libs/llvm-libunwind/llvm-libunwind-9999.ebuild b/sys-libs/llvm-libunwind/llvm-libunwind-9999.ebuild
index c16358fe4c62..387b8c31086c 100644
--- a/sys-libs/llvm-libunwind/llvm-libunwind-9999.ebuild
+++ b/sys-libs/llvm-libunwind/llvm-libunwind-9999.ebuild
@@ -23,10 +23,13 @@ RESTRICT="!test? ( test )"
RDEPEND="!sys-libs/libunwind"
# llvm-6 for new lit options
+# tests need libcxx with implicit -lunwind and libcxxabi
+# (but libcxx does not need to be built against it)
DEPEND="
>=sys-devel/llvm-6
test? (
- sys-libs/libcxx[${MULTILIB_USEDEP}]
+ sys-libs/libcxx[libunwind,${MULTILIB_USEDEP}]
+ sys-libs/libcxxabi
$(python_gen_any_dep 'dev-python/lit[${PYTHON_USEDEP}]') )"
# least intrusive of all