summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-07-02 12:41:03 +0000
committerSam James <sam@gentoo.org>2022-07-02 12:41:03 +0000
commit5faad6a505dc25262ff894805bfae514df4fba8f (patch)
tree7326fc97702c0f6ccb68942beff1bfc57029c70d
parentnet-misc/openvswitch: MODULES_OPTIONAL_USE is preinherit (diff)
downloadgentoo-5faad6a505dc25262ff894805bfae514df4fba8f.tar.gz
gentoo-5faad6a505dc25262ff894805bfae514df4fba8f.tar.bz2
gentoo-5faad6a505dc25262ff894805bfae514df4fba8f.zip
net-misc/curl: backport include fix
Closes: https://bugs.gentoo.org/855710 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--net-misc/curl/curl-7.84.0.ebuild1
-rw-r--r--net-misc/curl/files/curl-7.84.0-include-sched.patch24
2 files changed, 25 insertions, 0 deletions
diff --git a/net-misc/curl/curl-7.84.0.ebuild b/net-misc/curl/curl-7.84.0.ebuild
index 7ea18d7d53d0..7e08867a5200 100644
--- a/net-misc/curl/curl-7.84.0.ebuild
+++ b/net-misc/curl/curl-7.84.0.ebuild
@@ -96,6 +96,7 @@ MULTILIB_CHOST_TOOLS=(
PATCHES=(
"${FILESDIR}"/${PN}-7.30.0-prefix.patch
"${FILESDIR}"/${PN}-respect-cflags-3.patch
+ "${FILESDIR}"/${PN}-7.84.0-include-sched.patch
)
src_prepare() {
diff --git a/net-misc/curl/files/curl-7.84.0-include-sched.patch b/net-misc/curl/files/curl-7.84.0-include-sched.patch
new file mode 100644
index 000000000000..842310d2eaab
--- /dev/null
+++ b/net-misc/curl/files/curl-7.84.0-include-sched.patch
@@ -0,0 +1,24 @@
+https://github.com/curl/curl/commit/e2e7f54b7bea521fa8373095d0f43261a720cda0
+https://bugs.gentoo.org/855710
+
+From e2e7f54b7bea521fa8373095d0f43261a720cda0 Mon Sep 17 00:00:00 2001
+From: Daniel Stenberg <daniel@haxx.se>
+Date: Mon, 27 Jun 2022 08:46:21 +0200
+Subject: [PATCH] easy_lock.h: include sched.h if available to fix build
+
+Patched-by: Harry Sintonen
+
+Closes #9054
+--- a/lib/easy_lock.h
++++ b/lib/easy_lock.h
+@@ -36,6 +36,9 @@
+
+ #elif defined (HAVE_ATOMIC)
+ #include <stdatomic.h>
++#if defined(HAVE_SCHED_YIELD)
++#include <sched.h>
++#endif
+
+ #define curl_simple_lock atomic_bool
+ #define CURL_SIMPLE_LOCK_INIT false
+