summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-01-13 14:26:00 -0800
committerMatt Turner <mattst88@gentoo.org>2022-01-13 14:33:43 -0800
commit5fc133a1f632ed81b3cfd3e4747196f3019a3353 (patch)
tree4740e419108ccee32bea098384197081da046038
parentgnome-base/nautilus: Version bump to 41.2 (diff)
downloadgentoo-5fc133a1f632ed81b3cfd3e4747196f3019a3353.tar.gz
gentoo-5fc133a1f632ed81b3cfd3e4747196f3019a3353.tar.bz2
gentoo-5fc133a1f632ed81b3cfd3e4747196f3019a3353.zip
gnome-extra/gnome-boxes: Version bump to 41.3
Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rw-r--r--gnome-extra/gnome-boxes/Manifest1
-rw-r--r--gnome-extra/gnome-boxes/gnome-boxes-41.3.ebuild129
2 files changed, 130 insertions, 0 deletions
diff --git a/gnome-extra/gnome-boxes/Manifest b/gnome-extra/gnome-boxes/Manifest
index 93097b28c300..ec5cd70934d7 100644
--- a/gnome-extra/gnome-boxes/Manifest
+++ b/gnome-extra/gnome-boxes/Manifest
@@ -1,2 +1,3 @@
DIST gnome-boxes-40.3.tar.xz 1697444 BLAKE2B a7c1677224dde80142abdeeff8b99929c7b86ce38a3432bf0368ec93146df0a813cbeae033fc8cbcd2fb8cd5b28170e0385224f36a9517ed54244e94a3453b6c SHA512 1944414feb6fab054f46e32b5f245042c882cf0a1ecde0eafced81adda16af1018203139177d3f9fa1d2eaf1565ee9e3b3fdff63c4a4b06b0802e20a2f064890
DIST gnome-boxes-41.2.tar.xz 1614708 BLAKE2B 9896d558951d36d60843e8e4bc237007b7917fe6cd672e6af0d801de1b8a44cefe5098666b5bce95b8aebf4c4cd4ebbbe5ec6c94d88dfeff54216f524554ba66 SHA512 ef14d4bfeb3202664bb96047de5656295f0186121599bf7a82184f4815e956e18f5ce60d0a45ec6e405ec4d22134cc4138018f0d3f86b8372303c0c639751803
+DIST gnome-boxes-41.3.tar.xz 1614656 BLAKE2B 1d2a53ba833cdf130f1b2a350871344b0fd4c3f223e069d707e8279748a2fbd21e0d618d0cb229bb3bcfaa84e41d32da763df1d84efd7b749d890f28aceae904 SHA512 6aa8daf03898b7ec28397897b054e220bf2eabb7acbf4ea4dab7035bbe24e44c8a75e488c788f2b8cc56d6e72785651574cffa84cc1a06e5c9c7e0772839bfe7
diff --git a/gnome-extra/gnome-boxes/gnome-boxes-41.3.ebuild b/gnome-extra/gnome-boxes/gnome-boxes-41.3.ebuild
new file mode 100644
index 000000000000..a2108ec7a02c
--- /dev/null
+++ b/gnome-extra/gnome-boxes/gnome-boxes-41.3.ebuild
@@ -0,0 +1,129 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+VALA_USE_DEPEND="vapigen"
+VALA_MIN_API_VERSION="0.40"
+
+inherit gnome.org gnome2-utils linux-info meson readme.gentoo-r1 vala xdg
+
+DESCRIPTION="Simple GNOME application to access remote or virtual systems"
+HOMEPAGE="https://wiki.gnome.org/Apps/Boxes"
+
+LICENSE="LGPL-2+ CC-BY-2.0"
+SLOT="0"
+
+IUSE="rdp"
+KEYWORDS="~amd64"
+
+# FIXME: qemu probably needs to depend on spice[smartcard] directly with USE=spice
+# FIXME: Check over libvirt USE=libvirtd,qemu and the smartcard/usbredir requirements
+# Technically vala itself still ships a libsoup vapi, but that may change, and it should be better to use the .vapi from the same libsoup version
+# gtk-vnc raised due to missing vala bindings in earlier ebuilds
+DEPEND="
+ >=app-arch/libarchive-3.0.0:=
+ >=dev-libs/glib-2.52:2
+ >=x11-libs/gtk+-3.24.1:3
+ >=net-libs/gtk-vnc-0.8.0-r1[gtk3(+)]
+ x11-libs/gtksourceview:4
+ >=sys-libs/libosinfo-1.7.0
+ app-crypt/libsecret
+ >=net-libs/libsoup-2.44:2.4
+ virtual/libusb:1
+ >=app-emulation/libvirt-glib-4.0.0
+ >=dev-libs/libxml2-2.7.8:2
+ >=net-misc/spice-gtk-0.32[gtk3(+),smartcard,usbredir]
+ app-misc/tracker:3
+ >=net-libs/webkit-gtk-2.26.0:4
+ >=gui-libs/libhandy-1.0.0:1=
+
+ >=dev-libs/gobject-introspection-1.56:=
+ >=dev-libs/libgudev-165:=
+ rdp? ( >=net-misc/freerdp-2.0.0:= )
+" # gobject-introspection needed for libovf subproject (and gtk-frdp subproject with USE=rdp)
+# These are called via exec():
+# sys-fs/mtools mcopy for unattended file copying for files that libarchive doesn't support
+# app-cdr/cdrtools mkisofs is needed for unattended installer secondary disk image creation
+# app-emulation/libguestfs virt-sysprep is used for VM cloing, if not there, it logs debug and doesn't function
+# sys-apps/policycoreutils restorecon is used for checking selinux context
+# app-emulation/libvirt virsh used for various checks (and we need the library anyways)
+# sys-auth/polkit used for making all libvirt system disks readable via "pkexec chmod a+r" that aren't already readable to the user (libvirt system importer)
+# app-emulation/qemu qemu-img used to convert image to QCOW2 format during copy
+RDEPEND="${DEPEND}
+ app-cdr/cdrtools
+ app-misc/tracker-miners:3[iso]
+ app-emulation/spice[smartcard]
+ >=app-emulation/libvirt-0.9.3[libvirtd,qemu]
+ >=app-emulation/qemu-1.3.1[spice,smartcard,usbredir]
+ sys-fs/mtools
+ sys-auth/polkit
+"
+# gtk-frdp generates gir and needs gtk+ introspection for it
+# This is only needed for creating the .vapi file, but gnome-boxes needs it
+BDEPEND="
+ $(vala_depend)
+ net-libs/gtk-vnc[vala]
+ sys-libs/libosinfo[vala]
+ app-crypt/libsecret[vala]
+ net-libs/libsoup:2.4[vala]
+ app-emulation/libvirt-glib[vala]
+ net-misc/spice-gtk[vala]
+ x11-libs/vte:2.91[vala]
+ dev-libs/appstream-glib
+ rdp? ( x11-libs/gtk+:3[introspection] )
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+DISABLE_AUTOFORMATTING="yes"
+DOC_CONTENTS="Before running gnome-boxes for local VMs, you will need to load the KVM modules.
+If you have an Intel Processor, run:
+# modprobe kvm-intel
+
+If you have an AMD Processor, run:
+# modprobe kvm-amd"
+
+pkg_pretend() {
+ linux-info_get_any_version
+
+ if linux_config_exists; then
+ if ! { linux_chkconfig_present KVM_AMD || \
+ linux_chkconfig_present KVM_INTEL; }; then
+ ewarn "You need KVM support in your kernel to use GNOME Boxes local VM support!"
+ fi
+ fi
+}
+
+src_prepare() {
+ xdg_src_prepare
+ vala_src_prepare
+}
+
+src_configure() {
+ local emesonargs=(
+ -Ddistributor_name=Gentoo
+ -Ddistributor_version=${PVR}
+ $(meson_use rdp)
+ -Dinstalled_tests=false
+ -Dflatpak=false
+ -Dprofile=default
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+ readme.gentoo_print_elog
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}